Страницы: 1
RSS
Подставление значения в ячейку в зависимости от цвета заливки другой яейки
 
Добрый день! Возможно ли как-то формулами или макросом подставлять значение в ячейку в зависимости от того, какой цвет в ячейке рядом?
Есть столбец №1, в котором часть ячеек пользователем закрашивается. В столбце №2 в соответствующие ячейки подставляется некий текст.
Например, ячейка А1 зелёная - в ячейке B1 появляется текст "Номер 1", ячейка А2 синяя - в ячейке B2 появляется текст "Номер 2" и т.д. в зависимости от цвета ячейки в столбце №1.
Думаю что это должно быть Если ячейка.диапазон.Цвет=16тиричный код, тогда Ячейка.Диапазон="Текст" и так далее пока закрашенные ячейки не кончатся
 
Добрый вечер! UDF
Код
Public Function ЦВЕТЗАЛИВКИ(ЯЧЕЙКА As Range) As Double
    ЦВЕТЗАЛИВКИ = ЯЧЕЙКА.Interior.Color
End Function

Пример формулы: = ЕСЛИ(ЦВЕТЗАЛИВКИ(A1)=1234567890;"Номер 1";"")

 
Цитата
написал:
Добрый вечер! UDF
Код
    [URL=#]?[/URL]       1  2  3      Public   Function   ЦВЕТЗАЛИВКИ(ЯЧЕЙКА   As   Range)   As   Double          ЦВЕТЗАЛИВКИ = ЯЧЕЙКА.Interior.Color    End   Function   
   Пример формулы:  = ЕСЛИ(ЦВЕТЗАЛИВКИ(A1)=1234567890;"Номер 1";"")    
Огромное спасибо ))
Страницы: 1
Читают тему (гостей: 1)
Наверх