Страницы: 1
RSS
Поиск по несольким условиям (цифры и текст) для Excel 2003, поиск по диапазону с условиями
 
Здравствуйте.
Помогите с формулой, для Excel 2003, производящей поиск по диапазону с несколькими условиями, включающими как цифры, так и текст в строках и в столбцах.
Пример с таблицами и пояснениями во вложении.
 
Здравствуйте
Если правильно понял, вопрос что нужно, не нашел :)

Подправил таблицу, заполнил все ячейки в объединенных ячейках. Это можно обойти формулой, но лень вспоминать
=SUMPRODUCT(($D$21:$G$21=D$37)*($C$22:$C$33=$C38)*($B$22:$B$33=$B38)*$D$22:$G$33)
в Excel возможно нужно вводить как массивные
 
bigorq, Спасибо. В Excel 2003 работает без (Ctrl+Shift+Enter).
Столько дней пробовал решить задачу разными формулами, что даже и не заметил ошибку в первой, которая могла бы устроить.
P.S. Если вспомните формулу, обходящую необходимость вводить ссылки в каждую ячейку объединенных строк - буду очень признателен.
 
Дополненная формула от bigorq, для работы с объединенными ячейками.
=SUMPRODUCT(($D$21:$G$21=D$37)*($C$22:$C$33=$C38)*(LOOKUP(ROW($B$22:$B$33);ROW($B$22:$B$33)/($B$22:$B$33>0);$B$22:$B$33)=$B38)*$D$22:$G$33)
 
memo, Спасибо.
=СУММПРОИЗВ(($D$21:$G$21=D$37)*($C$22:$C$33=$C38)*(ПРОСМОТР(СТРОКА($B$22:$B$33);СТРОКА($B$22:$B$33)/($B$22:$B$33>0);$B$22:$B$33)=$B38)*$D$22:$G$33)
Страницы: 1
Читают тему (гостей: 1)
Наверх