Страницы: 1
RSS
СТАЖ РАБОТНИКИ, Расчет стажа общий, педагогический, стаж в МБДОУ
 
Добрый день. Помогите пожалуйста рассчитать стаж. Ни как не могу задать формулу. :)  
 
Код
=РАЗНДАТ(C2;T2;"y")&" г. "&РАЗНДАТ(C2;T2;"ym")&" мес. "&РАЗНДАТ(C2;T2;"md")&" дн."

Если на сегодняшний день, то
Код
=РАЗНДАТ(C2;СЕГОДНЯ();"y")&" г. "&РАЗНДАТ(C2;СЕГОДНЯ();"ym")&" мес. "&РАЗНДАТ(C2;СЕГОДНЯ();"md")&" дн."
Скажи мне, кудесник, любимец ба’гов...

 
Стаж получается высчитывает не тот больше становится.
 
В днях это будет вот столько
Код
=СУММПРОИЗВ(D2:T2-C2:S2)

А вот как Вы это будете переводить в год-месяц-день - это уже смотрите сами

Приведу простой пример:

1. Я отработал ранее 30 дней - с 01,03,2020 по 30,03,2020. И на текущей работе я отработал 1 день. Сколько всего в формате "г.м.д"? 01,03,2020 + 30 дней + 1 день = 31,03,2020. Итого получаем 0г.00м.31д

2. Я отработал ранее 30 дней - с 01,04,2020 по 30,04,2020. И на текущей работе я отработал 1 день. Сколько всего в формате "г.м.д"? 01,04,2020 + 30 дней + 1 день = 01,05,2020. Итого получаем 0г.01м.01д

И это я еще только с днями пример привел. Если полную дату брать, то все еще больше запутывается. Да еще високосные года если учитывать...
Это я к тому, что нужно быть готовым к ситуации, когда работник оспорит правильность расчетов - ведь, по идее, они оба правильны
Скажи мне, кудесник, любимец ба’гов...

 
У меня получается например выходит по формуле 27 лет. А считаю 21 год. тут то большая разница. я может не правильно формулу вбиваю. Уже несколько раз вводила получается 27 лет и всё тут. :)  
 
Цитата
Лия написал:
Уже несколько раз вводила
если бы привели данные, которые считаете, мы могли бы проверить, а так только посочувствовать
 
Вот так получается.
 
Все правильно считает, чтобы было 21 вам нужно складывать каждый отрезок, а вы первую и крайнюю дату только считаете
 
Вот так попробуйте
=РАЗНДАТ(C2;C2+СУММПРОИЗВ((D2:T2-C2:S2+1)*ЕЧЁТН(СТОЛБЕЦ(D2:T2)));"y")&" г. "&РАЗНДАТ(C2;C2+СУММПРОИЗВ((D2:T2-C2:S2+1)*ЕЧЁТН(СТОЛБЕЦ(D2:T2)));"ym")&" мес. "&РАЗНДАТ(C2;C2+СУММПРОИЗВ((D2:T2-C2:S2+1)*ЕЧЁТН(СТОЛБЕЦ(D2:T2)));"md")&" дн."

Но это не совсем верно. Вернее, не обязательно будет верно, +- пару дней люфт. Выше я написал, почему
Изменено: _Boroda_ - 28.11.2022 10:03:04
Скажи мне, кудесник, любимец ба’гов...

 
Спасибо огромное))) А то я в формулах не сильна.
Страницы: 1
Читают тему (гостей: 1)
Наверх