Страницы: 1
RSS
Выбрать данные из массива хронологически (помесячно) в обратном порядке при заданном параметре.
 
Добрый день. Прошу помочь.
Имеется таблица 1.... в строках производимые номенклатуры в столбцах помесячно за 2 года значения расходов распределенных на данную номенклатуру. При этом значения присутствуют не везде!
Есть другой перечень (таблица 2), в который надо затянуть из таблицы 1  (база данных по расходам за 2 года) показатель расходов по номенклатуре. Необходимо составить формулу, которая выберет для данной номенклатуры последнее имеющееся значение. Например в декабре данная номенклатура не была реализована, на нее расходы не распределялись, в ячейке 0. Но в ноябре реализована была, расходы распределены необходимо выбрать данные ноября. И так далее, не было в ноябре, проверь сентябрь, не было в сентябре проверь август. И так 24 месяца в обратном порядке. С учетом того, что перечень номенклатур 800 шт. вручную выбирать не представляется возможным, необходимо чтобы подтягивалось последнее по дате имеющееся значение. Перечень в таблице 2 меняется еженедельно. А таблица 1 имеет постоянные значения. Вроде просто, но сама не справляюсь. Помогите новичку!
Изменено: Алла Акифьева - 25.01.2023 10:23:33
 
Добрый вечер!
Почему вопрос в "Курилке"? Где Ваш файл?
 
Доброе утро. Файл прикрепила. Извините, что в курилку. Могу перекинуть в другую тему.... ?
 
=ЕСЛИОШИБКА(ПРОСМОТР(;-1/(ИНДЕКС('Затраты распределенные на ед.'!$B$3:$B$504;ПОИСКПОЗ(B5;'Затраты распределенные на ед.'!$A$3:$A$504;)):ИНДЕКС('Затраты распределенные на ед.'!$Y$3:$Y$504;ПОИСКПОЗ(B5;'Затраты распределенные на ед.'!$A$3:$A$504;)));ИНДЕКС('Затраты распределенные на ед.'!$B$3:$B$504;ПОИСКПОЗ(B5;'Затраты распределенные на ед.'!$A$3:$A$504;)):ИНДЕКС('Затраты распределенные на ед.'!$Y$3:$Y$504;ПОИСКПОЗ(B5;'Затраты распределенные на ед.'!$A$3:$A$504;)));)
Вы б назвали лист как-то покороче, а то страшная формула получается )))
Изменено: _Boroda_ - 25.01.2023 15:04:02
Скажи мне, кудесник, любимец ба’гов...
 
Спасибо! Очень помогли. Главное формула, а лист поправлю. БЛАГОДАРЮ.
Изменено: Алла Акифьева - 25.01.2023 16:35:59
 
Здравствуйте.Помогите, пожалуйста, исправить формулу, которую делали ранее в этой беседе. Появились отрицательные данные в массиве, и теперь  формула вытягивает данные последние положительные... что неверно. В прикрепленном файле выделены данные, которые надо вытянуть (как пример, естественно надо по всем позициям формулу), на листе Свод МД4 - ячейки выделены голубым, они должны затянуться по указанным номенклатурам в лист Плановые цены Апрель по соответствующим номенклатурам. Надо изменить так, чтобы отрицательные данные тоже попадали  или попадали данные более свежие но после отрицательных и формула не стопорилась, в остальном запрос тот же.
Спасибо.
https://cloud.mail.ru/public/uZZZ/rn9vLQKm6
Изменено: Алла Акифьева - 11.04.2024 14:26:11
 
Здравствуйте
похоже так
=ЕСЛИОШИБКА(ПРОСМОТР(9^9;ИНДЕКС('СВОД МД4'!$B:$B;ПОИСКПОЗ(B558;'СВОД МД4'!$A:$A;)):ИНДЕКС('СВОД МД4'!$AM:$AM;ПОИСКПОЗ(B558;'СВОД МД4'!$A:$A;)));"")
 
Спасибо! Поясните, пожалуйста, как работает в формуле выражение 9^9 ?
 
Алла Акифьева, пожалуйста
почитайте здесь
Страницы: 1
Наверх