Страницы: 1
RSS
Подсчет суммы покупок за каждый месяц.
 
Всем хорошего и доброго дня!
Помогите пожалуйста с такой задачей.
Есть таблица с суммами продаж за год(в примере выборка за три месяца).
В таблице у каждой продажи(суммы продажи) имеется дата чека и номер карты, по которой была совершена продажа.
Нужно чтобы производился подсчет сумм продаж по каждой карте за месяц и выводился в доп столбец.
В примере изобразил наглядно.
 
Цитата
andre1994 написал:
Помогите
сводная таблица поможет.
Пришелец-прораб.
 
Код
D3:D20    =ЕСЛИ(СЧЁТЕСЛИМН($C3:C$20;C3;$A3:A$20;">="&ДАТА(ГОД(A3);МЕСЯЦ(A3);1);$A3:A$20;"<"&ДАТА(ГОД(A3);МЕСЯЦ(A3)+1;1))<>1;"";ДАТА(ГОД(A3);МЕСЯЦ(A3);1))
E3:E20    =ЕСЛИ(СЧЁТЕСЛИМН($C3:C$20;C3;$A3:A$20;">="&ДАТА(ГОД(A3);МЕСЯЦ(A3);1);$A3:A$20;"<"&ДАТА(ГОД(A3);МЕСЯЦ(A3)+1;1))<>1;"";СУММЕСЛИМН($B$2:B3;$C$2:C3;C3;$A$2:A3;">="&ДАТА(ГОД(A3);МЕСЯЦ(A3);1);$A$2:A3;"<"&ДАТА(ГОД(A3);МЕСЯЦ(A3)+1;1)))
F3:F20    =ЕСЛИ(СЧЁТЕСЛИМН($C3:C$20;C3;$A3:A$20;">="&ДАТА(ГОД(A3);МЕСЯЦ(A3);1);$A3:A$20;"<"&ДАТА(ГОД(A3);МЕСЯЦ(A3)+1;1))<>1;"";C3)

 
Дня доброго
вариант:
 
Всем большое спасибо!
Страницы: 1
Наверх