Страницы: 1
RSS
Поиск максимального значения, которое меньше определенного и с дополнительным критерием.
 
Добрый день!
Подскажите пожалуйста, как возможно в ячейку С2 подставить дату, которая будет меньше чем дата в ячейке B2, но наибольшая из диапазона G и с учетом критерия номера вагона из столбца A, которое совпадает с диапазоном в столбце F?
Пытался как то сделать через
=ИНДЕКС(A:A;ПОИСКПОЗ(МАКС(ЕСЛИ(A:A<=B2;AB:AB;""));AB:AB;0);1)
Но не получается чтобы был еще критерий с номером вагона...
 
Массивная
Код
=МИН(ЕСЛИОШИБКА($G$2:$G$12/((B2>$G$2:$G$12)*(A2=$F$2:$F$12));""))
 
Указанным образом ищется минимальное значение.. А необходимо чтобы искалось максимальное, но меньше условного. т.е. должно найтись значение
01.08.2023 08:09:00
Указал в таблице
 
Ну так поменяйте МИН на МАКС
Код
=МАКС(ЕСЛИОШИБКА($G$2:$G$12/((B2>$G$2:$G$12)*(A2=$F$2:$F$12));""))
 
Спасибо большое!) работает!)
 
Формула
Код
=AGGREGATE(14;6;G$2:G$12/(G$2:G$12<B2);1)
Страницы: 1
Наверх