Страницы: 1
RSS
Формула "Если" с множеством условий
 
Добрый день, уважаемые знатоки, помогите, пожалуйста!

В итоговой оценке 3 критерия. Баллы начисляются за выполнение определенных.
По отдельности для каждого, формулу я прописала, но соединить всё вместе никак не получается. Какой - нибудь 1 всегда вылетает и не считается.

0 – кол-во участников ниже установленного минимума, нет роста;
1 –  кол-во участников ниже установленного минимума, рост базы до 3% включительно;
2 –  кол-во участников равно или выше установленного минимума;
3 –  кол-во участников кратно выше установленного минимума более чем в 3 раза.
Установленный минимум участиков - 60

Буду очень благодарна за помощь.
 
Мария Трофимова, создайте пример, как есть и что должно получится. Из вашего примера не понятно
 
Есть кол-во человек на начало года, втечении года их кол-во или уменьшается или увеличивается. В соответтсвии с этими изменениями начисляются баллы на конец года. При этом установлен минимум участников - 60.
Далее - по баллам.
Если на начало года кол-во было менее 60 и к концу года не было роста, то "0" - баллов
Если на начало года кол-во было менее 60 а к концу года было рост до 3% включительно, то "1" - балл
Если на конец года кол-во 60 и более, то "2" - балла
Если на конец года кол-во более 180, то "3" - балла
 
Мария Трофимова, а сколько баллов за, скажем, начало = 1 , конец = 59 ? А так, если у вас 2019 и выше, то есть функция SWITCH. В ней все легко прописывается.
Код
=SWITCH(
    1,
    (A2 < 60) * (B2 <= A2), 0,
    (A2 < 60) * (B2 > A2) * ((B2 / A2) <= 1.03), 1,
    B2 >= 180, 3,
    B2 >= 60, 2,
    "это другое"
)
Изменено: AlienSx - 14.02.2024 17:18:43
Пришелец-прораб.
 
попробуйте так
Код
=ЕСЛИ(B2>179;3;ЕСЛИ(B2>59;2;ЕСЛИ(B2<=A2;0;1)))
 
Цитата
написал:
попробуйте такКод=ЕСЛИ(B2>179;3;ЕСЛИ(B2>59;2;ЕСЛИ(B2<=A2;0;1c
Спасибо большое! Ваша формула работает, как нужно.
Всё гениальное - просто  :D , а я сильно перемудрила  
 
=ЕСЛИ(B2>=E1;2+(B2>3*E1);--(A2*1,03<=B2))
Изменено: Павел \Ʌ/ - 12.04.2024 12:04:22
Страницы: 1
Наверх