Страницы: 1
RSS
Распределение суммы по датам (по месяцам)
 
Всем Привет!

Подскажите пожалуйста формулой, во вложении пример (ручная вставка) распределение суммы по дате. Нужна формула для раскидования суммы на правой части таблицы по месяцам...  
 
Di540, приветствую.
В N2 (и далее скопировать):
Код
=ЕСЛИ(N$1-ДЕНЬ(N$1) = $D2-ДЕНЬ($D2); $H2; 0)
 
Спасибо!
 
Еще вариант

=(МЕСЯЦ(N$1)=МЕСЯЦ($D2))*$H2

Изменено: АlехМ - 28.02.2024 14:17:47
Алексей М.
 
Цитата
АlехМ, написал:
=(МЕСЯЦ(N$1)=МЕСЯЦ($D2))*$H2
А год проверять?
Код
=(ГОД(N$1)=ГОД($D2))*(МЕСЯЦ(N$1)=МЕСЯЦ($D2))*$H2
 
andypetr, Проглядел, что таблица более одного года, а в задании говорилось только о месяцах.
Алексей М.
 
Здравствуйте
Там концы... в заголовках... месяца
=(J$1= КОНМЕСЯЦА($D2;0))*$H2
Страницы: 1
Наверх