Страницы: 1
RSS
Копирование в ячейку, установленную функцией АДРЕС, Разработка макроса
 
Добрый день!
Имеется задача:
Необходимо разработать VBA-макрос для копирования значения из ячейки Е2 в ячейку, которая определяется функцией АДРЕС исходя из других переменных. Пример прилагаю.

Заранее благодарю за участие в решении данного вопроса!

[Вопрос закрыт]
Изменено: Gramr294 - 12.04.2024 18:10:38 (Прошу прощения, не совсем понял как в названии темы установить что вопрос закрыт, скорее всего это делается модераторами.)
 
Код
Sub test()
    Dim Adr$
    Adr = [d2]
    Range(Adr).Value = Range("E2").Value
End Sub
 
Код
 Range(Range("D2")) = Range("E2")
По вопросам из тем форума, личку не читаю.
 
Цитата
написал:
разработать VBA-макрос
Если это требование некритично, то вариант формулой. Вставить в B6 и протянуть.
Код
=ЕСЛИ(ПОДСТАВИТЬ(ЯЧЕЙКА("адрес";B6);"$";"")=$D$2;$E$2;"")
 
irabel, спасибо за помощь, именно то что и было нужно!
 
МатросНаЗебре, предполагалось закрепить макрос за фигурой чтобы создать своего рода кнопку, использовал решение предложенное выше.
 
БМВ, даже не предполагал что можно использовать конструкции Range(Range, благодарю за ответ.  
Страницы: 1
Наверх