Страницы: 1
RSS
Суммирование формулы массива с использованием фильтра
 
Добрый день, уважаемые форумчане!
У меня есть красивая формула, которая подсчитывает количество дней отпуска в графике отпусков по месяцам. Но я ума не приложу как сделать, чтобы формула считала количество дней с использованием фильтрации по должностям. Буду очень признательна, если поможете! :)

(желтым выделен пример как должна считать формула, если поставить фильтрацию)
 
Добрый.
Проще добавить выпадающий список с должностями и дописать ещё одно условие в формуле, чем париться с фильтрами.
Если в мире всё бессмысленно, — сказала Алиса, — что мешает выдумать какой-нибудь смысл? ©Льюис Кэрролл
 
Огромное спасибо! Этого достаточно♥
 
День добрый
Цитата
ringa: У меня есть красивая формула...
=СУММ((СТРОКА(ДВССЫЛ("A"&H1&":A"&КОНМЕСЯЦА(H1;0)))>=ТРАНСП($E$9:$E$508))*(СТРОКА(ДВССЫЛ("A"&H1&":A"&КОНМЕСЯЦА(H1;0)))<=ТРАНСП($F$9:$F$508))*(ТРАНСП($B9:$B508=$G3)))
пожалуй, предложу нестрашнее:
=СУММ(ЕСЛИОШИБКА(($B$9:$B$18=$G$3)*EXP(LN(ДАТАМЕС(H1;1)-H1+$D9:$D18-ABS($F9:$F18-ДАТАМЕС(H1;1)+1)-ABS($E9:$E18-H1))); ))/2
Страницы: 1
Наверх