Страницы: 1
RSS
Суммирование со смещением, Суммирование со смещением
 
Всем привет. Вопрос такой как можно суммировать значения со смещением?
Допустим в примере есть ячейка В4 в ней по формуле сумм суммируются значения столбца А - A5:A33, требуется сдвигаясь относительно столбца А из этой формулы суммировать значения в столбце D.
Свой вариант я написал но больно уж он громоздкий, возможны какое то более компактные изящные варианты?)))
 
Может быть так?
Код
=СУММ(СМЕЩ(ДВССЫЛ(ПОДСТАВИТЬ(ПСТР(Ф.ТЕКСТ(B4);7;99);")";));0;3))
Алексей М.
 
Цитата
написал:
=СУММ(СМЕЩ(ДВССЫЛ(ПОДСТАВИТЬ(ПСТР(Ф.ТЕКСТ(B4);7;99);")";));0;3))
Добрый день! Как научиться комбинировать также функции и составлять сложные формулы?
 
Gelton,
Добрый. Начните с изучения раздела Приёмы
Если в мире всё бессмысленно, — сказала Алиса, — что мешает выдумать какой-нибудь смысл? ©Льюис Кэрролл
 
АlехМ, нуу в принципе отчасти норм  :)  )) хотя бы не четыре обращения к ячейке с формулой.
Страницы: 1
Наверх