Страницы: 1
RSS
Пропуск новой строки в формуле
 
Добрый день.


Есть формула растянутая вниз:

=ЕСЛИОШИБКА(ЕСЛИ(И('Фин. Анализ'!P22<>"";'Фин. Анализ'!V22="Да";ВПР('Фин. Анализ'!P22;'Не финансовые преимущества'!$A:$H;2;0)<>"");МАКС($Y$1:Y1)+1;0);0)

Формула составляет неструктурированный список по условиям, и затем другими формулами формируется структурированный список.
Когда добавляю на листе "Фин. Анализ" новую строку, то следующая формула которая должна учитывать новую добавленную строку выглядит как:

=ЕСЛИОШИБКА(ЕСЛИ(И('Фин. Анализ'!P24<>"";'Фин. Анализ'!V24="Да";ВПР('Фин. Анализ'!P24;'Не финансовые преимущества'!$A:$H;2;0)<>"");МАКС($Y$1:Y1)+1;0);0)

т.е. новая строка пропускается.

Подскажите в чем причина и можно ли это исправить? Есть другие подобные формулы которые ссылаются на другие листы, но там используется ПОИСК, и таких проблем с ними нет.
 
новая строка не пропускается, просто при вставке происходит сдвиг и формула не знает о намерениях ваших.

=ЕСЛИОШИБКА(ЕСЛИ(И(ИНДЕКС('Фин. Анализ'!P:P;СТРОКА(A$1)+21)<>""; ИНДЕКС('Фин. Анализ'!V:V;СТРОКА(A$1)+21)="Да";ВПР(ИНДЕКС('Фин. Анализ'!P:P;СТРОКА(A$1)+21);'Не финансовые преимущества'!$A:$H;2;0)<>"");МАКС($Y$1:Y1)+1;0);0)

СТРОКА(A$1)+21 - может быть и так ;СТРОКА()+2  например, главное чтоб в нужном месте указывало на нужную строку.
По вопросам из тем форума, личку не читаю.
 
Помогло, спасибо  :)

СТРОКА(A$1)+21 заменил на СТРОКА(A1)+21 и растянул вниз, иначе расчет фиксировался на одной ячейке.
При добавлении новой строки сдвиг происходит корректно, ничего не теряется.
 
Цитата
написал:
СТРОКА(A$1)
да, закрепил я зря,  думал о другом немного, но принцип показан и понят. Это было главное.
По вопросам из тем форума, личку не читаю.
Страницы: 1
Наверх