Страницы: 1
RSS
как можно подсчитать сумму чисел в ячейках, между двумя ячейками с текстовым содержанием.
 
Здравствуйте!
Подскажите, пожалуйста, как можно подсчитать сумму чисел в ячейках, между двумя ячейками с текстовым содержанием.
Пример: В столбце "B" между ячейками "Кот" и "Пёс" нужно подсчитать сумму чисел  и в ячейке справа от ячейки "Кот" отобразить результат. Количество строк между ячейкой "Кот" и "Пёс" регулярно меняется.
 
мой вариант (не претендует на оптимальность)
Учимся сами и помогаем другим...
 
Спасибо огромное ber$erk! Сам только начинаю изучать возможности excel.
Как это работает? Что задаёт вычисление в данном промежутке? Слов "Кот" и "Пес" в формуле я не увидел.)))
Если есть время, можете пояснить?
 
считает формула массива. суммируются числовые ячейки (проверка через функцию ЕЧИСЛО), которые находятся выше, чем ближайшее текстовая ячейка после текущей. Как то так :-)
Учимся сами и помогаем другим...
 
Или такая формула массива:
=СУММ(ЕСЛИ(СТРОКА()=ПРОСМОТР(СТРОКА($B$6:$B$27);ЕСЛИ(ЕТЕКСТ($B$6:$B$27);СТРОКА($B$6:$B$27)));$B$6:$B$27))
"..Сладку ягоду рвали вместе, горьку ягоду я одна."
 
Спасибо огромное, буду разбираться.
 
В С6:
=ЕСЛИ(ЕТЕКСТ(B6);СУММ(B6:$B$28)-СУММ(C7:$C$28);"")
 
Может такой вариант?

Код
=SUM(INDEX(B6:B27;MATCH("Кот";B6:B27;0)+1):INDEX(B6:B27;MATCH("Пес";B6:B27;0)-1))
Изменено: jakim - 30.10.2014 16:31:25
Страницы: 1
Читают тему (гостей: 1)
Наверх