Страницы: 1
RSS
Чтобы не появлялся ноль в связанной ячейке
 
Подскажите пожалуйста, как сделать, чтобы если данные из одной ячейки дублируются в другую ячеек через =адрес ячейки, чтобы при отсутствии данных в связанной ячейке не появлялся бы ноль (0).

Чтобы, если удаляешь данные из ячейки A1, то в ячейке A2 было бы пусто, без ноля.
 
совсем пусто - это только макросом.
а чтобы нуля не было - можно так:
Код
=ЕСЛИ(ЕПУСТО(A1);"";A1)
фрилансер Excel, VBA - контакты в профиле
"Совершенствоваться не обязательно. Выживание — дело добровольное." Э.Деминг
 
Можно так
Код
=ЕСЛИ(A1;A1;"")
но только если эта ячейка не участвует в расчетах. Или все нули можно не отображать на листе, если в Параметрах - Дополнительно -- Показывать нули в ячейках, которые содержат нулевые значения, убрать галочку  
Изменено: gling - 03.06.2015 22:20:38
 
В  ячейке A2 уже есть одна формула =A1. Скажите, а может быть в ячейке две формулы?
Изменено: Olga H. - 03.06.2015 22:24:39
 
Отображение нуля в ячейках ещё можно отключить в параметрах Excel.
 
Цитата
может быть в ячейке две формулы?
А зачем? Написанные выше формулы заменяют формулу =A1.
 
gling, спасибо! Всё получилось без формулы.  Параметры Excel - Дополнительно -- сняла галочку с Показывать нули в ячейках, которые содержат нулевые значения-ok-и нули пропали. Документ, в котором эту функцию использую, не связан с расчетами.
 
Ну нормально - я про параметры сказал, а спасиба ушла gling :D
 
Формат ячеек > Все форматы> 0;;
 
Во "Все форматы" не нашла > 0;; Может это надо самой вписать в окно Тип?
 
Да, вручную.
 
Цитата
Юрий М написал: Ну нормально - я про параметры сказал, а спасиба ушла gling
Так он раньше тебя про параметры сказал. Кто первый встал - того и тапки :-)
Даже самый простой вопрос можно превратить в огромную проблему. Достаточно не уметь формулировать вопросы...
 
Всё равно обидно)
 
magrifa, ваш вариант более всего подошёл, потому что убирает ноли с выделенной зоны, а не со всего листа.
Выделяю ячейки, в которых не хочу видеть нули-Формат ячеек- Все форматы-Из поля Тип удаляю Основные-вставляю в поле Тип > 0;; -жму ОК- из выделенных ячеек нули исчезают, в остальных ячейках- остаются
 
Вообще правильно формат должен выглядеть так: 0;-0;
Почему? Проверьте, записав в ячейку отрицательное число. С форматом 0;; оно так же будет невидимо в ячейке, как и нули. С форматом 0;-0; - будут отображаться любые числа и текст, но не нули.
Даже самый простой вопрос можно превратить в огромную проблему. Достаточно не уметь формулировать вопросы...
 
The_Prist, спасибо ваш вариант с 0;-0;  работает! Уже его использую.
 
magrifa, спасибо, именно то что искал!  
 
The_Prist, спасибо за важное уточнение
Страницы: 1
Наверх