Поиск  Пользователи  Правила 
Закрыть
Логин:
Пароль:
Забыли свой пароль?
Регистрация
Войти
 
Страницы: 1
RSS
Продолжительность работы компании с аудитором
 
здравствуйте! у меня таблица со списком компаний и их аудиторов за период лет с 2000 по 2010ый год. Мне нужно посчитать начиная с 2000-го года сколько лет компания работает в паре с аудитором. в 2000-ом году пара копания-аудитор будет иметь значение 1. если в следующем году они продолжают сотрудничать- то 2. и если в какой то год аудитор поменялся, мне нужно начинать новый отсчет.
не могли бы подсказать как решить такую задачу в Excel? мне посоветовали воспользоваться функцией countif, но я никак не могу разобраться. заранее всем спасибо за помощь!
 
Показать файл-пример для начала.
 
         
company_codeyearauditor_code
3069720021
3069720031
3069720041
3069720051
3069720061
3069720071
3069720081
3069720091
105620024
105620034
105620044
105620054
105620064
136020012
136020022
136020032
136020042
136020052
147820015
147820021
147820031
147820041
147820051
147820061
147820071
147820081
158120011
158120021
158120031
158120041
161320013
161320023
161320033
161320043
161320053
161320063
161320073
161320083
186020031
186020041
186020051
186020061
186020071
186020081
186020091
186020101
186020111
186020121
186020131
 
Спасибо. Но файл-пример - это файл Excel.
Правила

Цитата
сколько лет компания работает в паре
Где в Вашем "примере" года? Считать по количеству?

Вот такой пример формулы. Вставьте в свой пример в сообщении - возможно, будет работать :)
=СЧЕТЕСЛИМН(диапазон_компании;компания;диапазон_аудиторы;аудитор)
 
=СУММ(ЧАСТОТА(ЕСЛИ((B2=$B$2:$B$50)*(D2=$D$2:$D$50);ПОИСКПОЗ($C$2:$C$50;$C$2:$C$50;0));ПОИСКПОЗ($C$2:$C$50;$C$2:$C$50;0)))

Формула массива вводится при помощи трёх клавиш - Ctrl+Shift+Enter/
"..Сладку ягоду рвали вместе, горьку ягоду я одна."
Страницы: 1
Читают тему (гостей: 2)
Наверх