Поиск  Пользователи  Правила 
Закрыть
Логин:
Пароль:
Забыли свой пароль?
Регистрация
Войти
 

Страницы: 1
Поиск
[VBA] Расчет значения ячейки при изменении соседней ячейки
Автор: BigPluxoV. Добрый день. У меня такая проблема: Есть формула "=ЕСЛИ((N2-B2)<0;0;ЕСЛИ((N2-B2)>1;(((N2-B2)*1440)-(ЦЕЛОЕ(N2-B2)*1440*6.5/24));(N2-B2)*1440)) ", которая должна рассчитывать значение при изменении соседней ячейки. Причем если строка изменится то соответственно должны измениться адреса ячеек (например в 3-ей строке должно быть N3-B3 ну и т.д.) Попробовал сделать макрос: Private Sub Worksheet_Change(ByVal Target As Range) For Each cell In Target 'проходим по всем измененным...
Изменен: 28 окт 2019
Читать сообщение на форуме или сайте.
Страницы: 1
Наверх