Поиск  Пользователи  Правила 
Закрыть
Логин:
Пароль:
Забыли свой пароль?
Регистрация
Войти
 
Выбрать дату в календареВыбрать дату в календаре

Страницы: 1
Суммы значений с распределением по месяцам и дням недели., Нужна единая формула, позволяющая суммировать определенные значения
 
Цитата
Пытливый написал:
Точно. Забыл в Деньнед еще один параметр указать. Надо вот так:Код ? 1=СУММ(($A8:$U8>0)*(МЕСЯЦ($A$5:$U$5)=МЕСЯЦ(BS$6))*(ДЕНЬНЕД($A$5:$U$5;2)<6))
Немного поправил вашу версию:
=СУММ(($C8:$BT8)*(МЕСЯЦ($C$6:$BT$6)=МЕСЯЦ(BU$6))*(ДЕНЬНЕД($C$6:$BT$6;2)<6))

А то считалось кол-во значений, а не их сумма.

Теперь, вроде бы, формула идеальная, продолжу тестить.

Михаил Витальевич С., Пытливый, Спасибо вам большое, вы настоящие гуру)  
Суммы значений с распределением по месяцам и дням недели., Нужна единая формула, позволяющая суммировать определенные значения
 
Пытливый, вот скрин.
Сделал, как вы писали. Но значение не правильное.  
Суммы значений с распределением по месяцам и дням недели., Нужна единая формула, позволяющая суммировать определенные значения
 
Михаил Витальевич С., ваша работает!)

Супер)

Но вот такой вопрос: возможно ли вашу формулу скорректировать так, чтобы она не привязывалась к году? Как вы правильно заметили, раньше в ячейке отображался просто "июнь", и не важно, какого года. Для вашей формулы это важно.

Может, есть идеи, как это поправить? Возможно, как-то изменить формат записи месяца...


Пытливый, не работает, к сожалению.  
Суммы значений с распределением по месяцам и дням недели., Нужна единая формула, позволяющая суммировать определенные значения
 
Коллеги, нужна ваша помощь.
Во вложении файл. В нем необходимо посчитать значения в "красных" ячейках.

Подробности:
Левая часть файла - это сетка. значения расставлены в определенные дни (будни и выходные) и в определенные месяцы.
Правая часть - ячейки, в которых должны быть суммы по строкам. Но для каждой строки необходимы отдельные суммы: июНь будни, июНь выходные, июЛь будни, июЛь выходные и т.д.

Я знаю, как посчитать сумму всех значений для определенного месяца. Пример специально оставил в августе, будни.
Но как в единой формуле сделать еще и распределение будни/выходные я совсем не понимаю. Нужна ваша помощь.

П.С. знаю, что можно решить эту проблему, просто выделив ячейки с выходными отдельно, а не всю строку целиком, но мне такое решение не подходит.  
Страницы: 1
Наверх