Поиск  Пользователи  Правила 
Закрыть
Логин:
Пароль:
Забыли свой пароль?
Регистрация
Войти
 
Выбрать дату в календареВыбрать дату в календаре

Страницы: 1 2 3 4 5 6 7 8 9 10 11 ... 19 След.
Преобразовать дату из ДД.ММ.ГГГГ в ГГГГ.ММ.ДД
 
здравствуйте
в лоб =ТЕКСТ(A1*1;"гггг.ММ.дд")
Из плоской таблицы сделать отсортированные сводные данные формулой (без доп.столбцов и без макросов)
 
Добрый вечер, а сводная не подходит?
Изменено: Настя_Nastya - 23 сен 2020 20:10:46
Перенос данных с одного листа на другой и обратно
 
пишу в личку
Объединение таблиц по заголовкам
 
Цитата
Ranker Dark написал:
как такое сделать без ctrl+c/ctr
тоже на картинке показать? сделайте пример в файле
Подсветить дубликаты в двух столбцах
 
Цитата
Микос001 написал:
какой формулой можно подсветить эти дубликаты
Код
=СЧЁТЕСЛИ($B$2:$B$5;A2)>0
здравствуйте
Добавление в одну ячейку гистограммы и условия, как сделать так что бы после заполнения гистограммы выполнялось определенное условие
 
Добрый день! Измените формулу в S15 и ниже на
=ЕСЛИ(L15>=I15;"Работы выполнены на 100%";L15/I15)
затем добавьте УФ на ячейки в S столбце:
Изменено: Настя_Nastya - 22 сен 2020 12:44:27
требуется макрос для сравнения двух столбцов, гугл таблицы
 
Пишу в личку
ТС пропал
Изменено: Настя_Nastya - 23 сен 2020 13:43:38
Формула расчета для определения минимальной цены
 
Два доп.столбца
=ЕСЛИ(C5="";D4;C5)
=ЕСЛИ(B5<D5;D5;B5)
Точки как граница ячеек по умолчанию. Как избавиться?
 
Добрый день! В настройках попробуйте выбрать цвет "авто" (если выбран другой цвет, то линия будет точечками отображаться)
Из текстовой строки дата с временем получить только дату VBA
 
Добрый вечер!
Код
Sub Дата_из_текста()
    Dim r, c As Range
    With ActiveSheet
        Set r = Intersect(.UsedRange, .[a:a]).Offset(1)
        r.FormulaLocal = r.FormulaLocal
        r.NumberFormat = "dd.mm.yyyy"
        For Each c In r
            .Cells(c.Row, c.Column) = Format(c.Value2, "dd.mm.yyyy")
        Next c
    End With
End Sub
Изменено: Настя_Nastya - 16 сен 2020 21:53:42
Автоматизация обработки путевых листов (Доработать существующую таблицу)
 
Пишу в личку
Обсуждаем
В работе
Готово
Изменено: Настя_Nastya - 21 сен 2020 18:42:57
Универсальный макрос вставки значений и форматирования чисел из буфера обмена в выделенную ячейку. Возможно ли?
 
Неа, тогда попробуйте одним макросом копировать, а другим вставлять
Код
Public s As Range
Sub Copy()
Set s = Selection
s.Copy
End Sub
Sub Paste()
Selection.PasteSpecial xlPasteValues
Selection.PasteSpecial xlPasteFormats
s.ClearContents
End Sub
Изменено: Настя_Nastya - 16 сен 2020 11:33:12
Универсальный макрос вставки значений и форматирования чисел из буфера обмена в выделенную ячейку. Возможно ли?
 
Здравствуйте! попробуйте этот код:
Код
Sub Paste ()
Selection.PasteSpecial xlPasteValues
Selection.PasteSpecial xlPasteFormats
End Sub
Изменено: Настя_Nastya - 16 сен 2020 11:06:28
Преобразовать сумму 0,00 в 0 рубл. 00 коп.
 
добрый день! Пользовательский формат
Проверка данных с поиском как в Google Sheets
 
Добрый день! mike31, может это Вам подойдет?)
Не работает авторасчет суммы и формула не вставляется
 
Беймбет Кушкалиев, в ячейку, где нужно посчитать сумму по Дебету!
Ну или просто нажмите Ctrl+H и замените точку на запятую.
Не работает авторасчет суммы и формула не вставляется
 
формула массива
=СУММ(ПОДСТАВИТЬ(I13:I473;".";",")*1)
Создание динамического текста примечания из нескольких ячеек
 
VBKomp, добавьте в код Mershik,  строку в конец
Код
End sub
Весь код
Код
Private Sub Worksheet_Change(ByVal Target As Range)If Target.Cells.Count > 1 Then Exit Sub
If Not Intersect(Target, Range("C4:C1000")) Is Nothing Then
 
Range("C2").ClearComments
lr = Cells(Rows.Count, 3).End(xlUp).Row
For i = 4 To lr
If Not IsEmpty(Cells(i, 3)) Then
If x <> "" Then
    x = x & Cells(i, 3).Value & Chr(10)
Else
    x = Cells(i, 3).Value & Chr(10)
End If
End If
Next i
Range("C2").AddComment Text:=x
 
End If
End sub
Не работает авторасчет суммы и формула не вставляется
 
И Вам добрый вечер. У Вас в данных разделитель точка, а нужна запятая, иначе Excel думает что это текст
Защитить некоторые ячейки от редактирования после ввода данных
 
Иван Васильев, а Вы как хотели?!
Защитить некоторые ячейки от редактирования после ввода данных
 
Добрый день! Сделала код для столбца Е. Остальное допилите.
Код
Private Sub Worksheet_Change(ByVal Target As Range)
If Target.Row >= 6 And Target.Row <= 1000 And Target.Column = 5 And Target.Value <> "" Then
ActiveSheet.Unprotect
Target.Locked = True
ActiveSheet.Protect
End If
End Sub
Проверка и подсветка гиперссылки на наличие во втором файле ячейки с указанным именем.
 
тема: проверка на наличие именованного диапазона в другой книге и, если есть, сделать на этот диапазон гиперссылку
=ЕСЛИ(ЕОШ(ДВССЫЛ(ПОДСТАВИТЬ(ПОДСТАВИТЬ(ГИПЕРССЫЛКА(СЦЕПИТЬ("[T Base.xlsm]_";A1));"]";"'!");"[";"'")));"";ГИПЕРССЫЛКА(СЦЕПИТЬ("[T Base.xlsm]_";A1)))
Другая книга должна быть открыта
Проверка и подсветка гиперссылки на наличие во втором файле ячейки с указанным именем.
 
Юрий М, добрый вечер Вам), думаю fedsum, имел ввиду проверку на наличие ячейки в другой книге с определенным значением (в данном случае "J51")... только вот забыл указать диапазон/столбец/лист для проверки... или нужно все 100500 ячеек книги перебрать?
вычислить количество нерабочий часов в интервале времени, вычислить количество нерабочий часов в интервале времени
 
Добрый день. с дополнительными столбцами (все лучше чем ручками)
Код
=ЕСЛИОШИБКА(ЕСЛИ((J4+1/24/60)<=$K$4;(J4+1/24/60););)
Код
=ЕСЛИОШИБКА(ЕСЛИ((J5-ЦЕЛОЕ(J5)>=$B$9)*(J5-ЦЕЛОЕ(J5)<=$C$9)+(J5=0);0;1/24/60);0)
PS Вы в расчете потеряли две секунды при переходе к новым суткам с 23:59:59 по 0:00:01...
вычислить количество нерабочий часов в интервале времени, вычислить количество нерабочий часов в интервале времени
 
добрый вечер! Сделайте файл пример, посчитайте для нескольких значений результат вручную что бы было понятно что Вам нужно получить и Вам обязательно помогут)
Подсчет изменений по сравнению с предыдущим значением, но так чтобы формула работала при увеличение дней (ячеек) и появлении пропусков в остатках и в конце считала изменения по отношению с началом месяца
 
Сделайте нормальный пример - как есть и как нужно (значения вручную вбейте).
Цитата
Faf написал:
при наличие значение в ячейке считалось
-это как вообще? что считалось? Формула? Какая, если у Вас в примере вообще нет формул...
Подсказка на кнопку запуска макроса
 
Цитата
Radomir-m написал:
можно ли вызвать макрос через гиперссылку?
Добрый вечер! Если гиперссылка в ячейке, то можно подвязать макрос на событие выделения этой ячейки...
Функция ВПР поверх значений в ячейках
 
Выделяете диапазон, в котором нужно в пустых ячейках вставить формулу, и нажимаете кнопку Заполнить
Код
Sub ggg()
Set S = Selection
For Each c In S
    If c.Value = "" Then [c1].Copy: c.PasteSpecial xlPasteFormulas
Next c
End Sub

Макрос скопирует формулу из ячейки С1 в пустые ячейки выделенного диапазона

Изменено: Настя_Nastya - 6 сен 2020 12:19:50
Гугл таблицы, Из бд сформировать таблицу.
 
Цитата
Mordvin111 написал:
Предложенные решения, дублируют существующее работающее решение
Имеющееся у ТС решение - таблица с кучей ненужных пустых строк без оформления (границ), которую каждый раз в ручную нужно приводить в порядок.
Предложенное решение - скрипт, который формирует таблицу только с необходимыми заполненными строками, а так же устанавливает границы.
ТС вместо того чтобы отписаться в личке, как и обещал, отписывается здесь через почти две недели.
Не очень красивый поступок, учитывая то, что я изначально озвучила примерную стоимость работы, ТС согласился и я потратила кучу времени на составление ТЗ...
Задание., Нужна помощь в решение и описании. Как и что делать.
 
Цитата
Roman написал:
который платит Вам деньги
Вы мне ничего не платите)

Цитата
Roman написал:
вы предлагаете варианты, сделать мне то, что я не умею
я попросила выложить исходные данные, а не то что должно получиться
Цитата
Настя_Nastya написал:
покажите часть Вашего файла, чтобы было понятно, с чем придется иметь дело

Просто хотела Вам помочь упростить поиск исполнителя
Страницы: 1 2 3 4 5 6 7 8 9 10 11 ... 19 След.
Наверх