Выбрать дату в календареВыбрать дату в календаре

Страницы: 1 2 3 4 5 6 7 8 9 10 11 ... 37 След.
Найти q в геометрической прогрессии (есть S1 и Sn)
 
Поиск решения, а вот протянуть не получается
Изменено: Тимофеев - 28.09.2022 18:55:54
расчет сумм с разными значениями
 
!
расчет сумм с разными значениями
 
Поставьте запятые 0,25 и 0,5 или 1/4 и 1/2 - поменял формулу
Изменено: Тимофеев - 28.09.2022 14:13:34
расчет сумм с разными значениями
 
Код
=СУММ(D7:D10*
ЕСЛИ(D7:D10=0;0;
ЕСЛИ(D7:D10<=1/4;4*$D$4;
ЕСЛИ(D7:D10<=1/2;2*$D$3;
ЕСЛИ(D7:D10<5;$D$6;
ЕСЛИ(D7:D10>=5;$D$5))))))
Изменено: Тимофеев - 28.09.2022 14:13:12
Первые три слова из ячеки, Первые три слова из ячеки
 
Код
=ФИЛЬТР.XML("<j><i>"&ПОДСТАВИТЬ(A1;" ";"</i><i>")&"</i></j>";"//i[1]")&" "&
ФИЛЬТР.XML("<j><i>"&ПОДСТАВИТЬ(A1;" ";"</i><i>")&"</i></j>";"//i[2]")&" "&
ФИЛЬТР.XML("<j><i>"&ПОДСТАВИТЬ(A1;" ";"</i><i>")&"</i></j>";"//i[3]")
Изменено: Тимофеев - 28.09.2022 11:28:57
Как поменять местами значения в одной ячейке?
 
Код
=ОБЪЕДИНИТЬ(", ";1;"Дискографии";ФИЛЬТР.XML("<j><i>"&ПОДСТАВИТЬ(A2;",";"</i><i>")&"</i></j>";"//i[not(contains(., 'Дискографии'))]"))
Сколько раз определенное слово встречается в таблице, НЕ количество ячеек, Необходимо посчитать количество повторений именно определенного слова, а не ячеек. Не макроссом, формулой
 
ну это смотря из какого офиса глядеть - в моем как положено 8
Изменено: Тимофеев - 27.09.2022 17:48:11
Сколько раз определенное слово встречается в таблице, НЕ количество ячеек, Необходимо посчитать количество повторений именно определенного слова, а не ячеек. Не макроссом, формулой
 
Код
=СЧЁТЗ(ФИЛЬТР.XML("<j><i>"&ПОДСТАВИТЬ(ОБЪЕДИНИТЬ(" ";1;A:A);" ";"</i><i>")&"</i></j>";"
//i[starts-with(., '"&ПСТР(E1;1;ДЛСТР(E1)-1)&"') 
and substring(., string-length(.) - string-length('"&ПСТР(E1;ДЛСТР(E1);1)&"') +1) = '"&ПСТР(E1;ДЛСТР(E1);1)&"' 
and string-length()="&ДЛСТР(E1)&"]"))
Изменено: Тимофеев - 27.09.2022 17:37:50
расчет сумм с разными значениями
 
Код
=СУММ(ЕСЛИ(--(ЦЕЛОЕ(C5:C8)=C5:C8)=1;C4;C3*2)*C5:C8)
График испытаний и осмотров, Автоматическое изменение даты
 
Код
=ЕСЛИ(G2=0;"не осматр";ДАТАМЕС(D2;G2))
VBA как компактнее написать перечисление условий
 
СПАСИБО!!! а через Array как-то можно тоже сделать для варианта на будущее?
Изменено: Тимофеев - 17.09.2022 14:15:46
VBA как компактнее написать перечисление условий
 
Добрый день, подскажите пожалуйста как запись вида
Код
If Cells(i, 1) = "6.3" Or Cells(i, 1) = "9.27" Or Cells(i, 1) = "9.30" Or Cells(i, 1) = "4.2" Or Cells(i, 1) = "2.32" _
Or Cells(i, 1) = "5.3" Or Cells(i, 1) = "12.1" Or Cells(i, 1) = "12.3" Or Cells(i, 1) = "12.9" Or Cells(i, 1) = "12.14" _
Or Cells(i, 1) = "12.15" Or Cells(i, 1) = "12.16" Or Cells(i, 1) = "12.17" Or Cells(i, 1) = "12.18" Or Cells(i, 1) = "12.19" _
Or Cells(i, 1) = "12.22" Or Cells(i, 1) = "12.25" Then
написать покороче
Разделение промежутка времени на дни, Есть дата и время старта и дата и время финиша. Необходимо разделить на промежутки.
 
Код
=ПОСЛЕД(ЦЕЛОЕ(C6)-ЦЕЛОЕ(B6)+1;1;ЦЕЛОЕ(B6);1)
=ЕСЛИ(ПОСЛЕД(ЦЕЛОЕ(C6)-ЦЕЛОЕ(B6)+1;1;ЦЕЛОЕ(B6);1)=ЦЕЛОЕ(B6);B6-ЦЕЛОЕ(B6);0)
=ЕСЛИ(ПОСЛЕД(ЦЕЛОЕ(C6)-ЦЕЛОЕ(B6)+1;1;ЦЕЛОЕ(B6);1)=ЦЕЛОЕ(C6);C6-ЦЕЛОЕ(C6);0.999305555555556)
Бланк в Exel, нужен бланк формата а3, со штампами (может в колонтитулах), чтоб в осн поле втавлять что хош, а форма бланка не менялась
 
Если таблицы для вставки одинаковы всегда, то можно и в ручную подогнать без проблем формат необходимый. Но думаю что они будут разные. Автокад вам больше подойдет для этой задачи, а вставлять и печатать готовое можно из Excel уже
Преобразование дат
 
Код
=ДАТА(D4;C4;B4)
Невозможно запустить макросы, Эксель блокирует макросы
 
Было такое, Вылечилось - сделать папки доверенными в безопасности
Как создать кнопку ,которая будет открывать Word файл?
 
Код
Sub Открыть_Word_Файл()
    Dim myWord As Object, myDocument As Object, WordFileName As String
     
    WordFileName = "Test.docx" 'название файла Word
    Set myWord = CreateObject("Word.Application")
    Set myDocument = myWord.Documents.Open(ThisWorkbook.Path & Application.PathSeparator & WordFileName)
    myWord.Visible = True
    'myWord.Activate
    myWord.WindowState = 1
End Sub
Разбить ячейки с данными (Не работает разделитель), Задача-разбить ячейки с каталожными номерами, чтобы в каждой ячейке было по одному номеру
 
Msi2102, да будет все не так с таким вариантом )
Разбить ячейки с данными (Не работает разделитель), Задача-разбить ячейки с каталожными номерами, чтобы в каждой ячейке было по одному номеру
 
Код
=ТРАНСП(ПОДСТАВИТЬ(ФИЛЬТР.XML("<j><i>"&ПОДСТАВИТЬ(ПОДСТАВИТЬ(B3;СИМВОЛ(32);"х");СИМВОЛ(10);"</i><i>")&"</i></j>";"//i");"ххххх";ЛЕВБ(B3;5)))
Перенос из ячейки выборочный текст
 
Код
ОГРН:
=ПСТР(A1;ПОИСК("ОГРН: ";A1)+6;13)
Дата:
=ПСТР(A1;ПОИСК("Дата присвоения ОГРН: ";A1)+22;10)

=ФИЛЬТР.XML("<j><i>"&ПОДСТАВИТЬ(A1;",";"</i><i>")&"</i></j>";"//i[contains(.,'Дата')]")
Изменено: Тимофеев - 07.09.2022 09:28:27
[ Закрыто] Форматнологическая проверка ячейки
 
а если -1 и пусто?
Код
=ЕСЛИОШИБКА(ЕСЛИ(ИЛИ(B11>17;B11<0;ЯЧЕЙКА("тип";B11)="b");"Ошибка";B11);"Ошибка")
Извлечение из текста двух и более дат
 
вот Вам пример коротенький, как вытащить 1 или 2 даты, по аналогии можете затащить 3-ю )
Код
=ТЕКСТ(
ПСТР(A2;ПОИСК("??.??.";A2);8)&
ТЕКСТ(ПСТР(A2;ПОИСК(".??.";A2)+6;2);"0;;;");"ДД.ММ.ГГГ")&"
"&
ЕСЛИОШИБКА(
ТЕКСТ(ПСТР(ПСТР(A2;ПОИСК(ТЕКСТ(--(ПСТР(A2;ПОИСК("??.??.";A2);8)&
ТЕКСТ(ПСТР(A2;ПОИСК(".??.";A2)+6;2);"0;;;"));"ДД.ММ.ГГГГ");A2)+11;1000);
ПОИСК("??.??.";ПСТР(A2;ПОИСК(ТЕКСТ(--(ПСТР(A2;ПОИСК("??.??.";A2);8)&
ТЕКСТ(ПСТР(A2;ПОИСК(".??.";A2)+6;2);"0;;;"));"ДД.ММ.ГГГГ");A2)+11;1000));8)&
ТЕКСТ(ПСТР(ПСТР(A2;ПОИСК(ТЕКСТ(--(ПСТР(A2;ПОИСК("??.??.";A2);8)&
ТЕКСТ(ПСТР(A2;ПОИСК(".??.";A2)+6;2);"0;;;"));"ДД.ММ.ГГГГ");A2)+11;1000);
ПОИСК(".??.";ПСТР(A2;ПОИСК(ТЕКСТ(--(ПСТР(A2;ПОИСК("??.??.";A2);8)&
ТЕКСТ(ПСТР(A2;ПОИСК(".??.";A2)+6;2);"0;;;"));"ДД.ММ.ГГГГ");A2)+11;1000))+6;2);"0;;;");"ДД.ММ.ГГГГ");
"")

Изменено: Тимофеев - 26.08.2022 18:40:20
Вставка картинки в ячейку по ссылке ЯндексДиска
 
чтоб картинка встала гиперссылка должна быть такой и сначала нужно как-то перейти на сайт по предыдущей ссылки и эту ссылку вытащить:
https://downloader.disk.yandex.ru/preview/9868c8a1329a5f0e87c7a4fd3611e32b1c173e84d6a4a5076­562e1170e...
Изменено: Тимофеев - 26.08.2022 16:41:54
Изменить расположение содержимого ячеек с вертикального в горизонтальное
 
Код
="http://wholesale.eropartner.com/product/"&
A2&
{"/highres/";"/web_images/";"/web_images/";"/web_images/"}&
"/"&
A2&
{"_hr.jpg";".jpg";"_mid.jpg";"_thumb.jpg"}
как понял
как в экселе найти второй или третий или четвертый плюс в одной ячейке, поиск вхождения 1 или 2 или 3 плюса(+)
 
Код
=ФИЛЬТР.XML("<j><i>"&ПОДСТАВИТЬ(A1;"+";"</i><i>")&"</i></j>";"//i[1]")
=ФИЛЬТР.XML("<j><i>"&ПОДСТАВИТЬ(A1;"+";"</i><i>")&"</i></j>";"//i[2]")
=ФИЛЬТР.XML("<j><i>"&ПОДСТАВИТЬ(A1;"+";"</i><i>")&"</i></j>";"//i[3]")
=ФИЛЬТР.XML("<j><i>"&ПОДСТАВИТЬ(A1;"+";"</i><i>")&"</i></j>";"//i[4]")
Изменено: Тимофеев - 24.07.2022 08:38:59
В каком случае скорость обработки будет быстрее?, Будет ли быстрее отфильтрованные данные
 
Можно попробовать подсказку "Право на ошибку"
Вызов формы по двойному клику не отрабатывает
 
Добрый день.
3 монитора установлено. На главном двойной клик вызывает форму, переношу Excel на второй монитор - форма тоже вызывается, а на третьем не хочет
Почему такое поведение? (Все мониторы разные - и по диагонали и по ориентации книжный и 2 альбомных)
И форма улетает на разные места хотя в макросе Gigant позиционирована вроде
Изменено: Тимофеев - 21.07.2022 15:46:33
Оптимизировать код удаления строк VBA по фильтру
 
все работает проверял
Код
.AutoFilter Field:=3, Criteria1:="<>Мандарины"
Изменено: Тимофеев - 21.07.2022 08:27:25
Подсчитать кол-во символов в диапазоне ячеек
 
Код
=СЧЁТЕСЛИМН(A12:P12;"в";A13:P13;8)
=СЧЁТЕСЛИМН(A12:P12;"вх";A13:P13;8)
ВПР с несколькими условиями, ВПР с несколькими условиями
 
Код
=ИНДЕКС(Лист1!A:H;ПОИСКПОЗ(B2&A2;Лист1!A:A&Лист1!H:H;0);{2;3;4;5;6;7})
Изменено: Тимофеев - 20.07.2022 16:48:40
Страницы: 1 2 3 4 5 6 7 8 9 10 11 ... 37 След.
Наверх