Выбрать дату в календареВыбрать дату в календаре

Страницы: 1 2 3 4 5 6 7 8 9 10 11 ... 28 След.
Функция ЕСЛИ-И с несколькими условиями при определенном критерии, Значения из одной одной таблицы на листе должны сравниваться со значениями в другой, находящимися на разных строках
 
Код
=ЕСЛИ(СУММЕСЛИ($F$3:$F$15;A3;$G$3:$G$15)<0;"нет";ЕСЛИ(СУММЕСЛИ($F$3:$F$15;A3;$G$3:$G$15)>0;"ок";""))
Ранжирование в PowerPivot по условиям на основе меры
 
Код
IF([Откл в Прод, руб. (2022г - 2021г)]<>BLANK();CALCULATE([Ранг2];ALLEXCEPT('Аналитики';'спрПодкатегории'[Подкатегория])))
Изменено: mechanix 85 - 05.08.2022 23:29:16
Ранжирование в PowerPivot по условиям на основе меры
 
возможно подскажут более красивый вариант

Код
=IF([Откл в Прод, руб. (2022г - 2021г)]<>BLANK();RANKX(FILTER(ALL('спрПодкатегории'[Подкатегория]);[Откл в Прод, руб. (2022г - 2021г)]<>BLANK());[Откл в Прод, руб. (2022г - 2021г)];;ASC))
Ранжирование в PowerPivot по условиям на основе меры
 
я думаю стоит начать с файла-примера и вручную покажите желаемый результат
Изменено: mechanix 85 - 05.08.2022 15:06:52
Доля подкатегории в Power BI, как посчитать долю элемента в группе элементов
 
Екатерина Смирнова, подробное руководство по dax
DAX формула, если пусто то данные с ячейки выше, Доброго времени суток ! помогите пожалуйста решить задачу
 
мопед не мой
ссылка от куда стащил https://community.powerbi.com/t5/Desktop/Repeat-last-value/m-p/530534

Код
= 
SUMX (
    'Календарь';
    VAR curPer = 'Календарь'[Date]
    RETURN
        IF (
            ISEMPTY ( RELATEDTABLE ( '1420' ) );
            CALCULATE (
                SUM ( '1420'[Кон. остаток] );
                LASTNONBLANK (
                    CALCULATETABLE ( 'Календарь'; 'Календарь'[Date] <= curPer );
                    COUNTROWS ( RELATEDTABLE ( '1420' ) )
                )
            );
            CALCULATE ( SUM ( '1420'[Кон. остаток] ) )
        )
)


зы: в excel формула не работает (по крайней мере в моей 2019 версии)
Изменено: mechanix 85 - 04.08.2022 15:04:40
DAX формула, если пусто то данные с ячейки выше, Доброго времени суток ! помогите пожалуйста решить задачу
 
файл вложите
Отбор значений по стоимости
 
или формулы или сводная таблица

только это отбор не самых дорогих или дешевых товаров, а поиск наибольшей и наименьшей цены на товар
Сортировка и фильтрация в Power Pivot на основании меры
 
Xanuman, так становитесь на сводную и сортируете по нужно мере
Сортировка и фильтрация в Power Pivot на основании меры
 
вариант

зы: для модели с годами и месяцами нужно будет немного подправить меры
Изменено: mechanix 85 - 03.08.2022 17:33:53
Power Query, Кавычки в номерах столбцов
 
ХЗ, может спецы дадут ответ
Power Query, Кавычки в номерах столбцов
 
Код
let
    source = Excel.CurrentWorkbook(){[Name="Столбцы"]}[Content][Столбцы]
in
    source
Сводная таблица с отображением пустых столбцов
 
tolikt,
Цитата
На вкладке Вывод в группе Вывод выполните одно или несколько из следующих действий.

Чтобы отображать или скрывать элементы без значений в строках, установите или снимите флажок Показывать элементы без данных в строках.

Примечание: Этот параметр доступен только для источника данных OLAP.

Чтобы отображать или скрывать элементы без значений в столбцах, установите или снимите флажок Показывать элементы без данных в столбцах.

Примечание: Этот параметр доступен только для источников данных OLAP.

а так как я только с такими источниками и работаю, то поэтому к этой галочке меня и привело сразу
Изменено: mechanix 85 - 02.08.2022 16:21:19
Сводная таблица с отображением пустых столбцов
 
тогда без файла можно долго гадать
Сводная таблица с отображением пустых столбцов
 
пересохраните файл в xlsx
Сводная таблица с отображением пустых столбцов
 
вот эти галочки установите
Смещение относительно текущего месяца в power pivot
 
Твердый, чисто логически если подумать, что таблица с данными содержит 10 млн. строк, а пользователю нужны еще такие колонки как Год, Месяц, Название Месяца, Год+Месяц, День, День недели и т.д. то размер файл вырастет как грибы после дождя
Power Query. Выбор максимального значения.
 
так?

Код
let
    Источник = Excel.CurrentWorkbook(){[Name="Таблица1"]}[Content],
    #"Измененный тип" = Table.TransformColumnTypes(Источник,{{"Столбец1", Int64.Type}}),
    #"Вставленные первые символы" = Table.AddColumn(#"Измененный тип", "Первые символы", each Text.Start(Text.From([Столбец1], "ru-RU"), 3), type text),
    #"Сгруппированные строки" = Table.Group(#"Вставленные первые символы", {"Первые символы"}, {{"Количество", each List.Max([Столбец1]), type number}}),
    #"Удаленные столбцы" = Table.RemoveColumns(#"Сгруппированные строки",{"Первые символы"})
in
    #"Удаленные столбцы"
Power Pivot итоги за неделю по последнему дню недели
 
Код
=AVERAGEX(VALUES('остатки'[дата]);CALCULATE(SUM('остатки'[остаток])))
скользящее среднее по сумме выручки
 
так?
Код
=CALCULATE(AVERAGEX(SUMMARIZE('Продажи';'Календарь'[Год];'Календарь'[Номер месяца]);[Выручка]); DATESINPERIOD('Календарь'[Date];MAX('Календарь'[Date]); -1; YEAR))
Как через PowerQuery получить отфильтрованный список по условию
 
нужна таблица с еще другими столбцами в таблице или нужно получить только макс дату?
Power BI. Расчет количества сделок на последней выбранной стадии.
 
так?

Код
=COUNTROWS(FILTER( ADDCOLUMNS( 'Лист1';"_max";CALCULATE(MAX('Лист1'[Дата и время попадания на стадию]);ALLEXCEPT('Лист1';'Лист1'[Идентификатор сделки])));'Лист1'[Дата и время попадания на стадию]=[_max]))
Соединить 2 таблицы в Dax Studio
 
тогда вложите эти две таблицы в файл excel
Соединить 2 таблицы в Dax Studio
 
Что значит соединить? сведение или присоединение?

в любом случае нужен пример с желаемым результатом
В DAX рассчитать среднюю, игнорируя один из столбцов
 
У Вас есть таблица, у нас нету
Объединение 2 полей в сводной таблице, Объединение 2 полей в сводной таблице год и месяц в поле с подгруппой
 
создайте иерархию, если речь про DAX
Формирование сводной таблицы в Google Таблицах
 
так пойдет? в B3 на своде
Код
=СУММПРОИЗВ(('Общий список'!$I$2:$I$1000=$A3)*('Общий список'!$A$2:$A$1000<=B$2)*('Общий список'!$B$2:$B$1000>=B$2)*'Общий список'!$D$2:$D$1000)
Изменено: mechanix 85 - 13.07.2022 19:07:09
Посчитать динамический прирост доли в Power bi
 
В примере бы показали, что нужно
Посчитать динамический прирост доли в Power bi
 
вариант
DAX SUMMARIZE помогите
 
так?

Код
 =ADDCOLUMNS( SUMMARIZE (
    data;Data[Store];Data[Date]);
    "Value All Stores SUMMARIZED";CALCULATE([Value];ALLEXCEPT(Data;'Data'[Date]))
    ) 
Страницы: 1 2 3 4 5 6 7 8 9 10 11 ... 28 След.
Наверх