Поиск  Пользователи  Правила 
Закрыть
Логин:
Пароль:
Забыли свой пароль?
Регистрация
Войти
 
Выбрать дату в календареВыбрать дату в календаре

Страницы: 1 2 3 4 5 6 7 8 9 10 11 ... 348 След.
Корректировка позиции для получения результата при поиске в диапазоне с объединенными ячейками
 
Тема: "Корректировка позиции для получения результата при поиске в диапазоне с объединенными ячейками"
вот так
Код
=ИНДЕКС($A$12:$G$12;ПОИСКПОЗ(A15;$A$2:$G$2;0)+1)
Лень двигатель прогресса, доказано!!!
Корректировка позиции для получения результата при поиске в диапазоне с объединенными ячейками
 
СМЕЩ летучая будет пересчитыватся каждый раз тогда уж лучше используйте ИНДЕКС с ПОИСКПОЗ с корректировкой позиции на 1  
Лень двигатель прогресса, доказано!!!
Корректировка позиции для получения результата при поиске в диапазоне с объединенными ячейками
 
лучше опишите задачу почему ищем 2 и смещаемся но столбец у которого значение 3 с итогом 26
Лень двигатель прогресса, доказано!!!
Суммирование данных в скобках
 
БМВ,  :D  я скачал посмотреть твое решение и его же прицепил
Лень двигатель прогресса, доказано!!!
Суммирование данных в скобках
 
массивная формула вводится комбинацией клавиш контрл+шифт+энтер
Изменено: Сергей - 28 Фев 2020 09:53:25
Лень двигатель прогресса, доказано!!!
Суммирование данных в скобках
 
Цитата
Dmw написал:
Данная часть не работает на массив
у меня работает, внимательно читать надо или это вам ни о чем не говорит
Цитата
Сергей написал:
массивная в F3
Лень двигатель прогресса, доказано!!!
Суммирование данных в скобках
 
массивная в F3 и протянуть вправо
Код
=СУММ(ЕСЛИОШИБКА(--ПОДСТАВИТЬ(ПОДСТАВИТЬ(ПОДСТАВИТЬ($B$3:$E$3;F2;"");"(";"");")";"");0))+СЧЁТЕСЛИ($B$3:$E$3;F2)*8
Лень двигатель прогресса, доказано!!!
Скидка в зависимости от кратности
 
если от общего кол-ва товаров ячейка G10 то так можно в L4
Код
=ВПР(G10;{0;0:3;0,35:6;0,4:12;0,45};2;1)
Лень двигатель прогресса, доказано!!!
Скидка в зависимости от кратности
 
честно не понятно что надо то у вас же считается скидка по каждому товару
Лень двигатель прогресса, доказано!!!
Не работает пересчет формул
 
набросок в файле растянуть вправо и вниз
1. проблема придется в выборе прописать один раз 20 листов
2. проблема пока не придумал нумерация существующих листов
Код
=ЕСЛИОШИБКА(ИНДЕКС(ВЫБОР($B3;А!$B:$D;Б!$B:$D;Г!$B:$D;Е!$B:$D);3;СТОЛБЕЦ()-3);)
Лень двигатель прогресса, доказано!!!
создание выпадающего списка из закрытой книги Excel
 
Цитата
artemkau88 написал:
Я описал проблему
описываем решение
1 Создать макрос который приоткрытии файла будет обращаться к файлу БД и забирать оттуда последние данные и формировать на основании них список
2 Создать скрытый лист в который с помощью ИНДЕКС тянем ФИО, адрес и на основании этого листа строим список
Лень двигатель прогресса, доказано!!!
создание выпадающего списка из закрытой книги Excel
 
Цитата
artemkau88 написал:
Если невозможно, так и напишите, задам вопрос на другом форуме
в первом же ответе
Цитата
БМВ написал:
Но не все потеряно. Вы покажите что хочется получит, из каких данных. Может и решение найдется.
вы читать не умеете или смысл понять не можете  
Лень двигатель прогресса, доказано!!!
Подстановка значений ячеек из разных столбцов
 
ВПР(что ищем;где ищем;ячейка настройки;0)
Лень двигатель прогресса, доказано!!!
Сравнение ячеек по условию.
 
как вариант
Код
=ЕСЛИ(ВПР(A2;$A$2:$B$18;2;1)=ВПР(A2;$A$2:$B$18;2;0);"одинаковые";"разные")
Лень двигатель прогресса, доказано!!!
Подстановка значения при наличии частичного совпадения значения с диапазоном данных
 
Цитата
Splinter Cell написал:
В чем фишка деления 1
что бы найти ПРОСМОТРом 2
Лень двигатель прогресса, доказано!!!
Подстановка значения при наличии частичного совпадения значения с диапазоном данных
 
нормальные примеры надо прилагать с различными вариантами написания этих номеров
Лень двигатель прогресса, доказано!!!
Подстановка значения при наличии частичного совпадения значения с диапазоном данных
 
о чем было говорено выше
Лень двигатель прогресса, доказано!!!
Подстановка значения при наличии частичного совпадения значения с диапазоном данных
 
файл пример где
без него в помощь вам ПРАВСИМВ и ВПР
Лень двигатель прогресса, доказано!!!
Найти в диапазоне сумму наибольших Х значений
 
что, где, почему покажите в примере сейчас как то все сумбурно
Лень двигатель прогресса, доказано!!!
Как формулой сделать с ссылки на ячейки с шагом в один столбец
 
в А7 и растянуть вправо и вниз
Код
=ЕСЛИ(ОСТАТ(СТОЛБЕЦ();2);ИНДЕКС($A3:$I3;ОКРВВЕРХ(СТОЛБЕЦ()/2;1));"")
Лень двигатель прогресса, доказано!!!
создание формулы с двумя сценариями и 4 подсценариями
 
чуть чуть покороче
Код
=(($C$9=1)*ЕСЛИ(D9<=0,43;0,6111+СУММПРОИЗВ({124,75:-9418,4:146737:-731929:2000000:-1000000}*(D9^СТРОКА($A$1:$A$6)));502,96+СУММПРОИЗВ({-1173,1:1262,4:-710,49:217,41:-34,263:2,1751}*(D9^СТРОКА($A$1:$A$6)))))+(($C$9=2)*ЕСЛИ(D9<=0,32;0,351+СУММПРОИЗВ({128,14:-12894:282415:-2000000:6000000:-6000000}*(D9^СТРОКА($A$1:$A$6)));346,83+СУММПРОИЗВ({-662,65:604,87:-277,81:63,003:-5,6569:-200000000}*(D9^СТРОКА($A$1:$A$6)))))
Изменено: Сергей - 25 Фев 2020 12:23:29 (не то скопировал)
Лень двигатель прогресса, доказано!!!
Как вывести результаты суммирования в отдельную таблицу
 
Тема: "Подсчет суммы значений с однотипных таблиц расположенных на разных листах без учета отрицательных значений. Интересует формула"
в В4 и вниз
Код
=СУММПРОИЗВ(СУММЕСЛИ(ДВССЫЛ({"январь!":"февраль!":"март!"}&"B"&СТРОКА());">0";ДВССЫЛ({"январь!":"февраль!":"март!"}&"B"&СТРОКА())))
Лень двигатель прогресса, доказано!!!
Сравнить столбцы и подставить соответствующие параметры
 
в B2 потом вправо и вниз
Код
=ВПР($A2;$I$2:$K$24;СТОЛБЕЦ();0)
Лень двигатель прогресса, доказано!!!
Прописать Макрос по трансформации даты 27 грудня 2019 року на 27.12.2019, если даты, месяц и год разные по всему столбце
 
изучите сайт планеты тут много чего есть
Лень двигатель прогресса, доказано!!!
Прописать Макрос по трансформации даты 27 грудня 2019 року на 27.12.2019, если даты, месяц и год разные по всему столбце
 
на последнем примере отработала полностью
Код
=ЕСЛИ(ЕЧИСЛО(--I6);I6;--(ЛЕВБ(I6;2)&"."&ПОИСК(ПСТР(СЖПРОБЕЛЫ(ПОДСТАВИТЬ(I6;ПСТР(I6;1;2);""));1;3);"  січлютберквітрачерлипсервержовлисгру")/3&"."&ПРАВБ(ПОДСТАВИТЬ(ПОДСТАВИТЬ(ПОДСТАВИТЬ(I6;" ";"");"р";"");".";"");4)))
Лень двигатель прогресса, доказано!!!
Прописать Макрос по трансформации даты 27 грудня 2019 року на 27.12.2019, если даты, месяц и год разные по всему столбце
 
запись исходника "28 травня 2019р." не тоже самое что в приложенном первом примере "28 травня 2019"  
Лень двигатель прогресса, доказано!!!
Прописать Макрос по трансформации даты 27 грудня 2019 року на 27.12.2019, если даты, месяц и год разные по всему столбце
 
Цитата
Isobev написал:
У меня в таблице ошибка
значит пример который вы приложили не соответствует исходным данным какие у вас есть
Лень двигатель прогресса, доказано!!!
Прописать Макрос по трансформации даты 27 грудня 2019 року на 27.12.2019, если даты, месяц и год разные по всему столбце
 
паразитирование на формуле Михаил Л,
Код
=ЕСЛИ(ЕЧИСЛО(--F3);F3;--(ЛЕВБ(F3;2)&"."&ПОИСК(ПСТР(СЖПРОБЕЛЫ(ПОДСТАВИТЬ(F3;ПСТР(F3;1;2);""));1;3);"  січлютберквітрачерлипсервержовлисгру")/3&"."&ПРАВБ(СЖПРОБЕЛЫ(F3);4)))
Лень двигатель прогресса, доказано!!!
Как посчитать количество дней между двумя датами которые входят в другой диапазон дат?
 
Цитата
Death написал:
ничего в ней не понимаю
прогоните через инструмент вычислить формулу
Лень двигатель прогресса, доказано!!!
Найти максимальное значение для одинаковых имен и присвоить им имя
 
для картинки
Код
=ЕСЛИ(МАКС(ЕСЛИ())=ячейка;истина;ложь)
Лень двигатель прогресса, доказано!!!
Страницы: 1 2 3 4 5 6 7 8 9 10 11 ... 348 След.
Наверх