Поиск  Пользователи  Правила 
Закрыть
Логин:
Пароль:
Забыли свой пароль?
Регистрация
Войти
 
Выбрать дату в календареВыбрать дату в календаре

Страницы: 1 2 3 4 5 6 7 8 9 10 11 ... 332 След.
Суммирование одной и той же ячейки
 
ни че не понял но может угадал в О5 и растянуть в право
Код
=$D$4*СЧЁТЕСЛИ($G$5:$M$5;O7)
Лень двигатель прогресса, доказано!!!
Подсчёт количества уникальных значений с учётом условия
 
в С2 и вниз
Код
=ЕСЛИ(СЧЁТЕСЛИ($A$2:A2;A2)=1;СЧЁТЕСЛИ($A$2:$A$22;A2);"")
Лень двигатель прогресса, доказано!!!
Подсчёт количества уникальных значений с учётом условия
 
.
Лень двигатель прогресса, доказано!!!
Подсчёт количества уникальных значений с учётом условия
 
Цитата
MishaBublik написал:
но у меня таблица большая
а у нас даже маленькой нет
Лень двигатель прогресса, доказано!!!
Удалить из строки символ "≈"
 
макрорекодер рисует такое
Код
Sub Макрос1()

    Cells.Replace What:="?", Replacement:="", LookAt:=xlPart, SearchOrder:= _
        xlByRows, MatchCase:=False, SearchFormat:=False, ReplaceFormat:=False
End Sub
Лень двигатель прогресса, доказано!!!
Вывести номер столбца второго совпадения минимального значения из массива, при этом игнорируя нули
 
ни че не понятно
Лень двигатель прогресса, доказано!!!
ячейки с зада :), и такое бывает
 
БМВ,  :D  
Лень двигатель прогресса, доказано!!!
Суммирование сгруппированных ячеек
 
жесточайшее извращение с использованием макрофункции
Лень двигатель прогресса, доказано!!!
Вставить данные из первой не пустой ячейки из списка ячеек (не диапазона)
 
вариант
Код
=ПРОСМОТР(2;1/(ЕТЕКСТ(B5:J5)*{0;1;0;0;1;0;0;1;0});B5:J5)
Лень двигатель прогресса, доказано!!!
Вставить данные из первой не пустой ячейки из списка ячеек (не диапазона)
 
Цитата
Fox54 написал:
в это и суть
обоснуйте чем не устраивает формула она работает не так как хотелось, она некрасивая или это дело принципа что бы только перечисленные ячейки нужны тогда ваш пример корявый для поставленной задачи
Лень двигатель прогресса, доказано!!!
Суммирование в двумерной таблице всех значений, удовлетворяющих условиям.
 
Код
=СУММЕСЛИ($A$4:$A$15;K4;ИНДЕКС($B$4:$I$15;;ПОИСКПОЗ(K3;$B$3:$I$3;0)))
Изменено: Сергей - 12 Сен 2019 16:36:45 (ужос чет у меня глюки какието)
Лень двигатель прогресса, доказано!!!
Вытянуть формулами данные из графика, -месяц, год по показатлю КРЛП
 
Код
ЕСЛИОШИБКА(ИНДЕКС($E$14:$BL$14;ПОИСКПОЗ("КРЛП";$E15:$BL15;0));"")
со второй аналогично
Лень двигатель прогресса, доказано!!!
Вытянуть формулами данные из графика, -месяц, год по показатлю КРЛП
 
месяц
Код
=ЕСЛИ(ЕОШИБКА(ИНДЕКС($E$14:$BL$14;ПОИСКПОЗ("КРЛП";$E15:$BL15;0)));"";ИНДЕКС($E$14:$BL$14;ПОИСКПОЗ("КРЛП";$E15:$BL15;0)))
год
Код
=ЕСЛИ(ЕОШИБКА(2020+ОКРУГЛВВЕРХ(ПОИСКПОЗ("КРЛП";$E15:$BL15;0)/12;)-1);"";2020+ОКРУГЛВВЕРХ(ПОИСКПОЗ("КРЛП";$E15:$BL15;0)/12;)-1)
если бы не эксель 2003 то формула бы короче раза в два
Лень двигатель прогресса, доказано!!!
Разрешения изменения динамического диапазона
 
что хотите получить в результате если откинуть динамические диапазоны
Лень двигатель прогресса, доказано!!!
Выборка всех одинаковых значений столбца по имени на новый лист
 
аналогично для других листов
Лень двигатель прогресса, доказано!!!
Поиск значений, расположенных в заданных ячейках расположенных на листе произвольно., Двумерный поиск по таблице
 
название не очень и описание не очень Р может появится сразу в нескольких местах если нет то зачем ограничивать поиск и очень не хватает файла примера в формате эксель
Лень двигатель прогресса, доказано!!!
Выборочные вычисления по нескольким критериям с учетом даты
 
формулами можно так на вскидку
Лень двигатель прогресса, доказано!!!
Перенос данных если совпадает значение., Упростить банальную =ЕСЛИ
 
в столбце AD создаем доп столбец и тогда обычной формулой можно подтягивать
Код
=ИНДЕКС(ИНДЕКС($C$60:$AC$241;ПОИСКПОЗ("*"&L3&"*";$AD$60:$AD$241;0)+1;);ПОИСКПОЗ(L3;ИНДЕКС($C$60:$AC$241;ПОИСКПОЗ("*"&L3&"*";$AD$60:$AD$241;0););0))
Лень двигатель прогресса, доказано!!!
Поиск значения по нескольким условиям(больше двух), Функция поискпоз
 
смотрите в файле, а про +1 ИНДЕКС:ИНДЕКС это мы формируем диапазон для основной формулы где искать нам нужное первый индекс находит дату второй тоже находит эту же дату но позицию мы корректируем на +1 так как у нас две смены в одной дате
Лень двигатель прогресса, доказано!!!
Поиск значения по нескольким условиям(больше двух), Функция поискпоз
 
каков пример такое и решение в примере была одна строка
Лень двигатель прогресса, доказано!!!
Поиск значения по нескольким условиям(больше двух), Функция поискпоз
 
пробегитесь по формуле через инструмент вычислить думаю все поймете
Лень двигатель прогресса, доказано!!!
Поиск значения по нескольким условиям(больше двух), Функция поискпоз
 
вариант в А9 дата в А10 код смены
Код
=ИНДЕКС(ИНДЕКС($C$4:$L$4;ПОИСКПОЗ(A9;$C$1:$L$1;0)):ИНДЕКС($C$4:$L$4;ПОИСКПОЗ(A9;$C$1:$L$1;0)+1);ПОИСКПОЗ(A10;ИНДЕКС($C$3:$L$3;ПОИСКПОЗ(A9;$C$1:$L$1;0)):ИНДЕКС($C$3:$L$3;ПОИСКПОЗ(A9;$C$1:$L$1;0)+1);0))
Лень двигатель прогресса, доказано!!!
Подсчет количества уникальных значений ячеек, соответствующих нескольким критериям
 
Код
=СУММ(--(ПОИСКПОЗ(ЕСЛИ((Таблица1[Место]=I5)*(Таблица1[Дата]>=I6)*(Таблица1[Дата]<=I7);Таблица1[продукт]);ЕСЛИ((Таблица1[Место]=I5)*(Таблица1[Дата]>=I6)*(Таблица1[Дата]<=I7);Таблица1[продукт]);0)=СТРОКА(Таблица1[Место])-5))-1
Лень двигатель прогресса, доказано!!!
Подсчет количества уникальных значений ячеек, соответствующих нескольким критериям
 
массивная
Код
=СУММ((ПОИСКПОЗ(ЕСЛИ(Таблица1[Место]=I5;Таблица1[продукт]);ЕСЛИ(Таблица1[Место]=I5;Таблица1[продукт]);0)=СТРОКА(Таблица1[Место])-5)*(Таблица1[Дата]>=I6)*(Таблица1[Дата]<=I7))-1
Лень двигатель прогресса, доказано!!!
подсчет количества дат до указанной даты, подсчет количества записей до указанной даты
 
непонятно пока что надо
Лень двигатель прогресса, доказано!!!
Поиск ячеек с числами в строках с определенным количеством столбцов
 
пример в файле где что есть что надо
Лень двигатель прогресса, доказано!!!
Определение номера позиции в динамической таблице
 
чет упустил этот момент тогда два допстолбца
Лень двигатель прогресса, доказано!!!
Определение номера позиции в динамической таблице
 
с допстолбцом если нужна отельная нумерация в разных столбцах то формулу разделить
Лень двигатель прогресса, доказано!!!
Изменение адреса абсолютной ссылки по условиям
 
в C2 и протянуть вниз потом где не надо удалить формулу
Код
=A2-ПРОСМОТР(2;$B$1:B2;$A$1:A2)
Лень двигатель прогресса, доказано!!!
проверка на корректность введенных данных(р\с, бик)
 
если бы поискали наверное уже бы бесплатно нашли на форуме есть такие темы
Лень двигатель прогресса, доказано!!!
Страницы: 1 2 3 4 5 6 7 8 9 10 11 ... 332 След.
Наверх