Поиск  Пользователи  Правила 
Закрыть
Логин:
Пароль:
Забыли свой пароль?
Регистрация
Войти
 
Выбрать дату в календареВыбрать дату в календаре

Страницы: 1 2 3 4 5 6 7 8 9 10 11 ... 339 След.
Автозаполнение диапазона столбцов после выбора из выпадающего списка
 
вообщем всего глобального замысла не понял вот вариант
Лень двигатель прогресса, доказано!!!
Автозаполнение диапазона столбцов после выбора из выпадающего списка
 
сделать не сложно и формулой только вопрос зачем в столбце В в каждой ячейке выпадающий список
Лень двигатель прогресса, доказано!!!
Расчет часов с минутами в табеле учета рабочего времени при выходе на работу
 
если будете вводить нормальные числа а не текст то для подсчета вполне хватит таких формул
ДНИ =СУММПРОИЗВ(--ЕЧИСЛО(F16:T16)) или =СЧЁТЕСЛИ(F16:T16;">0")
часы =СУММ(F16:T16)
Лень двигатель прогресса, доказано!!!
Поиск ближайшей даты по условиям, Формула массива
 
Цитата
olkuzn написал:
Уже сам модифицировал формулу.
ха ха ха это было час назад
Цитата
Сергей написал:
Код ? 1=ЕСЛИОШИБКА(ИНДЕКС($I$1:$I$2001;НАИМЕНЬШИЙ(ЕСЛИ(ABS($G$2:$G$2001-B$2)=МИН(ABS($G$2:$G$2001-B$2))*($H$2:$H$2001=$B$3);СТРОКА($G$2:$G$2001));СТРОКА($F1)));"")

Лень двигатель прогресса, доказано!!!
Поиск ближайшей даты по условиям, Формула массива
 
Цитата
olkuzn написал:
Условно мне необходимо, чтобы эта формула в данном примере вывела мне Дизель 95
Код
=ЕСЛИОШИБКА(ИНДЕКС($I$1:$I$2001;НАИМЕНЬШИЙ(ЕСЛИ(ABS($G$2:$G$2001-B$2)=МИН(ABS($G$2:$G$2001-B$2))*($H$2:$H$2001=$B$3);СТРОКА($G$2:$G$2001));СТРОКА($F1)));"")
Лень двигатель прогресса, доказано!!!
Поиск ближайшей даты по условиям, Формула массива
 
"Обратите внимание, что если G6 будет равен 04.01.2018 или 06.01.2018, то выводимых значений должно быть два: 627,17 и 627,18"
а если в данных будет еще и 05.01.2018 тогда три суммы выводить?
эт я к чему пока вводные плавающие и вы их постоянно подкидываете нормального решения не получите, подумайте хорошо и уже определитесь что надо может вообще нужно выбрать минимум по сумме из трех ближайших дат
Лень двигатель прогресса, доказано!!!
Большой столбец в маленькие
 
еще вариант формулой в А1 на листе как надо и растянуть вправо и вниз
Код
=ЕСЛИ(СТРОКА()>20;"стоп";ИНДЕКС('Что есть'!$A:$A;СТРОКА()+20*(СТОЛБЕЦ(A1)-1)))
Лень двигатель прогресса, доказано!!!
"счётеслимн" не хочет считать
 
в своем файле в столбце F встаньте на ячейку с датой установите формат ячейки общий вы увидите что ни чего не изменилось дак была типа дата так и осталась типа дата, после этого перейдите в мой пример проделайте туже манипуляцию посмотрите как изменится отображение даты
Лень двигатель прогресса, доказано!!!
"счётеслимн" не хочет считать
 
Цитата
Marus написал:
Так готового ответа никто
тут готовый ответ только принесет ли он вам пользу когда возникнет подобная проблема
Лень двигатель прогресса, доказано!!!
"счётеслимн" не хочет считать
 
у вас Даты в виде текста
Лень двигатель прогресса, доказано!!!
Неправильное кол-во аргументов в функции =ЕСЛИ(И(
 
Vadim_Zz, ваш файл открывается с ошибками
Лень двигатель прогресса, доказано!!!
Суммирование показателей по накопительной на заданную дату
 
в D5
Код
=СУММЕСЛИМН($I5:$AX5;$I$4:$AX$4;"<="&$G$2;$I$4:$AX$4;">="&КОНМЕСЯЦА($G$2;-1)+1)
Лень двигатель прогресса, доказано!!!
Неправильное кол-во аргументов в функции =ЕСЛИ(И(
 
Vadim_Zz, скобки смотрите внимательно функция "И" не закрыта и что будет если ЛОЖЬ не указано
Лень двигатель прогресса, доказано!!!
Каким образом сделать так,чтобы выделялись данные по конкретной дате, Выделение столбца с данными по конкретной дате
 
вариант
Лень двигатель прогресса, доказано!!!
Подсчет транзакций у ID
 
вариант с доп столбцом
Лень двигатель прогресса, доказано!!!
Подсчет транзакций у ID
 
Цитата
Jack Famous написал:
Делайте нормальный пример
поддерживаю не понятно вообще
1. показать просто что за представленный период хоть в одном дне были 2 покупки
2. показать просто что за представленный период за 7 (30) дней было 5 покупок, ТОГДА вопрос как определить период из 7 (30) где он начинается а где заканчивается по датам
Лень двигатель прогресса, доказано!!!
Как при одинаковом населении получить из справочника разные города
 
Цитата
Gaust написал:
но: Сергей  - в вашем файле нет дополнительных столбцов
есть только он был скрыт, вот с отображенным с поправленной формулой
Лень двигатель прогресса, доказано!!!
Как при одинаковом населении получить из справочника разные города
 
если допустим доп столбец то вот вариант
Лень двигатель прогресса, доказано!!!
Сумма за все прошедшие месяцы с начала года
 
Цитата
Lelya7 написал:
янвфевмарапр
пример в файле нужно что там у вас просто текст названия месяцев или полноценные даты
Лень двигатель прогресса, доказано!!!
Суммирование чисел-текстовых форматов
 
вариант
Код
=--ПОДСТАВИТЬ(ПОДСТАВИТЬ(G10;СИМВОЛ(10););".";",")
Лень двигатель прогресса, доказано!!!
Присвоить числовому диапазону категорию
 
Цитата
casablanca написал:
Excel пишет, что введено слишком много аргументов для этой функции ............Просто мне нужна, как для начинающего, наиболее простая формула
ну дак нужна простая с которой вы разобраться не можете или нужна рабочая формула вот до 60 лет
Код
=ВПР(A2;{20;1:25;2:30;3:35;4:40;5:45;6:50;7:55;8:60;9};2;1)
Изменено: Сергей - 18 Ноя 2019 13:09:03 (формулу поправил интервал в 5 лет)
Лень двигатель прогресса, доказано!!!
Присвоить числовому диапазону категорию
 
вариант
Код
=ЕСЛИ(A2>=30;3;ЕСЛИ(A2<25;1;2))
Лень двигатель прогресса, доказано!!!
Поиск значения по определенной дате.
 
вариант
Код
=ЕСЛИОШИБКА(ПРОСМОТР(2;1/((B2:B25=G1)*(H1>=C2:C25)*(H1<=D2:D25));E2:E25);"працует")
Лень двигатель прогресса, доказано!!!
Найти среднее количество календарных дней которые работала машина с двумя условиями: название машины и страны
 
так можно массивной или доп столбец и срзначеслимн
Код
=СРЗНАЧ(ЕСЛИ(($A$2:$A$13=$G2)*($B$2:$B$13=H$1);$D$2:$D$13-$C$2:$C$13))
Лень двигатель прогресса, доказано!!!
Подтянуть информацию из массива данных при соблюдении нескольких условий
 
еще вариант
массивная
Код
=ВПР(A2;ЕСЛИ($I$2:$I$6=B2;$G$2:$H$6);2;0)
не массивная
Код
=ПРОСМОТР(2;1/(($G$2:$G$6=A2)*($I$2:$I$6=B2));$H$2:$H$6)
Лень двигатель прогресса, доказано!!!
Получение сводной из значений, Получение количества
 
Формула МАССИВА
Лень двигатель прогресса, доказано!!!
Получение сводной из значений, Получение количества
 
в рамках реализации непонятного подхода формула массива в H6 и растянуть вниз
Код
=ЕСЛИОШИБКА(ПРОИЗВЕД(ЕСЛИ($E$6:$E$10*(($C$6:$C$10=C6)+($C$6:$C$10=G6)+($C$6:$C$10=ВПР(G6;$C$6:$G$10;5;0))+($C$6:$C$10=ЕСЛИОШИБКА(ВПР(ВПР(G6;$C$6:$G$10;5;0);$C$6:$G$10;5;0);)))=0;1;$E$6:$E$10*(($C$6:$C$10=C6)+($C$6:$C$10=G6)+($C$6:$C$10=ВПР(G6;$C$6:$G$10;5;0))+($C$6:$C$10=ЕСЛИОШИБКА(ВПР(ВПР(G6;$C$6:$G$10;5;0);$C$6:$G$10;5;0);)))));)
Лень двигатель прогресса, доказано!!!
Получение сводной из значений, Получение количества
 
Цитата
a4step написал:
Не вижу логики
в ваших примерах она тоже пока не наблюдается, желаемый результат какой и как получается
Лень двигатель прогресса, доказано!!!
Массив с повторяющимися значениями
 
по существу что не так, пример нормальный показывайте если пересечение строка столбец единично данная формула отработает  
Лень двигатель прогресса, доказано!!!
Массив с повторяющимися значениями
 
вариант
Лень двигатель прогресса, доказано!!!
Страницы: 1 2 3 4 5 6 7 8 9 10 11 ... 339 След.
Наверх