Поиск  Пользователи  Правила 
Закрыть
Логин:
Пароль:
Забыли свой пароль?
Регистрация
Войти
 
Выбрать дату в календареВыбрать дату в календаре

Страницы: 1 2 3 4 5 6 7 8 9 10 11 ... 351 След.
Метод Replace замена формата времени
 
FrinG, из объяснения+пример все равно непонятно, что нужно получить.
Нарисуйте в файле руками, что должно получиться.
Метод Replase вам не подойдет, как мне кажется.
Изменено: Михаил Витальевич С. - 2 янв 2021 04:32:11
Поиск значения на основе соответствия одного столбца нескольким
 
В файле два варианта: с дополнительным столбцом и обычный ВПР, и формула массива без доп. столбца.
Поиск значения на основе соответствия одного столбца нескольким
 
Вадим Комаровский, Так у вас файл Googl-Tabs, или Excel?
Если гугл - то нужно дать доступ на редактирование, и ссылку на сам файл; если Excel, внизу ответа ссылка - "Загрузить файлы"
Поиск значения на основе соответствия одного столбца нескольким
 
Цитата
Вадим Комаровский написал:
На 1-м листе есть столбец ФИО, на 2-м листе есть 3 столбца Фамилия,
Вадим Комаровский, открываю файл эксель; в нем всего один лист, и тот пустой...
Почему при использовании поиска вместо 4/1 отображается 43834
 
Цитата
sokol92 написал:  Не совсем так.
имеется ввиду, что если в Excel введем, например, 4/1, то это сразу преобразуется в дату - 4.янв (в русской версии); в гугл-табс в ячейке так и будет - 4/1, хотя в строке формул будет 04.01.20, если формат числовой. Если числовой формат поменяем на текстовый, то в строке формул станет 4/1.
Почему при использовании поиска вместо 4/1 отображается 43834
 
benel, в вашем файле на первом листе был числовой формат; в этом случае гугл воспринимает их как даты (excel в таком виде - тоже, но сразу переводит в дату)
Выделите три столбца, формат-числа - обычный текст.
Результат в файле по вашей ссылке.
Изменено: Михаил Витальевич С. - 31 дек 2020 00:51:25 (Очепятки)
Заполнение ячейки выбором с другого листа из нескольких колонок
 
Макросом возможно.
Для того, что б сделать нормальный макрос - слишком мало данных на листе "Орган".
Почему при использовании поиска вместо 4/1 отображается 43834
 
benel, делайте пример в Google Таблице, ссылку сюда.
И не забудьте дать доступ на правку.
Перемножение массивов с условием
 
Александр Шиллер, если нужно умножить на D1:D33, исключая строки с ошибками:
=СУММПРОИЗВ(A1:A33;B1:B33+C1:C33;ЕСЛИОШИБКА(D1:D33;0))
если просто исключить строки, где в D1:D33 ошибки то:
=СУММПРОИЗВ(A1:A33;B1:B33+C1:C33;ЕСЛИ(ЕОШИБКА(D1:D33);0;1))
обе формулы массива
Удаление данных  с листа, макросов, модулей, после несанкционированного открытия файла (взлома пароля VBA)
 
Цитата
vikttur написал: Такие вопросы обычно задают начинающие.
Цитата
Volounteer написал: наступает просветление и осознание того, что защищать то и нечего по сути
Анекдот дня, Постим сюда понравившиеся:)
 
Немецкая семья разгадывает кроссворд:
- Любимый в России суп на основе свеклы, красного цвета, 4 буквы, последняя буква schtsch?
Словарь (Scripting.Dictionary). Соответствие массивов ключей и элементов между собой
 
Цитата
Дмитрий(The_Prist) Щербаков написал:
если используется позднее связывание
я раннее связывание ни разу не использовал...
Словарь (Scripting.Dictionary). Соответствие массивов ключей и элементов между собой
 
Да, я сиё тоже упоминал; сам я это взял, емнип, у Hugo, более того, один раз, года четыре назад сам на это нарвался, причем словарь был не большой - чуть более ста элементов.
С тех пор пару keys - items я не использую; прохожу по ключам, значения беру из словаря по ключу - это чуть дольше но надежно.
А то что ни разу не нарывался... так а как ты ошибку заметишь, если специально внимательно не проверять?
Изменено: Михаил Витальевич С. - 30 дек 2020 18:38:15
Создать форму ввода данных в базу данных
 
Обсуждение работы.
Создать форму ввода данных в базу данных
 
Артем Коптев, доброго здоровья , и с наступающим!
Каков ваш бюджет и сроки?
Пишу в личку.
Отобразить даты недель форматом "дата_начало To дата_окончание"
 
=ТЕКСТ($A$2+(СТРОКА(B1)-1)*7;"[$-en-US]МММ Д;@") &" to "&ТЕКСТ($A$2+(СТРОКА(B1)-1)*7+6;"[$-en-US]МММ Д;@")
Изменено: Михаил Витальевич С. - 28 дек 2020 21:42:29
Сохранить лист книги в отдельный файл.
 
vaspup88, так не пробовали?
Код
Sub SaveSheets()
    ActiveSheet.Copy
    ActiveWorkbook.SaveAs Filename:="C:\Имя файла.xlsx", _
            FileFormat:=xlOpenXMLWorkbook, CreateBackup:=False
End Sub
Анекдот дня, Постим сюда понравившиеся:)
 
Каждый раз, когда что-то покупаю, у меня с карты списываются деньги.
Кто-нибудь знает, как отключить эту функцию? Очень раздражает.
Ошибка при импорте в Гугл таблице
 
Giorgi_R2, у меня в гугл-докс формулы на русском, потому смотрите файл по вашей же ссылке.
=ЕСЛИОШИБКА(ЕСЛИ($AE$2+СТОЛБЕЦ(A1)>КОНМЕСЯЦА(AB2,0),"-",AE2+1),"-")
Ошибка при импорте в Гугл таблице
 
Giorgi_R2, Ссылку даете, а доступ?
Таблица Excel, Таблица учета товаров, находящихся на разных этапах производства
 
Пишу в личку
Запрет открытия файла незарегистрированного ПК
 
New, Они (темы) уже все были, и не по разу...
Сумма значений за указанный период в случае если годы в строках, а месяцы в столбцах
 
=СУММПРОИЗВ((B3:B23=R8)*(C3:C23>=R5)*(C3:C23<=T5)*D3:O23)-СУММПРОИЗВ((B3:B23=R8)*(C3:C23=R5)*(D2:O2>=1)*(D2:O2<Q5)*D3:O23)-СУММПРОИЗВ((B3:B23=R8)*(C3:C23=T5)*(D2:O2>S5)*(D2:O2<=12)*D3:O23)
Почему дата отображается через пробел а не через точку?
 
Наргиза Балтаева, см. параметры Windows ,форматы данных.
Изменено: Михаил Витальевич С. - 25 дек 2020 21:58:39
Разные форматы дат для граничных дней месяца и для других дней
 
memo, Да, вы правы. Издержки копи-паста (проще говоря - лени :) )
Разные форматы дат для граничных дней месяца и для других дней
 
=ЕСЛИ(ИЛИ(ДЕНЬ(A8)=1;ДЕНЬ(КОНМЕСЯЦА(A8;0))=ДЕНЬ(A8));ТЕКСТ(A8;"[$-409]ДДДД, ММММ Д, ГГГГ");ТЕКСТ(A8;"[$-9]МММ Д"))
Изменено: Михаил Витальевич С. - 24 дек 2020 16:31:28
Автоматическое подтягивание единого значения для нескольких разных
 
Примерно так (см. файл).
Цитата
Dimagsk1995 написал:
в списке от логистики частенько попадаются новые название
Добавить данные на нужный лист вручную.
Написание макроса для заполнения другой ячейки из пары ячеек
 
Пишу в личку
В работе
Сделано
Оплачено.
Изменено: Михаил Витальевич С. - 24 дек 2020 12:27:19
Количество дней между первым и последним посещением
 
Mershik, я тоже обычно так, на простых вопросах - первое, что в голову пришло. :)
Обновление 05.12.2020
 
Цитата
Юрий М написал:
пытаюсь загрузить маленький файл, доходит до 90% и останавливается
подтверждаю
Страницы: 1 2 3 4 5 6 7 8 9 10 11 ... 351 След.
Наверх