Выбрать дату в календареВыбрать дату в календаре

Страницы: 1
Как просуммировать формулой у повторяющихся строк две колонки?
 
Цитата
Stics написал:
Код
Ваш вариант почему-то не работает, возможно формула скопирована с ошибкой. Но все равно спасибо. Воспользуюсь формулой Murderface_.

upd: Stics, разбирался с вашей формулой, я её немного изменил, вот что получилось:
Код
=СУММЕСЛИ(Таблица1[Адрес];Таблица2[[#Эта строка];[Адрес]];Таблица1[SUMGAZ])+СУММЕСЛИ(Таблица1[Адрес];Таблица2[[#Эта строка];[Адрес]];Таблица1[DOPGAZ])
Изменено: Lyuker - 26.11.2019 20:01:46
Как просуммировать формулой у повторяющихся строк две колонки?
 
Цитата
Murderface_ написал:
так?
Так! Благодарю.
Как просуммировать формулой у повторяющихся строк две колонки?
 
Уважаемые, прошу помочь. На листе 2 есть ряд данных, содержащих несколько повторяющихся записей (адрес). Теперь я хочу суммировать значения (SUMGAZ + DOPGAZ) у одинаковых адресов и перенести сумму на лист 1 в строку с соответствующим адресом. Смотрите пример.
Как из введенных данных (площадь, кол-во проживающих и признака учета) выбрать значение из таблицы с соц. площадями?
 
Код
=ЕСЛИ(D5=1;ЕСЛИ((D3/D4)<ИНДЕКС(D6:D9;ПОИСКПОЗ(D4;B6:B9;0));(D3/D4);ИНДЕКС(D6:D9;ПОИСКПОЗ(D4;B6:B9;0)));D3/D4)
Вот такая формула у меня получилась. Спасибо всем за помощь.
Как из введенных данных (площадь, кол-во проживающих и признака учета) выбрать значение из таблицы с соц. площадями?
 
Цитата
Сергей написал:
1=ЕСЛИ(D5=2;D3/D4;МИН(ИНДЕКС(D6:D9;D4);D3/D4))
Не подходит для второго примера.
Как из введенных данных (площадь, кол-во проживающих и признака учета) выбрать значение из таблицы с соц. площадями?
 
Пытаюсь сам добиться нужного результата. Пока что придумал такую формулу для первого примера:
"=ЕСЛИ(D5=1;ИНДЕКС(D6:D9;ПОИСКПОЗ(D4;B6:B9;0));D3/D4)" (в примере удалил слова "прож", чтобы остались только цифры)
, но для второго примера она уже не подходит, надо еще условия добавлять.
Изменено: Lyuker - 02.08.2019 15:03:56
Как из введенных данных (площадь, кол-во проживающих и признака учета) выбрать значение из таблицы с соц. площадями?
 
Цитата
Murderface_ написал:
во втором примере... Какой вариант правильный?
16,4 правильный.
Как из введенных данных (площадь, кол-во проживающих и признака учета) выбрать значение из таблицы с соц. площадями?
 
Цитата
Murderface_ написал:
судя по условию ответу в файле, во втором примере категория учета должна быть = 2.
Должна быть именно 1 во втором примере. Если бы была 2, то мы просто делили бы 49,2 (ALLSQ) на 3 (PERSPROZ) и получили бы нужный результат.
А так, при категории учета 1, мы должны учитывать соц. норму: 49,2 поделили на 3 получили 16,4, это значение меньше соц. нормы площади, т.к. у "3 прож" соц.норма равняется 21.
Если бы полученный результат был бы, например, не 16,4, а 22,4, то тогда бы мы выбрали 21.
Как из введенных данных (площадь, кол-во проживающих и признака учета) выбрать значение из таблицы с соц. площадями?
 
Цитата
Юрий М написал:
Исправил. Ранее скрытая помощь отображается.
Спасибо за помощь.
Как из введенных данных (площадь, кол-во проживающих и признака учета) выбрать значение из таблицы с соц. площадями?
 
Цитата
Юрий М написал:
Предложите новое, из которого будет понятна задача
Необходимо из введенных данных (площадь, кол-во проживающих и признака учета) выбрать значение из таблицы с соц. площадями.
Как из введенных данных (площадь, кол-во проживающих и признака учета) выбрать значение из таблицы с соц. площадями?
 
Цитата
Юрий М написал:
Предложите новое, из которого будет понятна задача
Вот так: Задача - составить формулу. Необходимо из введенных данных выбрать значение из таблицы.
Как из введенных данных (площадь, кол-во проживающих и признака учета) выбрать значение из таблицы с соц. площадями?
 
Задача - составить формулу. Необходимо из введенных данных (желтые поля) выбрать значение из таблицы (зеленые поля).
Пытаюсь сделать такое условие:

ЕСЛИ (Категория учета=1) ТОГДА
далее думаю использовать =ИНДЕКС (Зеленая таблицаПерваяКолонка; ПОИСКПОЗ ("ТоЧтоИщем-КолвоПрожив";"ЗеленаяТаблица";0)
ИНАЧЕ ДелимПлощадьНаКолвоЗарег

Результаты у меня получаются с ошибками.

Смотрите файл "3 примера.xls". В ячейку D12 надо формулу забить. Помогите, пожалуйста.
Изменено: Lyuker - 02.08.2019 14:10:43
Как перенести БД в Excel
 
Цитата
R Dmitry написал:
Пользуйтесь
В экселе 2016 указываю файл, который приложил в первом посте и выдает см. картинку
Изменено: Lyuker - 05.06.2017 00:48:46
Как перенести БД в Excel
 
Я так понял, что мне надо заменить все запятые, которые находятся внутри одинарных кавычках, другим символом, например '24-00-00 , 24-13-55' превратить в '24-00-00 * 24-13-55'. И тогда, думаю, получится стандартными средствами загрузить в Excel.  
Как перенести БД в Excel
 
Цитата
Sanja написал:
Чем можно открыть Ваш *.bd файл?
В Блокноте, в Notepad++
Как перенести БД в Excel
 
Цитата
Sanja написал:
1. Вручную (Копировать-Вставить)
Только таким способом могу, но там больше 2к строк. Мне бы автоматизировать такой процесс.
Как перенести БД в Excel
 
Как перенести БД со сложной структурой в Excel?
Исходный файл - Kak perenesti v exel.bd (можно открыть в Блокноте или в Notepad++)
Примерный результат - Результат.xls
Изменено: Lyuker - 03.06.2017 11:00:45
Оптимизация формулы или предварительное удаление ненужных сумм
 
ikki, спасибо за помощь!
Оптимизация формулы или предварительное удаление ненужных сумм
 
Здравствуйте! Есть формула, которую надо изменить, чтобы получать нужный результат. Или саму формулу изменить, или перед расчетом формулы, удалить/пометить для удаления ненужные суммы в колонке SOC. Смотрите пример с примечаниями. На данный момент таких людей я ищу вручную и, иногда, пропускаю.
Копирование данных из одного файла в другой
 
Цитата
Vika_22 написал: а зачем $ убирать?
А правда, не надо ) Буду ставить 1000 строк, больше не будет.

Цитата
Vika_22 написал: а можно файл с примером, где не получается
Ок.
"--" устраняют ошибку.
В итоге меня устраивает формула:
Код
{=ЕСЛИОШИБКА(ИНДЕКС(Лист1!$A$1:$I$1000;ПОИСКПОЗ(--Лист2!D2;--Лист1!$A$1:$A$1000;0);8);"0")}
Спасибо!
Копирование данных из одного файла в другой
 
Vika_22, получается на больших списках, если убрать некоторые $ в ссылках, например:
Код
=ЕСЛИ(ЕСЛИОШИБКА(ИНДЕКС(ФАЙЛ1!$A$1:$I5;ПОИСКПОЗ(ФАЙЛ2!D2;ФАЙЛ1!$A1:$A5;0););1)=1;1;"0")
но в формулу еще надо впихнуть проверку пку на формат или преобразование пку в нужный формат. У меня в примере не знаю какой формат, с таким форматом все получается. но если перевести у какого-нибудь человека пку в числовой формат, то значение получится не правильным.
Копирование данных из одного файла в другой
 
Grr, открываю ваш файл в 2010 офисе и, после того как я нажимаю на "разрешить редактирование", появляются значения "#ИМЯ?".
Изменено: Lyuker - 21.05.2015 19:11:18
Копирование данных из одного файла в другой
 
Здравствуйте! Нужно дополнить файл 2 по данным файла 1. Если человек из файла 2 есть в файле 1 (проверку можно сделать по колонке PKU, у всех людей ПКУ уникально), то нужно скопировать из файла 1 данные из колонок SEM и ZAR в соответствующие колонки в файл 2. Если человека из файла 2 нет в файле 1, то в колонку DUBL ставится 1. Как можно это сделать формулой или макросом?
Как можно подсчитать сумму в ячейках...
 
Сбасибо!
{=ЕСЛИ(E5="Z";СУММПРОИЗВ(C6:C31;--(ЕЧИСЛО(C6:C31));--(СТРОКА(C6:C31)<МИН((ЕСЛИ(НЕ(ЕЧИСЛО(C6:C31));СТРОКА(C6:C31);МАКС(СТРОКА(C6:C32)+1))))));0)}
Как можно подсчитать сумму в ячейках...
 
Ой. Извините. Исправил.
Как можно подсчитать сумму в ячейках...
 
Во вложении пример исходных данных и итог.
Пробовал экспериментировать с формулами из этой темы http://www.planetaexcel.ru/forum/index.php?PAGE_NAME=read&FID=1&TID=61001&TITLE_SEO=61001-kak-mozhno-podschitat-summu-chisel-v-yacheykakh_-mezhdu-dvumya-yacheykami-s-tekstovym-soderzhaniem.
но вылезают ошибки...
Большая просьба помочь!
Изменено: Lyuker - 31.10.2014 14:35:55
Объединение нескольких книг в один лист
 
{quote}{login=Саламандра}{date=10.10.2011 04:34}{thema=}{post}Подскажите, пожалуйста, как изменить строку так, чтобы открывались все файлы Excel?  
 
arFiles = .GetOpenFilename("Excel Files (*.xls), *.xls", , "Объединить файлы", , True){/post}{/quote}  
 
Самому понадобился такой скрипт, но надо было, чтобы открывались DBF файлы. Сам в VBA ничего не знаю, но в справке Microsoft нашел описание параметра .GetOpenFilename и изменил этот скрипт:  
 
arFiles = .GetOpenFilename("All Files (*.*), *.*", , "Объединить файлы", , True)
Сортировка текста по количеству символов
 
Есть столбец с ФИО. Нужно отсортировать по количеству символов, чтобы найти ФИО с ошибками. Подскажите, пожалуйста, как можно отсортировать?
Как скопировать данные с одной ячейки в другую?
 
О как просто! Спасибо!
Как скопировать данные с одной ячейки в другую?
 
В примере написал откуда копировать и куда. Как это можно сделать?
Страницы: 1
Наверх