Поиск  Пользователи  Правила 
Закрыть
Логин:
Пароль:
Забыли свой пароль?
Регистрация
Войти
 
Выбрать дату в календареВыбрать дату в календаре

Страницы: 1 2 3 4 5 6 7 8 9 10 11 ... 200 След.
Использование свойства AfterUpdate, Прошу объяснить поведение Excel
 
Уберите выгрузку формы, или замените ее на Me.Hide,
Цитата
OlegO написал:
нажмите Enter и вуаля - крах
не произойдет.
Взять данные из одного файла, и подставить в другой, формулой
 
И чем вам ВПР() не нравится?
Условное форматирование на диапазон ячеек
 
Excel не ругается, а сообщает вам, что вы желаете получить нечто, что он делать не может ни за какие коврижки.
Скопировать встроенное в xlam изображение на лист
 
Так ваш вопрос вообще не про xlam, а про Ribbon.
удаление части данных из ячейки . и замена пробела на слэш, удаление части данных из ячейки . и замена пробела на слэш
 
=ЛЕВСИМВ(ПОДСТАВИТЬ(C3;" ";"_");ПОИСК("/";C3)-1)
Изменено: RAN - 24 окт 2020 10:54:03
Привязать звук на кнопку в пдф файле сделанном из экселя
 
Миш, а пятничный оффтоп?
Привязать звук на кнопку в пдф файле сделанном из экселя
 
Цитата
Григорий Тимофеев написал:
Считаю данный макрос очень многим необходим
Стандартная фраза для любого, кого посетила очередная бредовая идея. На форуме появляется с периодичностью в пару месяцев.  :)
В макросе поиск значения несколько раз
 
Код
Set GCell = Sheets("Лист1")
Set GCell = Sheets("РЕГИСТРАЦИЯ")

????????
Workbooks().Close False ' не отрабатывает, при том что объект существует
 
Цитата
Дмитрий(The_Prist) Щербаков написал:
все срабатывает
Немного не так.
На примере моей недавней заморочки.
Имеется шаблон xltm, в событии Workbook_BeforeSave которого прописано сохранение книги методом SaveAs.
При попытке сохранить сей файл кодом из надстройки методом Save событие Workbook_BeforeSave возникает, макрос открывает диалог, отрабатывает от начала и до конца без ошибок. Одна беда - книга не сохраняется.
Пришлось дублировать в надстройку SaveAs.
Полагаю, что эта проблема, и проблема ТС - одного поля ягода, и скрыта она где-то глубоко в недрах Excel.
В макросе поиск значения несколько раз
 
Я нет, справка - да.
В макросе поиск значения несколько раз
 
Не  For Each, a FindNext
ФИО в инициалы макросом, ФИО (отчества может не быть) преобразовать в инициалы макросом
 
Удалите из кода
Код
& Left(Arr(2), 1) & "."
Копирование строк по нескольким условиям при срабатывании события
 
Код
If Cells(i, 6) = "a" Then
If Cells(i, 7) = "б" Then
If Cells(i, 8) = "с" Then

и т.д.
Подсчет любых чисел с заливкой ячеек независимо от цвета
 
Для любой формулы все символы и все ячейки всегда одинаково фиолетовые.
Изменено: RAN - 17 окт 2020 21:59:13
VBA не видит открытую книгу, (не сохранённая выгрузка данных в Excel)
 
Работа с Excel разных версий в нескольких процессах
Привязка фигуры Excel при помощи формулы
 
Можно.
Пишите макрос, который при пересчете формулы будет двигать вашу фигуру в нужное место.
Удалить строки содержащие цвет ячейки
 
Вариант без макроса.
Поставить фильтр по цвету, и удалить строки.  :)
Пройтись макросом по всем гиперссылкам в таблице, Как пройтись по всем ссылкам макросам в столбце в таблице
 
Цитата
ser987 написал:
Порядок такой:1 кликается первая гиперссылка(там макрос)
И зачем вам какой-то цикл? Он кликать не умеет.
Привидение в эксель, Полтергейст ! принскрин !
 
New, ой не факт!
.Replace с текстом и числами. Отказывается заменять, пропускает запятую.
 
Владимир, добрый день.
Пришел к тем-же выводам. Кстати, функция ведет себя аналогично.
Когда я вставил преобразование типа не в то место, получил совершенно ту же козу.
Код
[b1] = Replace(Данные, Найти, CDbl(ЗаменитьНа)

Разница лишь в том, что функция не проявляет излишней самостоятельности. И если ей скормили текст, то она и вернет текст.

Владимир Шаматонов, измените строку , и бубен будет не нужен.
Код
Cells(1, 2) = CDbl(Replace(Данные, Найти, ЗаменитьНа))
Изменено: RAN - 16 окт 2020 16:48:26
.Replace с текстом и числами. Отказывается заменять, пропускает запятую.
 
Цитата
Владимир Шаматонов написал:
без .Text это не работало
Неправда ваша
Это не работает при использовании Range.Replace Method (почему, самому до кончика хвоста любопытно), и работает при использовании Replace Function
Автоматическое заполнение текстом нескольких строк разной ширины.
 
Почитайте тут. Но только внимательно.
Автоматическое заполнение текстом нескольких строк разной ширины.
 
Цитата
Роман написал:
Хотелось бы найти решение, которое автоматизирует подгонку текста в строки
Это решение имеет вполне определенное название - Word.
Определение коэффициента учитывающего объём механических повреждений методом интерполяции
 
Задурил мне голову утром
Цитата
Greshnik_vl написал:
не не так
я и с горяча изменил работающую формулу. Пришлось вернуть.

Нет, ну конечно, если
Цитата
Greshnik_vl написал:
80,1%=0,9
80%=0,9
то формула считает неверно, но, с какого перепуга она должна так считать, тоже не понятно.

Вить, какая разница, коэффициент чего? Подобные таблицы встречаются в какой угодно области.
Изменено: RAN - 13 окт 2020 21:46:05
Определение коэффициента учитывающего объём механических повреждений методом интерполяции
 
=ВПР(D21;{0;0,5:20;0,6:40;0,7:60;0,8:80;0,9};2;1)+(D21/20-ЦЕЛОЕ(D21/20))/10+(D21=100)/10
Изменено: RAN - 13 окт 2020 21:31:56
Вставляю текст из блокнота, его разрывает по ячейкам реагируя на пробел, как отключить "разрыв текста"?
 
Миш, это новее 95 и 03  :D
Ошибка при при попытке вызова переменной пользовательского типа из другой процедуры другого модуля
 
Date As Date - это точно рублевая идея? Вот я почему-то сомневаюсь.
Посчитать количество определенных символов в таблице
 
=СУММПРОИЗВ(--($A$2:$AJ$2="З")*(--(A4:AJ4="+")))
Очистка проверки данных выпадающего списка созданного макросом
 
Да ничего там добавлять не надо, там и так все работает. Просто чьи-то шаловливые ручки испортили строку
Valid = Target.Validation.Formula1
Повторный вопрос о замене файла
 
Неожиданно то, что при этом  Application.DisplayAlerts = True
Страницы: 1 2 3 4 5 6 7 8 9 10 11 ... 200 След.
Наверх