Поиск  Пользователи  Правила 
Закрыть
Логин:
Пароль:
Забыли свой пароль?
Регистрация
Войти
 
Выбрать дату в календареВыбрать дату в календаре

Страницы: 1 2 3 4 5 6 7 8 9 10 11 ... 21 След.
Не корректная работа функции ВПР
 
Как вариант:
Код
=ЕСЛИОШИБКА(ВПР(ОКРУГЛТ(I2*24;1)/24;rate!$A$5:$F$1404;4;ЛОЖЬ);0)
Выдает ошибку #Н/Д при совмещении формул с "индексом и поискпоз" в "ЕСЛИ".
 
Если файл такой же как и здесь
http://forum.msexcel.ru/index.php?topic=9949.0
то формула:

Код
=ЕСЛИ(ЕНД(ПОИСКПОЗ(B3;Настройки!A3:A18;0));
ИНДЕКС(Настройки!E9:H18;ПОИСКПОЗ(B3;Настройки!D9:D18;0);ПОИСКПОЗ(РАЗНДАТ(E4;H1;"m");{0:4:7:13}));
ТЕКСТ(ИНДЕКС(Настройки!B3:B18;ПОИСКПОЗ(B3;Настройки!A3:A18;0));
ВЫБОР(ПОИСКПОЗ(ИНДЕКС(Настройки!B3:B18;ПОИСКПОЗ(B3;Настройки!A3:A18;0));{1:99998:99999});"0%";"#";"# ##")))
Проверка противоположных значения в разных строках таблицы, какие формулы примерно применить?
 
Забыл сказать, что в А10 стоит формула ="" чтобы не делать проверку. Без этой формулы можно так (для Excel 2007 и выше):

Код
=ПОВТОР(B2;ЕСЛИОШИБКА(СЧЁТЕСЛИ(ИНДЕКС($B$2:$C$10;ПОИСКПОЗ(B2;$A$2:$A$10;);0);$A2);0))
Проверка противоположных значения в разных строках таблицы, какие формулы примерно применить?
 
Можно так:
подсчет кол-ва уникальных записей, массивы
 
Вот такой вот монстрик:

Код
=СУММ((ЧАСТОТА(ЕСЛИ(ЕОШ(ПОИСК("ОШИБКА";ПОИСКПОЗ(A2:A82;A2:A82;)&B2:B82));ПОИСКПОЗ(A2:A82;A2:A82;);"");ПОИСКПОЗ(A2:A82;A2:A82;))=ЧАСТОТА(ПОИСКПОЗ(A2:A82;A2:A82;);ПОИСКПОЗ(A2:A82;A2:A82;)))*(ЧАСТОТА(ПОИСКПОЗ(A2:A82;A2:A82;);ПОИСКПОЗ(A2:A82;A2:A82;))>1))
Сортировка чисел и текста вместе, формулой
 
Варианты в файле:
Подсчет суммы за последние 10 дней
 
Можно так:

Код
=СУММЕСЛИ(B4:W4;"<"&СЕГОДНЯ();B5:W5)-СУММЕСЛИ(B4:W4;"<"&МАКС(СЕГОДНЯ()-11;B4);B5:W5)
Если нет данной даты, взять следующую "имеющуюся" дату
 
Цитата

Суть в том нет данных о курсе валют на выходные, поэтому надо чтобы брал след дату на которой есть курс валюты
off Насколько я знаю, всегда берется курс действующий, т.е. пятничный. А так получается, что курс в Сб берется из будущего.:)
При добавлении строк функция ОШИБАЕТСЯ
 
И где 4-е значение за октябрь?
Если с третьей, то должно быть
Код
СТРОКА(Роспис!A$1:A$48)
Изменено: DV - 18 Янв 2014 10:16:35
Если нет данной даты, взять следующую "имеющуюся" дату
 
вариант простой формулы:

Код
=ПРОСМОТР(C4;I$4:I$9;ЕСЛИ(СЧЁТЕСЛИ(I$4:I$9;C4);J$4:J$9;J$5:J$9))
При добавлении строк функция ОШИБАЕТСЯ
 
Все диапазоны должны начинаться с 1-й строки, а не с 3-й, как у Вас.
поиск ближайшей даты по дню недели
 
Проще разбираться так:
выделяете часть формулы и жмете F9.
Забыл сказать - все "вск" надо заменить на "вс" (в последнем примере я уже заменил)
Изменено: DV - 18 Янв 2014 04:17:55
поиск ближайшей даты по дню недели
 
При дальнейшем рассмотрении оказалось, что можно и "простой" формулой

Код
=ТЕКСТ(СЕГОДНЯ()+ПОИСКПОЗ(1;СЧЁТЕСЛИ(E3:G3;ТЕКСТ(СЕГОДНЯ()+{0:1:2:3:4:5:6};"ддд"));)-1;"ДД/ММ/e")
поиск ближайшей даты по дню недели
 
С такой организацией данных получилось только формулой массива (Ctrl+Shift+Enter):

Код
=ТЕКСТ(СЕГОДНЯ()+МИН(ПОИСКПОЗ(ЕСЛИ(E3:G3="";ТЕКСТ(СЕГОДНЯ()-1;"ддд");E3:G3);ТЕКСТ(СЕГОДНЯ()+{0:1:2:3:4:5:6};"ддд");))-1;"ДД/ММ/e")
Формула для создания последнего рабочего дня квартала
 
Можно так:

Код
=РАБДЕНЬ(ДАТА(C4;B4*3+1;1);-1)
минимальная дата в массиве для указанной даты, Почему может не работать МИН(ЕСЛИ...
 
"И" и "ИЛИ" не возвращают массивы, а только одно значение.
Как вариант:

Код
=ИНДЕКС(D2:D55;1+ПОИСКПОЗ(H2-ДЕНЬ(H2)+1;D2:D55))

или

Код
=ПРОСМОТР(H2-ДЕНЬ(H2)+1;D2:D54;D3:D55)
Изменено: DV - 16 Янв 2014 13:32:50
Извлечение части наименования из ячейки, Можно ли укоротить длинную формулу?
 
Если работает, то можно еще подсократить:

Код
=ЕСЛИОШИБКА(ЛЕВБ(A1;ПОИСК("/";A1)-1)&ПСТР(A1;ПОИСК("/";A1;10);99);ЛЕВБ(ПОДСТАВИТЬ(A1;"-";ПОВТОР(" ";30);2);20))
Извлечение части наименования из ячейки, Можно ли укоротить длинную формулу?
 
Можно так:

Код
=ЕСЛИ(ПОДСТАВИТЬ(A1;"/";;2)=A1;ЛЕВБ(ПОДСТАВИТЬ(A1;"-";ПОВТОР(" ";30);2);20);ЛЕВБ(A1;ПОИСК("/";A1)-1)&ПСТР(A1;ПОИСК("/";A1;10);99))
Формат ячеек (время)
 
видимо надо поделить еще на 1440
среднее значение с условием в трехмерной формуле
 
Цитата
сомневаюсь, что это можно сделать 1 формулой.
Можно:

Код
=СУММ(СУММЕСЛИ(ДВССЫЛ("'цех "&{1;2;3}&"'!A1");">=0"))/СУММ(СЧЁТЕСЛИ(ДВССЫЛ("'цех "&{1;2;3}&"'!A1");">=0"))
но лучше с доп строкой
Изменено: DV - 13 Янв 2014 13:05:06
Не работает ВПР при перестановке местами искомых значений в виртуальном массиве
 
Я уже изменил диапазоны, смотрите предыдущее сообщение.
Не работает ВПР при перестановке местами искомых значений в виртуальном массиве
 
Не работает, потому что у Вас искомое значение "СтавропольПупкин", а диапазон для поиска {"Ставрополь";"Пупкин";3}. Почувствуйте разницу.
Можно так:

Код
=ВПР(C3&B3;ЕСЛИ({1;0};E$3:E$4&F$3:F$4;G$3:G$4);2;0)
формула массива - вводится Ctrl+Shift+Enter
Изменено: DV - 11 Янв 2014 07:08:04 (изменил диапазоны)
Полуофф: Личный ТОП 2013 года, Какие новые трюки в Excel вы открыли для себя за последний год?
 
Обсуждалось здесь:
http://www.excelworld.ru/forum/7-5324-1
Вхождение диапазона дат в диапазон дат
 
Если учитывать, что поломка происходила только во время работы, то можно так (формула массива):

Код
=СУММ(ЕСЛИ((E$2:E$277>=A2)*(F$2:F$277<=B2);(B2-A2)-F$2:F$277+E$2:E$277))
Автоматическое изменение всех формул в книге
 
Это можно сделать через  Ctrl+H
Полуофф: Личный ТОП 2013 года, Какие новые трюки в Excel вы открыли для себя за последний год?
 
Для меня было открытием, что в объединенных ячейках можно сохранить значение каждой ячейки, невидимые, но в формулах участвующие.
Изменено: DV - 5 Янв 2014 18:54:42 (добавил файл)
Помогите разобратся с форматом времени (5 заменить на 00:05, 15 на 00:15 и т.д.)
 
В любой ячейке пишете 1440, копируете - выделяете диапазон с минутами - прав кн мыши - спецвставка - разделить.
И выставляем формат ячеек [ч]:мм
HB
 
Спасибо!!!
HB
 
Спасибо большое за поздравления!!!
Округлить количество минут в большую сторону
 
Код
=ОКРВВЕРХ(A2*1440;1)
Страницы: 1 2 3 4 5 6 7 8 9 10 11 ... 21 След.
Наверх