Поиск  Пользователи  Правила 
Закрыть
Логин:
Пароль:
Забыли свой пароль?
Регистрация
Войти
 
Выбрать дату в календареВыбрать дату в календаре

Страницы: 1 2 3 4 5 6 7 8 9 10 11 ... 77 След.
Разделение текста в ячейке на строки по абзацу со сведением данных
 
ОК. Осталось еще 3 способа.
Всё сложное - не нужно. Всё нужное - просто /М. Т. Калашников/
Перерасчет сводной таблицы
 
1. Правила форума читали? Про файл-пример и его размер?
2. Что такое макрорекордер знаете?
3. Что такое Событие в VBA знаете?
Всё сложное - не нужно. Всё нужное - просто /М. Т. Калашников/
Разделение текста в ячейке на строки по абзацу со сведением данных
 
Попробуйте дождаться волонтера или обратиться в раздел "Работа". Или подтянуть уровень знаний. Задача то - нетривиальная, раз поиск решения - не увенчался...
Можно еще попробовать "решить проблему в корне", т.е. добиться изменения способа сбора информации изначально. Чтобы сразу предоставлялся файл в формате "как надо", а не "как есть".
Всё сложное - не нужно. Всё нужное - просто /М. Т. Калашников/
Сведение данных из нескольких листов в один
 
Цитата
serhiy.pikalov написал:
Помогите плиз
Сначала помогите себе сами. Выложите файл-пример, ИМЕЙТЕ СОВЕСТЬ, В КОНЦЕ КОНЦОВ!!! (  :D  )

PS

В "Приемах" смотрели?
Изменено: Михаил Лебедев - 24 Янв 2020 06:55:06
Всё сложное - не нужно. Всё нужное - просто /М. Т. Калашников/
Сумма чисел через дробь и чисел в текстовом формате
 
Можно еще вот так:
Код
=СУММ(ЕСЛИОШИБКА(--ЛЕВСИМВ(ПОДСТАВИТЬ(B4:F4;"/";ПОВТОР(" ";10));3);0))
Всё сложное - не нужно. Всё нужное - просто /М. Т. Калашников/
Большой файл медленно работает
 
Можно еще вот так попробовать...
1. Убрать на листе z все блоки, в которых Вы рассчитываете по каждому продукту кол-во, кроме одного, где считать "на лету", при выборе е.и. из раскрывающегося списка. А "накопительные" столбцы (с L по P, где "итого") - считать с пом. более сложной формулы. Кол-во столбцов сокращается "в разы".

Смотрите изменения на обоих листах.
В столбцах, где "итого" - наверно можно придумать формулу без использования =ТРАНСП(), но что-то не придумывается. М.б., если идеея понравится, кто из форумчан предложит более резвую формулу? :)

PS
Исходил из того, что вряд ли кому требуется одновременно смотреть кол-во одного и того же товара в различных е.и.
А даже если и требуется, то проще сделать отдельную таблицу на один товар, где организовать выбор этого товара из списка
Всё сложное - не нужно. Всё нужное - просто /М. Т. Калашников/
Выделить неверно введенные данные, согласно двум объединенным таблицам, условия на первой вкладке
 
В файле сообщения #5 - также нестыковка. См. поз "корова".
Вот - как вариант для размышлений. С доп. столбцами и перекомпоновкой табл. "норматив" на 1-м листе для упрощения расчетов УФ.
Всё сложное - не нужно. Всё нужное - просто /М. Т. Калашников/
Выделить неверно введенные данные, согласно двум объединенным таблицам, условия на первой вкладке
 
Лист "табл", строка 7: кошка вес 2,3 - нет вылета из 1-й таблицы, т.к. 2,3 < 10
Всё сложное - не нужно. Всё нужное - просто /М. Т. Калашников/
Перенести данные из документа Word состоящий из надписей в таблицу Excel
 
Выделите, скопируйте, вставьте в Excel.
Но проблема, думаю, не в этом, а в том, что сформированы файлы в Word - некорректно с точки зрения Excel. Поэтому в Excel они вставляются неправильно (Например: то, что должно быть названием группы понятий и вставляться НАД группой, вставляется ВНУТРЬ группы).
Всё сложное - не нужно. Всё нужное - просто /М. Т. Калашников/
Учет остатков по удельному весу
 
Посчитать удельный вес ликёра и записывать в 3 столбца. "Название", "Расход в мл", "Расход при пересчете в гр".
Всё сложное - не нужно. Всё нужное - просто /М. Т. Калашников/
Объединение значений в столбцах по условию
 
Если отсортировать по полю "Покупатель", то можно обычной формулой.
Всё сложное - не нужно. Всё нужное - просто /М. Т. Калашников/
Фильтрация списка по ключевому слову
 
Делается "на раз" (точнее - на 1-2-3-4  :D  ) с помощью автофильтра.
1. Создаете копию листа.
2. Устанавливаете автофильтр.
3. Для столбца F: Текстовые фильтры ► не содержит ► "москва"
4. Отобранные строки выделяем и удаляем.
Изменено: Михаил Лебедев - 21 Янв 2020 05:28:55
Всё сложное - не нужно. Всё нужное - просто /М. Т. Калашников/
автозаполнение ячеек при выборе комбинации значений в двух ячейках, или как избавиться от ошибок
 
Цитата
rtt написал:
"...автозаполнение относящихся к товару параметров..."
- либо формулами, либо макросами. "Третьего не дано".

Цитата
rtt написал:
1) в ячейках, естественно, ошибки, когда ничего не выбрано в выпад.списках

А ошибки можно "завернуть" в =ЕСЛИОШИБКА(....;"")
Всё сложное - не нужно. Всё нужное - просто /М. Т. Калашников/
Как назначить Tebox в UserForm формат даты и денежный формат
 
Цитата
Alex32 написал:
Ну чтобы в UserForm в TextBox,  ввел 19 автоматически поставилась точка, ввел 01 автоматически поставилась
а это не оно, разве?!?!?!  :(
Цитата
Михаил Лебедев написал:
Например - вот такое:(взято с CyberForum.ru)
Всё сложное - не нужно. Всё нужное - просто /М. Т. Калашников/
Большой файл медленно работает
 
Цитата
vlad_d написал:
в среднем получается 3000 строк и 500 столбцов
- заменяйте формулы на значения перед отправкой по почте
Цитата
vlad_d написал:
в среднем получается 3000 строк и 500 столбцов
- у Вас "шахматка". Каким образом она получается? Сотрудник(-ки) заполняет(-ют) вручную? Сколько у Вас полей с "0" получается? М.б. стоит отказаться от "шахматки вручную". Тем более, если ее заполняют несколько сотрудников. Имеет смысл обратить внимание на Power Query.

Цитата
vikttur написал:
Не нужно в формулах обходить отображение нулей - для этого есть галочка в параметрах листа. ...
... или, если не везде нужно "" вместо "0", можно выбрать формат "финансовый" , а в нем заменить вывод 0 в виде "-" на вывод 0 в виде "".
Например - вот такой: _-* # ##0,00\ _₽_-;-* # ##0,00\ _₽_-;""
Всё сложное - не нужно. Всё нужное - просто /М. Т. Калашников/
Формула с условиями
 
С доп. столбцом
Изменено: Михаил Лебедев - 20 Янв 2020 10:25:05
Всё сложное - не нужно. Всё нужное - просто /М. Т. Калашников/
Расчет количества сотрудников в зависимости от оборота компании
 
А какого оборота нужно достичь, чтобы уже нанять сотрудника, который напишет формулы и выполнит "Расчет количества сотрудников в зависимости от оборота компании"? :)
Всё сложное - не нужно. Всё нужное - просто /М. Т. Калашников/
Как назначить Tebox в UserForm формат даты и денежный формат
 
Сделайте 3 textboxa-a. Для года, месяца и дня месяца. Или поищите в инете решение. Например - вот такое:
(взято с CyberForum.ru)
Всё сложное - не нужно. Всё нужное - просто /М. Т. Калашников/
Исключить запуск процедуры Chage при изменении ячеек кодом
 
М.б. это? (https://habr.com/ru/post/112458/ )

"...Часто макросы требуют долгого времени выполнения, которое можно значительно сократить. В начале и в конце каждой ресурсоёмкой функции вызвать Prepare и Ended.
Код
Public Sub Prepare()
    Application.ScreenUpdating = False
    Application.Calculation = xlCalculationManual
    Application.EnableEvents = False
    ActiveSheet.DisplayPageBreaks = False
    Application.DisplayStatusBar = False
    Application.DisplayAlerts = False
End Sub
Код
Public Sub Ended()
    Application.ScreenUpdating = True
    Application.Calculation = xlCalculationAutomatic
    Application.EnableEvents = True
    ActiveSheet.DisplayPageBreaks = True
    Application.DisplayStatusBar = True
    Application.DisplayAlerts = True
End Sub
По порядку:
1. Отключить перерисовку объектов на экране, чтобы ничего не мигало.
2. Выключить расчет. Внимание, если макрос прервался посреди работы, то расчет так и останется в ручном режиме!
3. Не обрабатывать события.
4. Отображение границ страниц, тоже почему-то помогает.
5. В статусной строке выводятся различные данные, что замедляет работу, отключаем.
6. Это если нужно. Выключает сообщения Экселя. Например, мы делаем Workbook.Close, Эксель хочет спросить сохранить ли изменения. При выключении этого параметра все ответы будут даны автоматически (изменения не сохранятся).
..."
Всё сложное - не нужно. Всё нужное - просто /М. Т. Калашников/
Суммирование значений по признаку соседней ячейки (в пределах одной даты), Нужна формула для вывода итогового значения по каждому уникальному номеру ,ориентируясь по дате .(Номера с большим количеством повторении..)
 
в H2:
Код
=СУММЕСЛИМН($C$2:$C$26;$A$2:$A$26;F2;$B$2:$B$26;G2)
Изменено: Михаил Лебедев - 17 Янв 2020 11:57:09
Всё сложное - не нужно. Всё нужное - просто /М. Т. Калашников/
Автоматическое подтягивание значения по условию
 
Цитата
Ruslan2923 написал:
эта формула некорректно работает когда ищет "ТЧ-17", выдает код как для "ТЧ-1"
тогда вот такая (тоже массивная:) ▼
Код
=ИНДЕКС(A6:A11;ПОИСКПОЗ(1;--(ПРАВСИМВ(A3;ДЛСТР(B6:B11))=B6:B11);0))
а формула от Dyroff
Код
=ИНДЕКС($A$6:$A$11;ПОИСКПОЗ(ПРОСМОТР(2;1/ПОИСК($B$6:$B$11;A3);$B$6:$B$11);$B$6:$B$11;0))
(Dyroff , при всём уважении, :) ) не будет работать, если:
1. в В10 будет не "ТЧ-17", а "ТЧ-171"
2. в А3 выбрать, например, "Ремонт будівель і споруд ТЧ-17"
Изменено: Михаил Лебедев - 17 Янв 2020 06:09:10
Всё сложное - не нужно. Всё нужное - просто /М. Т. Калашников/
Есть ли, какой–то функционал в EXCEL 2019 для исправления правильности написания словосочетаний?, Можно пожалуйста на тупой вопрос не тупой ответ? :))
 
Цитата
daniil.dnk написал:
Работа автослесарем
Работа мотористом
Вакансия автомеханика
Вакансия автоэлектрика
т.е. еще и если работа, то "кем", а если вакансия, то "кого"...

М.б. так?...
Изменено: Михаил Лебедев - 16 Янв 2020 12:35:56
Всё сложное - не нужно. Всё нужное - просто /М. Т. Калашников/
Сумма чисел через дробь и чисел в текстовом формате
 
Код
=СУММ(--ЕСЛИОШИБКА(ЛЕВСИМВ(B2:E2;ПОИСК("/";B2:E2)-1);B2:E2))
или
Код
=СУММ(--ЛЕВСИМВ(ПОДСТАВИТЬ(B2:E2;"/";ПОВТОР(" ";10));3))
Тоже массивные
Изменено: Михаил Лебедев - 16 Янв 2020 11:36:28
Всё сложное - не нужно. Всё нужное - просто /М. Т. Калашников/
Номера телефонов привести к единому формату
 
Цитата
Андрей VG написал:
...Вот и оппонент считает, что этот форум - это как бы PLEX Market с возможностью индивидуального заказа...
Ну, так оно и есть, частенько :)
Всё сложное - не нужно. Всё нужное - просто /М. Т. Калашников/
перенести значение из одного столбца в другой через 6 строк
 
Формула+условное форматирование подойдет? (см. файл)
Всё сложное - не нужно. Всё нужное - просто /М. Т. Калашников/
выделить в строке код артикула, выделить в строке код артикула и перенести данные из одного столбца в другой через 6 строк каждое значение
 
По вопросу 2:
Формула+условное форматирование подойдет? (см. файл)
По вопросу 1:
Одна тема - один вопрос.
Изменено: Михаил Лебедев - 16 Янв 2020 09:20:52
Всё сложное - не нужно. Всё нужное - просто /М. Т. Калашников/
Номера телефонов привести к единому формату
 
Цитата
RAN написал:
Тёзка, ты не прав. В магазине платить надо.  
 8) :excl:  
Всё сложное - не нужно. Всё нужное - просто /М. Т. Калашников/
Номера телефонов привести к единому формату
 
Цитата
Андрей VG написал:
RUSBelorus , зашёл на форум как в магазин...
Дык! Ёлы-палы! :)
Всё сложное - не нужно. Всё нужное - просто /М. Т. Калашников/
Посчитать кол-во израсходоного ГСМ за год на каждое наименование масел
 
Тема: Как правильно задать аргументы для функции =СУММЕСЛИМН()

Ответ:
Аргументы данной функции, которые представляют диапазоны ячеек, должны быть одинакового размера. Например - так:
Код
=СУММЕСЛИМН(Итог_Масла!E6:E156;Итог_Масла!D6:D156;"Автогрейдеры";Итог_Масла!G6:G156; "Shell 15-W40")

В этом случае функция выдаст правильный ответ = 0, т.к. нет ни одного Автогрейдера, использовавшего масло Shell 15-W40.
Всё сложное - не нужно. Всё нужное - просто /М. Т. Калашников/
Замена значений в текстовых формулах вручную и при помощи макроса
 
Цитата
egorkaqwerty написал:
В ячейках есть текстовые формулы (пример на скрине).
Скрин не нужен. Нужен файл екселя
Всё сложное - не нужно. Всё нужное - просто /М. Т. Калашников/
Страницы: 1 2 3 4 5 6 7 8 9 10 11 ... 77 След.
Наверх