Поиск  Пользователи  Правила 
Закрыть
Логин:
Пароль:
Забыли свой пароль?
Регистрация
Войти
 
Выбрать дату в календареВыбрать дату в календаре

Страницы: 1 2 3 4 5 6 7 8 9 10 11 ... 157 След.
[ Закрыто] Почему не работает логическое условие
 
4303  и "4303" разные вещи. файл показывем.
Работа только с видимыми ячейками
 
Код
Selection.SpecialCells(xlCellTypeVisible)
в помощь
Переименовать лист на основе значения ячейки
 
в файле кнопку не увидел. А кнопка кнопке рознь.
Почему не число при извлечении значения из текста
 
т.к. вы используете в формуле текстовые функции то и результат текст.
Выборочная замена букв их порядковым номером в слове
 
вариант
Код
Function Zamena(ячейка As Range) As String
Dim i%, k%
For i = 1 To WorksheetFunction.Min(Len(ячейка.Value), 10)
    If InStr(1, "aeIouy", Mid(ячейка, i, 1)) Then
        k = IIf(i = 10, 0, i)
        Zamena = Zamena & k
    Else
        Zamena = Zamena & Mid(ячейка, i, 1)
    End If
Next
Zamena = Trim(Zamena & Mid(ячейка, 11, 100))
End Function
Переменная дата в названии файла
 
Код
дата = "17.09.19" 
windows (“сальдовая ведомость по главам баланса на " & дата & " НА"). Activate
[ Закрыто] Заполнение таблицы с помощью форм.
 
ну так запускайте форму внутри кода Rock.Show
на Ок формы вешайте заполнение.

П.С.
Код
зачем так длинно
Range("Z1").Select
    ActiveCell.FormulaR1C1 = "Code"
если можно просто
Range("Z1") = "Code"
SUMIFS формула, в которой в 1 из критериев 2-ое условие, по типу или-или.
 
Цитата
Paul Zealand написал:
а какое бы Вы предложили решение для этой задач
buchlotnik уже все сделал, и название предложил и решение. пост #3.
вариант который предлагал во 2-ом посте
Код
СУММЕСЛИМН(D:D;A:A;I13;B:B;J13;C:C;"<"&$F$1)+СУММЕСЛИМН(D:D;A:A;I13;B:B;J13;C:C;"")
Изменено: V - 20 Сен 2019 09:24:58
SUMIFS формула, в которой в 1 из критериев 2-ое условие, по типу или-или.
 
СуммЕСлиМн принимает только условие И. Для ИЛИ нужна другая функция, но названием темы вы урезали варианты ответов.
как вариант СуммЕСлиМн(1условие)+СуммЕСлиМн(2 условие)
Изменено: V - 20 Сен 2019 09:06:22
Преобразование радианов в градусы, Преобразовывая радианы в градусы есть сомнение правильности работы Excel. Давайте обсудим данный вопрос.
 
в общем, я бы считал так.
1. высота по теореме Пифагора.
2. Угол "в" по косинусу. (отношение противолежащего катета к гипотенузе).
3, Угол "а" 180-90-"в".
У вас я не пойму что за формула для расчета угла "а".
Изменено: V - 19 Сен 2019 16:34:08
Преобразование радианов в градусы, Преобразовывая радианы в градусы есть сомнение правильности работы Excel. Давайте обсудим данный вопрос.
 
высоту по теореме Пифагора не проще высчитать?
VBA: заменить текст на листе при смене состояния переключателя
 
вариант
[ Закрыто] VBA: усовершенствование макроса в коде листа
 
Цитата
Андрей_26 написал:
Не знаю у меня все сразу срабатывает.
Лист2 меняется на Лист3?
[ Закрыто] VBA: усовершенствование макроса в коде листа
 
как вариант написать макрос в модуле и переключатели привязать к этому макросу.
ВПР и Сумма значений
 
Цитата
ДПП написал:
как правильно
Почитать правила форума. особенно пункты 2,1-2,3.
Изменено: V - 19 Сен 2019 14:01:37
[ Закрыто] поиск и замена, формула поиска ячейки и подставления ее значения.
 
1. Читаем правила форума.
2. Подсказка: ищем ВПР в ПРИЕМАХ.
Разные формулы при разных ставках
 
Да. Но принцип такой же. Если в Если, допускается 15 вхождений ЕСЛИ.
Разные формулы при разных ставках
 
если только два варианта 1 или 0,5 то я так и написал формулу.
Формула для подсчета данных с других листов, СУММПРОИЗВ. Как ей считать с других листов ?
 
для название (М370)
Код
=ВПР(B370;названия!$A$2:$B$2472;2;)

дальше разбирайтесь сами.
в #2 сообщении добавил ссылку на статью про ВПР в приемах, если вдруг не заметили. (подчеркнутая ВПР)
Изменено: V - 12 Сен 2019 09:51:23
Формула для подсчета данных с других листов, СУММПРОИЗВ. Как ей считать с других листов ?
 
для столбцов M, N функция ВПР (в приемах есть её описание).
х и цвет тоже подтягиваете ВПР-ом и суммируете.
Изменено: V - 12 Сен 2019 09:25:48
Поиск наибольшей даты с условием. Защита диапазона от изменения.
 
зачем вам это?
Разные формулы при разных ставках
 
это?
Код
=ЕСЛИ(D12=1;ЕСЛИ(Y12<11280;11280;0);ЕСЛИ(Y13<5640;5640;0))
Выделение ячеек, содержащих значения из заданного списка
 
Смотрите
Изменено: V - 11 Сен 2019 14:42:47 (файл забыл прицепить. :))
Выделение ячеек, содержащих значения из заданного списка
 
Цитата
БМВ написал:
или в условное форматирование
может не прокатить т.к. ссылка на другой лист.
выход, формулу загнать в диспетчер имен (ctrl+F3)
Кол-во фамилий в одной ячейке, Посчитать кол-во фамилий в одной ячейке и всему столбцу
 
Цитата
КлёцыК написал:
посчитать кол-во фамилий в одной ячейке
если разделитель фамилий всегда запятая то вариант
Код
=ДЛСТР(B4)-ДЛСТР(ПОДСТАВИТЬ(B4;",";""))+1
Автоматическое создание листов по примеру
 
Цитата
abdu__rashid написал:
на 1 листе есть реестр данных
не поверите, у меня нет ;)
Горизонтальный вывод значений по условию, впр
 
с доп. столбцом сводная не подойдет?
формула массива
Код
=ЕСЛИОШИБКА(ИНДЕКС($B$2:$B$17;НАИМЕНЬШИЙ(ЕСЛИ($A$2:$A$17=$G2;СТРОКА($A$1:$A$16);"");СТОЛБЕЦ(A$1)));"")
Изменено: V - 10 Сен 2019 11:20:21
Вычисление имени поставщика по критерию цены
 
Цитата
spun написал:
Обе формулы у меня не сработали
первая вводится тремя клавишами. ctrl+shift+enter
вторую нужно перевести на русский язык.
Вычисление имени поставщика по критерию цены
 
формула массива
Код
=ИНДЕКС(D1:G1;;МАКС(ЕСЛИ(D2:G6=МИН(B2:B6);СТОЛБЕЦ(A1:D1);)))

если будет две и более минимальных цен, будет брать с столбца который правее.
Изменено: V - 9 Сен 2019 17:31:21
Счёт количества дат , входящих в диапазон. VBA, Application.WorksheetFunction.CountIfs
 
Цитата
frowzy написал:
У Вас считает?
не проверял верно или нет но считало.
Страницы: 1 2 3 4 5 6 7 8 9 10 11 ... 157 След.
Наверх