Поиск  Пользователи  Правила 
Закрыть
Логин:
Пароль:
Забыли свой пароль?
Регистрация
Войти
 
Выбрать дату в календареВыбрать дату в календаре

Страницы: 1 2 3 4 5 6 7 8 9 10 11 ... 36 След.
Вычислить площадь листа, размеры которого имеются в тексте
 
=ПСТР(A1;НАЙТИ("*";A1)+1;ПОИСКПОЗ(1;-ПСТР(A1;СТРОКА(A$1:A$199);1))-НАЙТИ("*";A1)) массивная и ВЫЧИСЛИТЬ() в диспетчере имен
Как сделать накопительный диапазон суммирующий последнее изменение данных в ячейке
 
цель одна - минимизировать путем построения оптимально структурированных данных:
- затраты на формирование отчета
- вероятность ошибки,.

Ну что я вас агитирую за советскую власть?
Изменено: dude - 20 июл 2019 15:46:24
Как сделать накопительный диапазон суммирующий последнее изменение данных в ячейке
 
Почему бы не вести реестр выполнения и подтягивать нужные данные по дате отчета
все в одном файле
это  подстраивается подсовет
Подсчет дней переработки с учетом вахотового метода работы, Свыше 30 дней непрерывной работы - переработка
 
чуть логики и автофильтр
Изменено: dude - 3 июл 2019 18:33:24
Был ли сбой в период времени
 
Код
=ЕСЛИ(СУММ(--(ЕСЛИ(C2<$Q$2:$Q$5;C2;$Q$2:$Q$5)-ЕСЛИ(B2>$P$2:$P$5;B2;$P$2:$P$5)>0))=0;"нет";"да")
=СУММ(ЕСЛИОШИБКА((ЕСЛИ(C2<$Q$2:$Q$5;C2;$Q$2:$Q$5)-ЕСЛИ(B2>$P$2:$P$5;B2;$P$2:$P$5))^0,5;)^2)

как формула массива
Построение диаграммы (графика) по нескольким столбцам только по непустым значениям
 
http://www.excelworld.ru/forum/2-2544-1
Макрос для экспорта данных из Excel по условию в документ Word, есть таблица Excel с данными по поставщикам и есть шаблонный документ Word. Нужно на основании таблицы создать тарифные приложения по каждому поставщику.
 
все это реализуется только в экселе
приложение это еще один лист
функции: ВПР и СЦЕПИТЬ (&)
Поиск текста в ячейке по ключевым словам
 
Код
=ЕСЛИОШИБКА(ИНДЕКС(Sup!$A$57:$A$89;АГРЕГАТ(15;6;Sup!$F$57:$F$89/ЕТЕКСТ(Sup!$B$57:$E$89)/ЕЧИСЛО(ПОИСК(Sup!$B$57:$E$89;I2));1));$BQ$1)
Создать список, в котором будут только те строки, где разница между ячейками
 
функция РАЗНДАТ и автофильтр
Поиск значения по частичному совпадению игнорируя пробелы и знаки
 
https://www.planetaexcel.ru/techniques/7/5636/
Рассчет дней не учитивая праздники
 
Код
=РАБДЕНЬ.МЕЖД(K1;L1-1;"0000000";$P$3:$P$13)
Рассчет дней не учитивая праздники
 
Код
=K1+L1*2-ЧИСТРАБДНИ.МЕЖД(K1;L1+K1-1;"0000000";$P$3:$P$13)-1
Рассчет дней не учитивая праздники
 
Код
=K1+L1*2-ЧИСТРАБДНИ.МЕЖД(K1;L1+K1-1;"0000000";$P$3:$P$13)
Изменено: dude - 30 апр 2019 21:37:41
Как найти минимальное количество общих цифр в массиве данных, Как найти минимальное количество общих цифр в массиве данных
 
Цитата
хотя бы одна из них будет в каждой строке
уточните условия, в вашем примере число 10 в 6 строках (максимум)
Расчет регрессивной шкалы оплаты., Формула расчета стоимости в зависимости от количества выполненной работы
 
Код
=СУММПРОИЗВ((E2>$A$2:$A$6)*(E2-$A$2:$A$6)*$C$2:$C$6)
Автомотическое удаление нулевых значений диаграммы по оси Х
 
использовать для диаграммы диапазон, преобразующий нулевые значения в НД!
Формирование сводного документа из нескольких листов, Формирование реестра из данных расположенных в разных листах по критерию
 
функция двссыл
Извлечь количество 2-3х мест в строках по каждому столбцу.
 
спортсмены и игроки не перепутались?
Автоматическая прорисовка границ и выделение цветом в новом диапазоне ячеек
 
десять групп
при ярких цветах граница не актуальна
Изменено: dude - 2 мар 2019 22:06:09
Автоматическая прорисовка границ и выделение цветом в новом диапазоне ячеек
 
>недоразумения с цветопередачей принтера
можно найти цвета без недоразумений :)

для 3*8 вводить 8 в 3 последовательные ячейки
сколько всего может быть групп?
Автоматическая прорисовка границ и выделение цветом в новом диапазоне ячеек
 
=И(B$7<=$C$3;$B8<=$C$2;C$7<=ВПР(-ОСТАТ($B8;2)+2;$AP$4:$BV$5;6);C$7>ВПР(-ОСТАТ($B8;2)+2;$AP$4:$BV$5;5))
добавлять новые правила, изменяя это правило для всего диапазона с увеличением красных чисел на единицу
группы одинаковые и жирные границы не стал делать, есть же цвет
Определить кто с кем из сотрудников пересекается по датам отпусков, Есть график отпусков. Пересечения определятся если они есть, но не понятно с каким сотрудником/ми
 
формула массива, тянуть вправо и вниз
Код
=ЕСЛИОШИБКА(ИНДЕКС($AI:$AI;АГРЕГАТ(15;6;СТРОКА($AI5:$AI$57)/(ЕСЛИ($AK5:$AK$57>$AK4;$AK4;$AK5:$AK$57)-ЕСЛИ($AJ5:$AJ$57>$AJ4;$AJ5:$AJ$57;$AJ4)+1>0);ЧИСЛСТОЛБ($AI$4:AI$4)));"")
Автозаполнение и печать квитанций из массива данных
 
с данными по выставленным счетам и оплатой и таблицами подстановки
разные результаты функции ПРОСМОТР как части СУММПРОИЗВЕД и самой по себе
 
ларчик был открыт
формулу на листе для ratio сделал так ПРОСМОТР(ЦЕЛОЕ(искомое);....)
всё заработало
разные результаты функции ПРОСМОТР как части СУММПРОИЗВЕД и самой по себе
 
один месяц не соответствует. Числа в столбце J – транспонированные значения из строки 26 для ratio. К-т (ratio U6) специально сделан 1 для соответствия столбцу J
разные результаты функции ПРОСМОТР как части СУММПРОИЗВЕД и самой по себе
 

Добрый день!

Делал болванку для расчета денежных потоков по проектам.

Лист l. Доли платежей рассчитал для равномерных, уменьшающихся, увеличивающихся и с провалом и подъемом в середине на длительности 60 месяцев.,

Лист для ratio (вспомогательный) для расчета поправочных к-тов к долям для длительностей меньших 60. Меньшие длительности искусственно расширены на 60 (важно в основном для кривых).

Лист ratio. для выбора поправочного к-та к исходным долям для длительностей, отличных от 60. Рассчитано для длительностей от5.

Лист итог. Формула в столбце Н берет данные из таблицы слева (месяц начала, сумму, длительность, и метод распределения) и для каждого проекта выбирает расчетную долю для определённого месяца и поправочный к-т и суммирует.

Когда все длительности были 60, всё было ОК. При разной длительности сумма столбца Н не соответствует сумме из таблицы. Специально выбрал нестрогое соответствие для поиска номера периода умножением текущего номера на результат отношения 60/длительность проекта.

В приведенном файле для длительности 22 месяца и распределения провалом один месяц не соответствует. Числа в столбце J – транспонированные значения из строки 26 для ratio. К-т (ratio U6) специально сделан 1 для соответствия столбцу J

Формулы считал по шагам. Источника ошибки не нашел. Пробовал связку ИНДЕКС-ПОИСКПОЗ. ГПР. Ничего

Счётеслимн считает пустые ячейки но с формулой
 
=СЧЁТЕСЛИМН('тут считет пустое'!H7:H15;A7;'тут считет пустое'!K7:K15;F7;'тут считет пустое'!Q7:Q15;">""")
Поиск в массиве части текста из эталонного списка и при совпадении перенос значения
 
Другой подход. одна таблица для сумм и построчно фирмы и их деятельность. при больших объемах данных менее ресурсоемко
1C против Excel в бизнесе, Что есть такого в 1С, что не сделать в Excel и наоборот?
 
Excel - потрясающая программа (даже с некоторыми придирками)
Поэтому смотри на старшего брата и учись! А не изобретай велосипед
надеюсь, что никто не будет спорить с тем, что программирование это вспомогательная деятельность, призванная сделать более эффективной основную?
И что мы имеем в 1С (с чем столкнулся я,и я не бухгалтер):
1 для защиты от дурака выпадающие списки должны быть пустыми (без значения по умолчанию) (не все, конечно), без заполнения всех дальше не пойдёшь
2 торг12, стандартная конфигурация не предусматривает заполнения граф, положенных по закону
3 the best! подписанты документов. какое отношение база ФЛ имеет к этому? Какая проблема подтягивать список подписантов по дате документа.
4 в восьмёрке блок для руководителя, состояние расчётов с контрагентами. это песня: номеров строк нет, автофильтра нет, фирмы не по алфавиту, актуальности данных нет.
1C против Excel в бизнесе, Что есть такого в 1С, что не сделать в Excel и наоборот?
 
Простите за грубость
1С - ..., написано ламерами для ламеров, если мягко.
мнение основано на опыте внедрения двух их продуктов
Страницы: 1 2 3 4 5 6 7 8 9 10 11 ... 36 След.
Наверх