Поиск  Пользователи  Правила 
Закрыть
Логин:
Пароль:
Забыли свой пароль?
Регистрация
Войти
 
Выбрать дату в календареВыбрать дату в календаре

Страницы: 1 2 3 4 След.
VBA. Экспорт из Excel в xml. Как создать самозакрывающийся тег xml
 
Благодарю.
Подскажите как отформатировать вывод xml с отступами, но без замены самозакрывающихся тегов?

Как переделать этот код? Или есть другой способ?
Код
'Процедура для придания XML читабельного вида (с отступами)
Sub transformXML(ByRef xml As Variant)

    'Cоздание объекта XSL
    Set xsl = CreateObject("MSXML2.DOMDocument")
    
    'Загрузка XSL из строки (не требует наличия отдельного XSL-файла)
    xsl.LoadXML ("<xsl:stylesheet version='1.0' xmlns:xsl='http://www.w3.org/1999/XSL/Transform'>" & vbCrLf & _
    "<xsl:output method='xml' version='1.0' encoding='UTF-8' indent='yes'/>" & vbCrLf & _
    "<xsl:template match='@*|node()'>" & vbCrLf & _
    "<xsl:copy>" & vbCrLf & _
    "<xsl:apply-templates select='@*|node()' />" & vbCrLf & _
    "</xsl:copy>" & vbCrLf & _
    "</xsl:template>" & vbCrLf & _
    "</xsl:stylesheet>")
    
    'Выполнение преобразования
    xml.transformNodeToObject xsl, xml

End Sub
Изменено: Евгений Кириллов - 22 Авг 2017 06:33:05
VBA. Экспорт из Excel в xml. Как создать самозакрывающийся тег xml
 
Задача сформировать xml файл.
Тег "photo" должен быть самозакрывающийся:
Код
<photo url="pic1.jpg" />

Сейчас получается создать только парные теги:
Код
<photo url="pic1.jpg">
</photo>
Код
    Set createImg = createGood.appendChild(xml.createElement("photo"))
    createImg.setAttribute "url", photo
Операции с элементами диапазонов разного размера
 
Очень добрый день.

!!! Задача
1 Сцепляем непустые ячейки всех столбцов (количество ячеек может быть разным), каждый элемент с каждым через пробел;
2 Определяем длину строки каждой получившейся комбинации
3 Считаем число комбинаций с длинной строки меньше 50 символов.

? Возможно ли формулой, без VBA?
Все операции с массивами производятся только с одинаковыми размерами (((
Сохранить фильтр интерактивной таблицы
 
Alexey Ko, записать макрос...
Расчет схемы приема препарата Варфарин, нужна помощь кардиологу!
 
Денис, А еще можно добавить историю приема препарата прошлых недель, что вероятно даст понимание как изменение дозы влияет на изменение MHO.
И не ясно как влияет на результат анализов пиковое принятие препарата, например, в схеме на день сдачи анализа приходится прием на 1 таблетку больше/меньше, чем в течении всей недели.

В последнем посте ваши критерии пересекаются, потому как +/-0,5 от цели 2,5 (диапазон нормы) - 20%, либо корректировка на 20% либо не меняем курс лечения?!
Расчет схемы приема препарата Варфарин, нужна помощь кардиологу!
 
Денис, в ячейке L3 поменяйте 10% на 5% или любое другое... ограничение в 20% меняется в L4
Расчет схемы приема препарата Варфарин, нужна помощь кардиологу!
 
Не стал привязываться к предопределенным схемам приема лекарства:

Выбираем тип MHO.
Сравниваем отклонение текущего показателя от целевого.
Если отклонение меньше 10%, то лечение не меняем.
Если отклонение белее 20%, то меняем дозу на 20%.
Если отклонение в диапазоне от 10-20%, то меняем на это процент.
Определяем количество таблеток на неделю с точностью до половины таблетки.
Распределяем равномерно недельное количество по дням с точностью до половины таблетки.
Расчет схемы приема препарата Варфарин, нужна помощь кардиологу!
 
vikttur, дак, и я о том же. все таблетки имеют полоски для удобного деления на 2 части. зачем скачки 1 - 2 - 1 -2 такого сильного препарата? или я чего то не понимаю в медицине.
Расчет схемы приема препарата Варфарин, нужна помощь кардиологу!
 
Денис, программы лечения изменению не подлежат?
В группе схем лечения "A" возможен прием по половине таблетки,
но в группе "B" уже нет, могут чередоваться прием 1 2 1 2 1 2, почему не 1,5 1,5 1,5 1,5 1,5 ...???  
Нахождение суммы в массиве данных с условием по строкам и столбцам.
 
{=СУММ(ЕСЛИ($C16=Поставщик;1;0)*ЕСЛИ(D$15=Период;1;0)*МассивДанных)}
ФМ
Копирование динамической диаграммы
 
Бонус, тогда привязка (формулы) должна быть с указанием листа, если не указан то данные будут ссылаться на новый лист где нет данных.
Не могу отследить ошибку в формуле (с поиском поз. по двум условиям)
 
Цитата
Jnas пишет: ЕСЛИ(распределение!O:O=C14
У вас не ФМ, поэтому первое значение в диапазоне распределение!O:O = «20F-MRI-03»
Любое другое значение выдаст #Н/Д
Условное форматирование повторяющихся значений по нескольким столбцам
 
İlham Heydar, через доп. столбик Сцепить()
http://www.planetaexcel.ru/techniques/14/69/
Макрос для диагональной замены значений на "0", Копирование значений с построчной заменой значений
 
Smerd,
Код
=ЕСЛИ(СТРОКА()>=СТОЛБЕЦ();Исходник!A1;0)
Совместить 2 диаграммы с накоплением в одну
 
Acid Burn,
я бы не лепил все в 1 график:
отдельно показал бы: - план-факт, динамику было-стало, за счёт чего ± (добавлено / ликвидировано ).
1 мысль = 1 слайд (диаграмма/гарфик)!
Отображает дату числом
 
evgeniy_m,
Код
=--A1

И да, формат ячейки Дата в нужном вам виде.
Создание выпадающего списка с данными из несмежных ячеек + связанные с ними списки
 
jurij271, http  :/  /www.planetaexcel.ru/techniques/2/80/ - сортировка формулой;
http :/ /www.planetaexcel.ru/techniques/1/38/ - зависимы выпадающие списки
Разъяснение функции ЕСЛИ
 
SUM, функция ЕСЛИ() работает следующим образом (вам же нужно разъяснение функции ЕСЛИ?):

= ЕСЛИ ( Логическое выражение - сравниваете то, что вам нужно с тем, что вам нужно ; Что делать если сравнение истинное ; Что делать если сравнение ложное )
Подсчет количества значений при условии в Excel 2003., Подсчет значений справа налево от условия.
 
okiel,
Код
=СЧЁТЕСЛИМН($M$2:$M$29;O2;$J$2:$J$29;"ДАТА" )
Изменено: Евгений Кириллов - 26 Июл 2014 20:23:55
Совместить 2 диаграммы с накоплением в одну
 
Acid Burn, возможно, вас устроит такая визуализация.
Проблемы с формулой =РАБДЕНЬ() в условном форматировании, Как подсветить два следующих рабочих дня?
 
Юрий Глодовский,
Код
=И((РАБДЕНЬ(СЕГОДНЯ();2)>=A1);(ДЕНЬНЕД(A1;2)<6);(A1>СЕГОДНЯ()))
в мой версии Excel нет РАБДЕНЬ.МЕЖД()
Совместить 2 диаграммы с накоплением в одну
 
Acid Burn, что вы хотите видеть, добавив эти данный на диаграмму ? Если просто добавить, то выделить диапазон Ctrl + C  и вставить в диаграмму Ctrl + V  :)
Изменено: Евгений Кириллов - 25 Июл 2014 21:26:16
Проблемы с задвоенными строками
 
AlyKun,
Код
=ЕСЛИОШИБКА(ВПР(C2;ТаблицаЛиц;1;0);A1)
=ЕСЛИ(A1<>A2;0;ЕСЛИОШИБКА(ВПР(C2;ТаблицаКатегорийЛиц;1;0);B1))
При такой структуре можно и в сводную таблицу передать
Изменено: Евгений Кириллов - 25 Июл 2014 09:04:26 (добавил файл, исправил формулы)
Перенос столбцов таблицы по условию, по нескольким условиям
 
я Ирина, если без макроса то надо доработать в исходные данные для сводной таблицы, колонку "флаг" - если значение в нужном месяце больше 2%.
и добавить в фио строку "прочее" сумма всего что без "флага"
В сводной фильтр по флагу.
Сводная диаграмма на основе сводной таблицы.
Как сделать обновление графика от динамического диапазона
 
я Ирина, пожалуйста.
Формулой ВПР выбрать формулу для расчета даты платежа
 
verrrra,
=ВПР() - для выбора отсрочки из справочника компания-отсрочка
=РАБДЕНЬ() - для определения срока платежа в банковских днях

Большего, за неимением от вас файла примера, сделать для вас не могу. (см. правила форума)
Разделить окно в Excel на более чем 4 окна
 
Shikamaru, Если просто видеть части книги, используйте инструмент Камера.
Вынесение новых значений в ячейке в отдельный столбец
 
LILLY, без макроса, вносить значение прямо в таблицу
дату и время вставлять горячими клавишами:

Дата: Ctrl+Shift+;
Время: Ctrl+Shift+:
Замена пустых ячеек на среднее соседних
 
Цитата
vikttur пишет:
для чего так растягивать сообщение?
В строке 3 - его текущая формула, выделил таким способом (осознанно). Существенно на высоту комментария не повлияло.
Замена пустых ячеек на среднее соседних
 
oleg28,
Код
=ЕСЛИ(ЕПУСТО(RC[-2]);
СРЗНАЧ(R[-1]C;R[1]C)
;RC[-2]) 
Страницы: 1 2 3 4 След.
Наверх