Поиск  Пользователи  Правила 
Закрыть
Логин:
Пароль:
Забыли свой пароль?
Регистрация
Войти
 
Выбрать дату в календареВыбрать дату в календаре

Страницы: 1 2 3 4 5 6 7 8 9 10 11 ... 55 След.
Присвоить формулу ячейке при заполнении из формы, Нужно правильно расставить синтаксис
 
Ruskat учитывая, что Вы вводите данные в плоскую таблицу, то оформите ее как умную и необходимость ввода формул отпадет сама собой.
Требуется макрос (макросы) для разделения отчета на разные файлы и сшивания обработанных файлов в один отчет
 
Пишу в личку.
Сделано.
Изменено: skais675 - 1 Апр 2020 17:58:46
Присвоить формулу ячейке при заполнении из формы, Нужно правильно расставить синтаксис
 
Ruskat, ну и где попытки вставить формулу, на каком листе, какой макрос, где форма?
Присвоить формулу ячейке при заполнении из формы, Нужно правильно расставить синтаксис
 
Ruskat, приложите пример. И еще вариант - может лучше просто протягивать формулу или копировать и вставлять если диапазон разрывной?
График. Наименование основной вертикальной оси макросом
 
Код
Public Sub plot()
    Sheets("График").Select
    With ActiveChart
        .SetElement (msoElementPrimaryCategoryAxisTitleAdjacentToAxis)
        Selection.Format.TextFrame2.TextRange.Characters.Text = "Дата, время"
        
        .SetElement (msoElementPrimaryValueAxisTitleRotated)
        .Axes(xlValue, xlPrimary).AxisTitle.Text = "Процесс 1"
        
        .SetElement (msoElementSecondaryValueAxisTitleRotated)
        .Axes(xlValue, xlSecondary).AxisTitle.Text = "Процесс 2"
    End With
End Sub
Изменено: skais675 - 31 Мар 2020 17:10:04
Подсчет суммы в столбце до определенной ячейки и далее новый подсчет
 
Пишу в личку.
Сделано.
Оплачено.
Изменено: skais675 - 1 Апр 2020 13:09:57
Закрепление строк в виде "групп" и "подгрупп" для оформления сводных таблиц
 
ДЭНЧИК147, для начала нужно правильно сформировать источник данных.
Суммирование и выведение стоимости продукта
 
Решение.
Скрытый текст
Изменено: skais675 - 29 Мар 2020 21:32:15
Суммирование и выведение стоимости продукта
 
aniramulis, Ну и где пояснения и наглядный пример что и как нужно сделать?
Изменено: skais675 - 29 Мар 2020 16:22:47
Суммирование и выведение стоимости продукта
 
aniramulis,Хороший ответ, а нам что делать?
Код
Или это уже нереальная просьба?

Для формул Ваша задача думаю слишком сложна будет, возможно выполнима, макросом однозначно выполнима.
Изменено: skais675 - 29 Мар 2020 16:19:51
Суммирование и выведение стоимости продукта
 
aniramulis Приложите пример более наглядный с подробным пояснением, что и как должно вычисляться.
Цитата
Самый последний приход по умолчанию в столбцах ближе к левому краю.
Обычно мы дополняем справа.
И где же узнать остаток?
Изменено: skais675 - 29 Мар 2020 16:06:28
Суммирование и выведение стоимости продукта
 
Код
=СУММЕСЛИ($2:$2;"Кол-во, шт.";3:3)

Код
=СУММПРОИЗВ((СМЕЩ($D$2;;;;СЧЁТЗ($2:$2)-3)="Кол-во, шт.")*СМЕЩ($D3;;;;СЧЁТЗ($2:$2)-3)*СМЕЩ(СМЕЩ($D3;;;;СЧЁТЗ($2:$2)-3);;2))/B3
Изменено: skais675 - 29 Мар 2020 15:44:03
Как отфильтровать в столбце нужное слово
 
Ivanfnfnnf Не понимаю, их искать не нужно фильтр отлично работает, Вы хоть пробовали?
Да и выполните просьбу модератора с логином.
Как отфильтровать в столбце нужное слово
 
Ivanfnfnnf Ну так обычный фильтр это делает, непонятно в чем проблема?
Изменено: skais675 - 29 Мар 2020 13:31:08
Определить ближайшее для указанного числа
 
Код
=ВПР(40;A:A;1;1)
Изменено: skais675 - 29 Мар 2020 13:04:47
Как отфильтровать в столбце нужное слово
 
Ivanfnfnnf Это как? если у вас в строчке помидоры, огурцы, баклажаны Вы хотите увидеть только слово огурцы?
Как отфильтровать в столбце нужное слово
 
А вы пробовали фильтровать?
Шаблон таблицы, Контроль сроков и объемов возвратов с выделением цветом
 
Пишу в личку.
Не со мной.
Изменено: skais675 - 28 Мар 2020 20:47:17
уникальные + неуникальные значения с условием
 
Формула массива
Код
=ЕСЛИ(СЧЁТЕСЛИ(A:A;A1)=1;"да";ЕСЛИ(C1-B1=МИН(ЕСЛИ(A:A=A1;C:C-B:B));"да";"нет"))

Судя из логики можно первое условие упустить и оставить только
Код
=ЕСЛИ(C1-B1=МИН(ЕСЛИ(A:A=A1;C:C-B:B));"да";"нет")
Изменено: skais675 - 27 Мар 2020 12:53:18
Подтягивание значений из другого листа в зависимости от выбранного из раскрывающегося списка
 
Annsound, стандартно ВПР
Код
=ЕСЛИОШИБКА(ВПР([@[Наименование элемента]];Группы!C:D;2;0);"")
Подсчет суммы в столбце до определенной ячейки и новый подсчет
 
Решение.
Код
Sub Формулы()
    arr = ActiveSheet.UsedRange.Value
    fr = 13
    For i = 13 To UBound(arr)
        If arr(i, 1) = "" And arr(i, 6) <> "" And arr(i, 8) <> "" Then
            Cells(i, "A").FormulaR1C1 = "=SUM(R[-1]C:R[" & fr - i & "]C)"
            fr = i
        End If
    Next
End Sub
Таблица/программа для быстрого подсчета результатов
 
Пишу в личку.
Сделано.
Оплачено.
Изменено: skais675 - 19 Мар 2020 17:44:49
Как победить #Н/Д, Как правильно написать формулу что бы не появлялась #Н/Д
 
sandra_m приложите пример, где не получилось с моей формулой.
Поиск и сопоставление значений и их замена
 
Ford2018, куда посмотреть?
Как победить #Н/Д, Как правильно написать формулу что бы не появлялась #Н/Д
 
sandra_m в моем примере?
Поиск и сопоставление значений и их замена
 
Функция ВПР Вам в помощь, для наглядности приложите пример.
Как победить #Н/Д, Как правильно написать формулу что бы не появлялась #Н/Д
 
sandra_m в предыдущей теме я же выложил Вам пример.
Как во все листы вставить в определенную ячейку название каждого соответствующего листа?
 
Arthur26 сделайте без именованного диапазона.
Плановый процент в зависимости от трех показателей
 
sandra_m пишем ЕСЛИОШИБКА - чем не устраивает?
Плановый процент в зависимости от трех показателей
 
Добавляем доп столбец и ВПР
или формула массива
Код
=ИНДЕКС($C$2:$C$4;ПОИСКПОЗ(B8&C8;$A$2:$A$4&$B$2:$B$4;0))
Изменено: skais675 - 18 Мар 2020 17:37:11
Страницы: 1 2 3 4 5 6 7 8 9 10 11 ... 55 След.
Наверх