Поиск  Пользователи  Правила 
Закрыть
Логин:
Пароль:
Забыли свой пароль?
Регистрация
Войти
 
Выбрать дату в календареВыбрать дату в календаре

Страницы: 1 2 3 4 5 6 7 8 9 10 11 ... 23 След.
Power Query. Трансформация структуры отчета из 1С в плоскую таблицу.
Поиск минимального значения в зависимости от соседнего столбца
 
Добрый день
Код
=АГРЕГАТ(15;6;B2:B6/(A2:A6<>"");1)

так попробуйте
и файл с примером, конечно, не помешает
Распределить товар по магазинам, Распределить товар по магазинам. Каждый магазин имеет один из 4-х форматов, товар часто может находиться не во всех форматах.
 
Добрый вечер. ela98, поясните, почему для магазина 1 (формат 1) план 40, если количество товара на формат 1 равно 24?
Первое и последнее число платежа
 
ещё вариант
Код
=АГРЕГАТ(15;6;$A$4:$A$42/(ЕЧИСЛО(B4:B42));1)

Код
=АГРЕГАТ(14;6;$A$4:$A$42/(ЕЧИСЛО(B4:B42));1)

обычные
Изменено: Stics - 12 Сен 2019 14:04:40
[ Закрыто] Сортировка значений в зависимости от ячейки
 
Код
=СУММПРОИЗВ(ЕСЛИОШИБКА(($C$21:$H$27=J20)*($C$20:$H$26);0))

массивная
для модератора: "Суммирование значений по условию"
Изменено: Stics - 11 Сен 2019 22:51:15
[ Закрыто] Сортировка значений в зависимости от ячейки
 
И Вам добрый день! Файл с примером приложите. Это ускорит и упростит помощь.
Подстановка всех значений согласно искомому значению в столбец по порядку
 
Добрый день!
ну и АГРЕГАТОМ до заодно. Обычная.
Код
=ЕСЛИОШИБКА(ИНДЕКС($B$4:$B$12;АГРЕГАТ(15;6;(СТРОКА($C$4:$C$12)-3)/($C$4:$C$12=$E$3);СТРОКА(A1)));"")
Наиболее распространенное слово в столбце
 
Начните с файла с примером. Вы поставьте себя на место помогающего, посмотрите на Вашу формулу и определите желание разобраться и помочь.
Среднее значение между двумя столбцами если есть еще один критерий
 
Добрый день!
Цитата
joda1307 написал:
есть еще один критерий
что за критерий?
Приложите файл с примером. "Что есть" -> "как надо". Это упрощает и ускоряет помощь.
а так как понял
Код
=ЕСЛИ(СЧЁТЗ(A1:B1)=2;СРЗНАЧ(A1:B1);"")
Изменено: Stics - 11 Сен 2019 21:26:12
Расскидать случайным образом число в диапазоне
 
Цитата
franchesko написал:
каждое из 13 чисел должно быть больше 90
Цитата
franchesko написал:
примерно в радиусе 100 (+-50)
два условия противоречат друг другу
150 * 13 = 1950 < 2148
нужно какое-то условие скорректировать
а так СЛУЧМЕЖДУ попробуйте для генерации 12 чисел, а 13-е = 2148 - [сумма первых 12-и сгенерированных чисел]
Формирование групп из массива данных
 
Цитата
Inexsu написал:
Рюкзак тут и рядом не валялся :-)
Значит показалось, что похожая формулировка). Для общего развития подскажите тогда кто "валялся"?)
Изменено: Stics - 5 Сен 2019 12:16:51
Формирование групп из массива данных
 
Ras174, поищите "задачу о рюкзаке". На форуме, кажется тоже встречались похожие задачи
линейный тренд с помощью ПРЕДСКАЗ()
 
Цитата
futurama3000 написал:
предположим, что я не знаю, что тренда нет. Есть просто набор конечных данных. Как быть?
1. Проверить наличие тренда.
2. Если тренд есть использовать модель Y = b*x + a
3. Если тренда нет, использовать модель Y = a
Изменено: Stics - 3 Сен 2019 12:25:34
линейный тренд с помощью ПРЕДСКАЗ()
 
Добрый день! Не очень понятно, зачем вы тренд оцениваете, если знаете, что его изначально нет.
Модель, которую вы оцениваете: Y = b*x + a. И коэффициент "b" в любом случае будет оценен, как отличный от 0, поэтому Y = 100 не получается.
Если тренда нет, то оцените модель Y = a (a=Yсреднее), тогда и получите Y = 100.
Почему exel не считает корректную формулу?, Exel перестал считать формулы
 
alenasever, сравните то, что Вам написали,
Код
=СУММПРОИЗВ((B2:B18)*1)

и что у Вас
Как выбрать самую позднюю дату, Есть отчет, в котором у одного пользователя может стоять несколько дат. Нужно выбрать самую позднюю дату
 
PQ
Поиск соответствия условию в таблице
 
Цитата
Mershik написал:
никак не подружусь с агрегатом)
А я уже от НАИМЕНЬШИЙ/НАИБОЛЬШИЙ отвык)
Основной момент в том, что деление "/" выполняет роль фильтра.
т.е. в СТРОКА($A$1:$A$5)/(C$3:C$7="ТО") мы делим либо на 0, либо на 1.
Если делим на 0, то получаем #ДЕЛ/0! и игнорируем его, а с оставшимися значениями работаем дальше
В целом принцип такой же как и в вашей формуле.
Поиск соответствия условию в таблице
 
Цитата
ATPZT написал:
То, что я выбрал вручную, и то, что выводит формула, - совершенно разные вещи
исправил. Ссылки абсолютные в одном месте забыл открепить
Поиск соответствия условию в таблице
 
или так
Код
=ЕСЛИОШИБКА(ИНДЕКС(C$12:C$16;АГРЕГАТ(15;6;СТРОКА($A$1:$A$5)/(C$3:C$7="ТО");СТРОКА(A1)));"")
Лист Microsoft Excel (2) (5)_ред.xlsx (12.51 КБ)
Изменено: Stics - 21 Авг 2019 17:48:28
Поиск соответствия условию в таблице
 
ATPZT, покажите итоговый результат в файле, который прикрепили. Так проще будет.
Поиск соответствия условию в таблице
 
как понял
для модератора: "поиск соответствия условию в таблице"
Изменено: Stics - 21 Авг 2019 16:22:11
Подсчет пробега автомобилей
 
ещё вариант для
Цитата
Mershik написал:
или так?
Код
=F18-ИНДЕКС($F$2:F17;АГРЕГАТ(14;6;($A$2:A17)/($B$2:B17=B18);1);0)
Отчет по реестру инициатив, Два автора под одним номером инициативы
 
как вариант
Код
=ЕСЛИОШИБКА(ИНДЕКС($I$2:$I$16;АГРЕГАТ(15;6;(СТРОКА($A$2:$A$16)-1)/($A$2:$A$16=$Q$8);СТРОКА(A1)));"")
Автоматическая нумерация строк с текстом
 
Добрый день!
Как вариант.
Код
=СЖПРОБЕЛЫ(ПРАВСИМВ(ПОДСТАВИТЬ(E3;" ";ПОВТОР(" ";ДЛСТР(B3)));ДЛСТР(B3)))&"."&" "&B3
Изменено: Stics - 1 Авг 2019 17:34:41
Нумерация повторяющихся строк
 
как вариант
Код
=ОКРУГЛВВЕРХ(СТРОКА(A1)/3;0)
Расчет среднего значения цены закупки последних 3-х поставок товара, Как сделать чтобы считалось только среднее арифметическое последних трех цен закупки определенного товара
 
как вариант
P.S.
hitrik, уточните, у Вас указана "цена закупки" или "стоимость закупки"?
Изменено: Stics - 1 Авг 2019 10:47:12
Повторяющиеся значения
 
вариант на PQ
Код
let
    Источник = Excel.CurrentWorkbook(){[Name="Таблица1"]}[Content],
    index = Table.AddIndexColumn(Источник, "index", 1, 1),
    grp = Table.Group(index, "data", {"tmp", each Table.AddIndexColumn(_, "ind", 1, 1)}),
    expand = Table.ExpandTableColumn(grp, "tmp", {"index", "ind"}),
    sort = Table.Sort(expand, "index"),
    result = Table.AddColumn(sort, "result", each if [ind]=1 then [data] else null),
    final = Table.SelectColumns(result, "result")
in
    final
Поиск минимальных значений по условию, без задвоений
 
у Вас в примере три 0, какой из них и почему является наименьшим?
Изменено: Stics - 29 Июл 2019 14:02:17
Поиск минимальных значений по условию, без задвоений
 
так?
Код
=ИНДЕКС($A$2:$A$9;АГРЕГАТ(15;6;(СТРОКА($A$2:$A$9)-1)/($C$2:$C$9>=0)/($B$2:$B$9=$B$2);СТРОКА(A1)))
Выделить строки содинаковыми значениями в трех столбцах
 
попробуйте "условное форматирование"
Страницы: 1 2 3 4 5 6 7 8 9 10 11 ... 23 След.
Наверх