Поиск  Пользователи  Правила 
Закрыть
Логин:
Пароль:
Забыли свой пароль?
Регистрация
Войти
 
Выбрать дату в календареВыбрать дату в календаре

Страницы: 1 2 3 4 5 6 7 8 9 10 11 ... 27 След.
Сортировка огромной таблицы и добавление + удаление лишних строк, Необходимо удалить и добавить новые строки в таблицу
 
PQ
но без пустых строк
Код
let
    Источник = Excel.CurrentWorkbook(){[Name="Таблица1"]}[Content],
    date = Table.TransformColumnTypes(Источник,{{"Дата накладной", type date}}),
    min_max = Table.Group(date, "Наименование товар", {{"min", each Table.Min(_, "Дата накладной")},{"max", each Table.Max(_, "Дата накладной")}}),
    unpivot = Table.UnpivotOtherColumns(min_max, {"Наименование товар"}, "Атрибут", "Значение"),
    out = Table.FromRecords(unpivot[Значение]),
    type_date = Table.TransformColumnTypes(out,{{"Дата накладной", type date}})
in
    type_date
Сортировка огромной таблицы и добавление + удаление лишних строк, Необходимо удалить и добавить новые строки в таблицу
 
Leto123, Добрый день!
Файл с примером приложите "что есть" -> "как надо".
Вывод цены по приоритетности по заданным данным
 
вариант
Код
=ИНДЕКС(B5:E5;;АГРЕГАТ(15;6;(СТОЛБЕЦ(B$2:$E3)-1)/НЕ(ЕПУСТО(B5:E5));1))

в G4
Изменено: Stics - 31 Мар 2020 21:09:11
Поиск текстового словосочетания из одного массива в другом массиве.
 
ещё вариант
Код
=ЕСЛИ(ЕЧИСЛО(ПРОСМОТР(2;1/ПОИСК($G$8:$G$12;A24)));"Да";"Нет")

массивная
Большой диапазон данных нужно сгруппировать в доступном виде.
 
вкладке "Просмотр" есть "Расширенный редактор".
Изменено: Stics - 26 Мар 2020 15:50:31
Большой диапазон данных нужно сгруппировать в доступном виде.
 
ДЭНЧИК147, код выше это не макрос, а скрипт Power Query.
С макросом не смогу помочь
Большой диапазон данных нужно сгруппировать в доступном виде.
 
ДЭНЧИК147, обновил #2.
Изменено: Stics - 26 Мар 2020 14:07:10
Большой диапазон данных нужно сгруппировать в доступном виде.
 
Здравствуйте!
Сводной можно

или PQ

Код
let
    Источник = Excel.CurrentWorkbook(){[Name="Таблица1"]}[Content],
    grp = Table.Group(Источник, {"Товар"}, {{"количество", each List.Sum([#"К-во"]), type number}, {"средняя_цена", each List.Average([Розничная цена]), type number}}),
    out = Table.AddColumn(grp, "стоимость", each [количество]*[средняя_цена])
in
    out
Изменено: Stics - 26 Мар 2020 14:05:01 (добавлен вариант на PQ)
Минимум и максимум стандартного отклонения
 
gfer, примеры, как правило, в виде файлов прикладывают. Это же не сложно, и всем проще файл открыть, чем данные копировать.
Вы так стандартную ошибку выборочного среднего считаете.
Попробуйте использовать ДОВЕРИТ, ДОВЕРИТ.НОРМ, или ДОВЕРИТ.СТЬЮДЕНТ.
Минимум и максимум стандартного отклонения
 
gfer, пример небольшой приведите с данными. "что есть" -> "как надо". Думаю так гораздо быстрее получите помощь
Удаление одинаковых пар в двух столбцах
 
aleksa_yara, посмотрите, исправил в #7
Удаление одинаковых пар в двух столбцах
 
вариант (без количества)
Код
=ЕСЛИ(ЕЧИСЛО(ПОИСКПОЗ(A2&B2;$B$2:$B$8&$A$2:$A$8;0));"дубль";"нет")


или так
Код
=СУММПРОИЗВ(--(A6&B6=($B$2:B6&$A$2:A6)))

формула массива
Изменено: Stics - 25 Мар 2020 20:09:08
Умножать только на первую цифру
 
здравствуйте!
Код
=--ЛЕВСИМВ(M15;1)*$U$14
SVM - метод опорных векторов. Решения с помощью ВБА
 
как искали? в гугле по запросу "svm excel vba" куча ссылок. Но на английском, правда. Если для практических задач, то смотрите лучше в сторону R/Python
Обработка множества txt-файлов. Удалить все после двоеточия в каждой строке
 
Цитата
BobbyJo написал:
Нужно во всех файлах удалить все
это в раздел Работа
Подсчете пациентов, заболевших ОРВИ в определенном возрастном диапазоне
 
Добрый день!
вариант
Код
=СУММПРОИЗВ(($A$2:$A$11<=C23)*($D$2:$D$11="ОРВИ"))-СУММПРОИЗВ(($A$2:$A$11<=C22)*($D$2:$D$11="ОРВИ"))
Присвоить последовательную нумерацию блокам данных.
 
вариант
Код
=ЕСЛИ(ЕПУСТО(B2);"";ЕСЛИ(ЕПУСТО(B1);A1;D1))
Расчет доли сотрудников с определенными показателями, Необходимо посчитать долю сотрудников,удовлетворяющих определенным критериям, в каждой группе
 
для первой группы 3%
Код
=СУММПРОИЗВ(--(D3:D15>=0,03))

далее по аналогии
Подсчет общего количества одинаковых наименований.
 
еще вариант для списка упорядоченного по "Аптека" и "Наименование"
Код
=ЕСЛИ(ИЛИ(A2<>A3;B2<>B3);СУММЕСЛИМН($C$2:$C$23;$A$2:$A$23;A2;$B$2:$B$23;B2);"")
office 365
 
Всем добрый день! Приобрел подписку на office 365 для дома. Срок действия до 15 марта 2021 года. В наличии 5 ключей. Может кому нужно. Отдам по себестоимости - 469 руб за ключ.
Как сформировать из одной таблицы другую с меньшим числом столбцов но с одинаковой датой
 
Добрый день!
формулами можно так
Код
=ЕСЛИОШИБКА(ИНДЕКС('2018....'!$A$8:$S$16;АГРЕГАТ(15;6;(СТРОКА('2018....'!$P$8:$P$16)-7)/('2018....'!$P$8:$P$16=$F$4);СТРОКА(A1));ПОИСКПОЗ(A$5;'2018....'!$A$7:$S$7;0));"")


названия колонок таблиц должны быть везде одинаковыми
Power Query Замена данных в массиве на основе справочника
 
вариант кнопками
Код
let
    Источник = Excel.CurrentWorkbook(){[Name="График"]}[Content],
    unpivot = Table.UnpivotOtherColumns(Источник, {"Этаж"}, "Атрибут", "Значение"),
    merge = Table.NestedJoin(unpivot,{"Значение"},Справочник,{"Наименование"},"Справочник",JoinKind.LeftOuter),
    expand = Table.ExpandTableColumn(merge, "Справочник", {"Количество"}, {"Количество"}),
    delete = Table.RemoveColumns(expand,{"Значение"}),
    out = Table.Pivot(delete, List.Distinct(delete[Атрибут]), "Атрибут", "Количество")
in
    out
Формула для нахождения дельты в % (отклонение) по четырем условиям
 
Evajons, дельты в % если план и факт с разными знаками не считают. Считают только разницу "факт" - "план".
Подсчет количества уникальных значений при условии
 
добрый день!
Предлагаю ввести признак "комплектность" и считать по нему
Код
=СУММПРОИЗВ(ЕСЛИОШИБКА(((F2:F11="комплект")*(A2:A11=I4))/СЧЁТЕСЛИМН(B2:B11;B2:B11;A2:A11;A2:A11;C2:C11;C2:C11;D2:D11;D2:D11);0))
Поиск самого раннего значения по дате с дополнительным условием
 
ещё вариант
Код
=ИНДЕКС($C$2:$C$6;ПОИСКПОЗ(МИН(ЕСЛИ($A$2:$A$6=A3;$B$2:$B$6;""));$B$2:$B$6;0))


для модератора: "Поиск самого раннего значения по дате с дополнительным условием"
PQ Получить номер месяца из его названия
 
вот это не поможет?
Траспонирование данных из столбца в строки без повторений
 
на базе формулы Настя_Nastya,
Код
=ЕСЛИ($A2<>$A1;ИНДЕКС($B2:$B5;СТОЛБЕЦ(A$1));"")
Изменено: Stics - 21 Фев 2020 22:20:00
Найти максимальное значение для одинаковых имен и присвоить им имя
 
Ещё вариант. Не массивная.
Код
=ЕСЛИ(АГРЕГАТ(14;6;($B$2:$B$11)/($A$2:$A$11=A2);1)=B2;"Больше";"Меньше")
Найти максимальное значение и присвоить имя из списка
 
и ещё вариант
Код
=ИНДЕКС(A1:A20;АГРЕГАТ(15;6;СТРОКА(B1:B20)/(B1:B20=МАКС(B1:B20));1))
Cоздание массива дат из произвольных интервалов дат
 
Olegio555, чем PQ не устраивает?
Страницы: 1 2 3 4 5 6 7 8 9 10 11 ... 27 След.
Наверх