Поиск  Пользователи  Правила 
Закрыть
Логин:
Пароль:
Забыли свой пароль?
Регистрация
Войти
 
Выбрать дату в календареВыбрать дату в календаре

Страницы: 1 2 3 4 5 6 7 8 9 10 11 ... 24 След.
PQ, Отмечать записи, после которіх значение не повторяется
 
так?
формула массива
Код
=ЕСЛИ(B6=МАКС(($C$2:$C$8=C6)*($B$2:$B$8));"Да";"Нет")
Добавить в одну таблицу данные из подгруппы другой PQ
 
sku
Очередное сравнение таблиц с одинаковой структурой
 
Добрый день!
Цитата
mihail_ms написал:
позже если надо
нужно, желательно в виде "как есть" -> "как надо".
Вникать в текст без наглядного примера мало кому интересно.
Как при одинаковом населении получить из справочника разные города
 
Gaust, Вы в курсе, что для Германии ряд значений не числовые, а текстовые?
Генерация случайных чисел для средней с условием, для Excel 2003
 
Максим, а в этой теме как, помог ответ?
Изменено: Stics - 15 Ноя 2019 15:51:40
Подтянуть информацию из массива данных при соблюдении нескольких условий
 
добрый день!
Как понял.
Формула массива.
Код
=ЕСЛИОШИБКА(ИНДЕКС($H$2:$H$6;ПОИСКПОЗ(A2&B2;$G$2:$G$6&$I$2:$I$6;0));"нет данных")
задача, Найти сумму значений ТО, Т и К с учетом ОТМ за месяц с определенным БЕ
 
Игорь68, у Вас файл пустой. И с таким названием темы модераторы не пропустят.
Массив с повторяющимися значениями
 
в приёмах вот эту тему посмотрите

или в PQ можно сделать
Изменено: Stics - 12 Ноя 2019 15:22:08
Поиск по 2 значениям в горизонтали
 
покажите небольшой пример в реальной структуре данных
Поиск по 2 значениям в горизонтали
 
Цитата
paff написал:
Почему от строки отнимаем -3 ? (чтобы понять где начало?)
да
Поиск по 2 значениям в горизонтали
 
paff,
Цитата
paff написал:
как сюда еще дату впихнуть!?
в M12
Код
=ЕСЛИОШИБКА(ИНДЕКС($D$4:$D$21;АГРЕГАТ(15;6;(СТРОКА($A$4:$A$21)-3)/($A$4:$A$21=$K12)/($C$4:$C$21=$L12)/($B$4:$B$21=$J12);СТРОКА($A$1)));"")
ДД Как прибавить число во втором актете
 
Hugo, надо полагать это как октет, только "актет")
PowerQuery_группировка с усреднением и произвольным кол-вом столбцов(?)
 
Добрый день!
мышкой
Код
let
    Source = Excel.CurrentWorkbook(){[Name="Table3"]}[Content],
    unpivot = Table.UnpivotOtherColumns(Source, {"TvCompany"}, "Атрибут", "Значение"),
    pivot = Table.Pivot(unpivot, List.Distinct(unpivot[Атрибут]), "Атрибут", "Значение", List.Average)
in
    pivot
Подсчет уникальных значений в соседнем столбце, по заданному критерию
 
Wild.Godlike, у меня работает. в "C7" скопировали?
Поиск по 2 значениям в горизонтали
 
ещё вариант
Размножить таблицу на строки другой таблицы
 
Добрый день!
вариант на PQ
Скрыть строки несоответствующие выбранному значению.
 
Добрый день!
Как вариант.
А проще всего фильтр выставить: вкладка "Данные" -> "Фильтр"
Изменено: Stics - 8 Ноя 2019 17:31:33
Подсчитать количество уникальных значений в диапазоне.
 
вариант на PQ
Код
let
    Источник = Excel.CurrentWorkbook(){[Name="Таблица1"]}[Content],
    id = Table.AddColumn(Источник, "id", each 1),
    unpivot = Table.UnpivotOtherColumns(id, {"id"}, "atrib", "value"),
    type_change = Table.TransformColumnTypes(unpivot,{{"value", type text}}),
    count_distinct = Table.Group(type_change, {"atrib"}, {"tmp", each List.Count(List.Distinct([value]))}),
    result = Table.Transpose(count_distinct),
    #"Повышенные заголовки" = Table.PromoteHeaders(result, [PromoteAllScalars=true]),
    #"Измененный тип" = Table.TransformColumnTypes(#"Повышенные заголовки",{{"a", Int64.Type}, {"b", Int64.Type}, {"c", Int64.Type}})
in
    #"Измененный тип"
Автоматически выводить количество товаров определенного вида в определенном типе вагонов
 
Sharmat, в приемахпосмотрите. Как раз все подробно написано
Автоматически выводить количество товаров определенного вида в определенном типе вагонов
 
Sharmat, ПРОСМОТР ищет 9^9 = 387420489, не находит его и возвращает последнее числовое значение массива.
PQ Транспонирование столбцов
 
День добрый!
расчёты t-критерия Стьюдента, преобразование формул/расчётов из Excel 2007 в Excel 2003
 
Цитата
Vladimir Chebykin написал:
Думаю, формулы и их аналоги, которые Вы ищите, отстутствовали в принципе в эксель 2003.
были они, но не в полном объеме
Максим,
посмотрите, так Вам нужно?
Суммирование в ячейках соответствующих условию, суммесли
 
Код
=СУММПРОИЗВ((ПРАВСИМВ($C$3:$C$9)=ТЕКСТ(C12;0))*($D$3:$D$9))

как вариант
выборка топовых значений
 
добрый день!
Код
=СУММ(АГРЕГАТ(14;6;($B$2:$B$42)/($A$2:$A$42=G2);{1:2:3}))

формула массива

PQ
Код
let
    Источник = Excel.CurrentWorkbook(){[Name="Таблица1"]}[Content],
    result = Table.Group(Источник, {"fio"}, {"result", each List.Sum(List.MaxN([sales], 3))})
in
    result
Изменено: Stics - 31 Окт 2019 17:43:25 (добавлен вариант на PQ)
Вычислением среднего значения диапазона ячеек по условиям
 
добрый день!
как понял
Среднее значение между массивами дат с применением выбора
 
_strekoza_, в Вашем примере нет объекта "щ" и нет дат 2017 года.
Наименьшее по уникальным значениям
 
Уточните, а какой результат Вы ожидаете? Функция выдает значения в штатном режиме.
Поиск второго или третьего результата и возврат его позиции
 
вариант
Код
=АГРЕГАТ(15;6;(A5:A13)/(B5:B13=D5);E5)
Power Query - удаление дубликатов по условиям
 
buchlotnik, спасибо, взял приём в работу)
Power Query - удаление дубликатов по условиям
 
Добрый день! Так?
Код
let
    Источник = Excel.CurrentWorkbook(){[Name="Звіт_по_заведеним_заявкам_в_КФ"]}[Content],
    tmp = Table.Group(Источник, "ФИО Клиента", {{"tmp", each Table.Max(_, "Дата создания Заявки")}, {"amount", each List.Count([Тип])}}),
    result = Table.FromRecords(tmp[tmp]),
    join = Table.NestedJoin(result, {"ФИО Клиента"}, tmp, {"ФИО Клиента"}, "tmp", JoinKind.LeftOuter),
    expand = Table.ExpandTableColumn(join, "tmp", {"amount"}, {"amount"}),
    #"Измененный тип" = Table.TransformColumnTypes(expand,{{"Дата создания Заявки", type datetime}, {"Дата отправки", type datetime}})
in
    #"Измененный тип"
Изменено: Stics - 10 Окт 2019 17:43:34
Страницы: 1 2 3 4 5 6 7 8 9 10 11 ... 24 След.
Наверх