Поиск  Пользователи  Правила 
Закрыть
Логин:
Пароль:
Забыли свой пароль?
Регистрация
Войти
 
Выбрать дату в календареВыбрать дату в календаре

Страницы: 1 2 3 4 5 6 7 8 9 10 11 ... 28 След.
PQ Разница между дат внутри таблицы
 
Топорненько, конечно:
Код
let
    from = Excel.CurrentWorkbook(){[Name="Table1"]}[Content],
    group = Table.Group(from, {"Менеджер"}, {{"temp", each [#"Дата операции"], type table}}),
    join = Table.NestedJoin(from,"Менеджер",group,"Менеджер","All"),
    lists = Table.TransformColumns(join,{{"All", each [temp]{0}}}),
    diff = Table.AddColumn(lists, "Пользовательская", each try [#"Дата операции"]-List.Skip([All],List.PositionOf([All],[Дата операции])-1){0} otherwise #duration(0,0,0,0)),
    to = Table.RemoveColumns(diff,{"All"})
in
    to
Каждому For свой Next
Выборка значений из последнего подсчитанного столбца
 
Цитата
Saigon написал:
не совсем то получилось,
какой вопрос... ловите:
Код
=ИНДЕКС(B3:P3;МАКС(ЕСЛИ($A$3:$O$14*ЕНЕЧЁТ(СТОЛБЕЦ($A$3:$O$14));СТОЛБЕЦ($A$3:$O$14);"")))
Каждому For свой Next
Получение соседних значений от полученного формулой значения
 
Код
=ИНДЕКС($D$4:$D$15;ПОИСКПОЗ("h";$B$4:$B$15;0)+СТРОКА(A3)-1)
Каждому For свой Next
Выборка значений из последнего подсчитанного столбца
 
массивка
Код
=ИНДЕКС(B3:P3;МАКС(ЕСЛИ(A3:O3*ЕНЕЧЁТ(СТОЛБЕЦ(A3:O3));СТОЛБЕЦ(A3:O3);"")))
Каждому For свой Next
Подсчёт количества уникальных значений с учётом условия
 
ещё можно сводной
Каждому For свой Next
Поиск и подстановка номера заказа по его статусу формулой
 
Цитата
dredd812 Frant написал:
это и есть запрос через PQ
там два варианта - на формулах (слева) и на PQ (справа)
Цитата
dredd812 Frant написал:
Попробовал вставить формулу в А2,
как вставляли? показывайте. Формулы массива вводятся сочетанием ctrl+shift+enter
Каждому For свой Next
Поиск и подстановка номера заказа по его статусу формулой
 
так вам просто статусы собрать чтоли?  (массивка)
Код
=ЕСЛИОШИБКА(ИНДЕКС(Таблица1[Заказ];НАИМЕНЬШИЙ(ЕСЛИ(ЕТЕКСТ(Таблица1[Статус]);СТРОКА(Таблица1[Заказ])-1;"");СТРОКА(A1)));"")

бонусом PQ
Код
let
    from = Excel.CurrentWorkbook(){[Name="Таблица1"]}[Content],
    remove = Table.SelectColumns(from,{"Заказ", "Статус"}),
    to = Table.SelectRows(remove, each ([Статус] <> null))
in
    to
Каждому For свой Next
Поиск всех элементов списка в текстовых значениях другого списка
 
Цитата
Asim написал:
что означает ^0
любое число, кроме нуля, возведенное в нулевую степень даст 1, сумма единиц = количество совпадений, что формула вам и выдает.
Каждому For свой Next
Имя функции в переменной
 
а
Код
Select Case Target.Address
не поможет?
Каждому For свой Next
Остановить вычисление формулы в ячейке при заполнении другой ячейки.
 
не до конца понимаю зачем вам сравнение с 3000, но базовая конструкция такая :
Код
 =ЕСЛИ(ЕПУСТО(I11);СЕГОДНЯ()-I6;I11-I6)
Каждому For свой Next
Поиск всех элементов списка в текстовых значениях другого списка
 
OFF ну вот, нашёл крайнего; может тему почистить до осмысленного состояния?
Изменено: buchlotnik - 14 Сен 2019 12:43:29
Каждому For свой Next
Остановить вычисление формулы в ячейке при заполнении другой ячейки.
 
Цитата
Nik108 написал:
как сделать
формулой - никак, кроме ситуации, когда в заполняемую ячейку вносят именно дату остановки вычислений
Изменено: buchlotnik - 14 Сен 2019 12:28:06
Каждому For свой Next
Разделить значение по условию количества символов в соседнем столбце через PQ
 
а Text.Replace - ПОДСТАВИТЬ()  :D
ну и до кучи
Код
let
    from = Excel.CurrentWorkbook(){[Name="Таблица1"]}[Content],
    to = Table.AddColumn(from, "to", each Text.BeforeDelimiter([Столбец2], "-", 1), type text)
in
    to
Изменено: buchlotnik - 14 Сен 2019 12:13:16
Каждому For свой Next
Разделить значение по условию количества символов в соседнем столбце через PQ
 
Строго по примеру:
Код
let
    from = Excel.CurrentWorkbook(){[Name="Таблица1"]}[Content],
    to = Table.AddColumn(from, "to", each Text.Replace([Столбец2],"-"&[Столбец1],""))[[to]]
in
    to
а строго по вопросу в теме:
Код
let
    from = Excel.CurrentWorkbook(){[Name="Таблица1"]}[Content],
    to = Table.AddColumn(from, "to", each Text.Start([Столбец2],Text.Length([Столбец2])-Text.Length([Столбец1])-1))
in
    to
Изменено: buchlotnik - 14 Сен 2019 11:56:17
Каждому For свой Next
Поиск всех элементов списка в текстовых значениях другого списка
 
Цитата
Андрей VG написал:
Осмелюсь, предположить
Цитата
Asim написал:
Задача такая: нужно узнать содерджится ли
какой вопрос...
Изменено: buchlotnik - 14 Сен 2019 09:39:57
Каждому For свой Next
Поиск всех элементов списка в текстовых значениях другого списка
 
массивка
=СУММ(ЕСЛИОШИБКА(ПОИСК($F$5:$F$9;B5)^0;0))
тема - поиск всех элементов списка в текстовых значениях другого списка
Каждому For свой Next
Транспонирование столбца со сдвигом
 
offendj, вы бы изначально дали вменяемый пример - как у вас соотносятся количество перечислений в столбце 3 и число возможных столбцов с изображениями - меньше бы было недоразумений
Изменено: buchlotnik - 14 Сен 2019 01:02:56
Каждому For свой Next
При заполнении шести ячеек, появляется отметка в седьмой ячейке
 
Код
=ЕСЛИ(СЧЁТЗ(шесть ячеек)=6;"заказ готов";"")
Каждому For свой Next
Закрашивание ячейки при заполнении
 
Цитата
Val023 написал:
Подскажите формулу,
формулы не красят ячейки, формула для УФ а ля НЕ(ЕПУСТО()) может помочь
Каждому For свой Next
PQ_определить регистр буквы
 
Цитата
sokol92 написал:
А нельзя
да можно, но больно громоздко выходит:
Код
=Text.Upper(Text.End([Column2],1))=Text.End([Column2],1) and Text.Lower(Text.End([Column2],1))<>Text.End([Column2],1)
чуть короче, но тоже заморочно:
Код
=[a=Text.End([Column2],1),b = Text.Upper(a)=a and Text.Lower(a)<>a][b]

зато действительно универсально, sokol92, , спасибо за алгоритм  ;)
Изменено: buchlotnik - 13 Сен 2019 22:10:09
Каждому For свой Next
PQ_определить регистр буквы
 
Цитата
PooHkrd написал:
И если уж докапываться
ну блин, на Ё заканчивается если только что-то из японского  :D
Каждому For свой Next
PQ_определить регистр буквы
 
вариант
Код
=List.ContainsAny({Text.End([Column2],1)},{"A".."Я"})
Изменено: buchlotnik - 13 Сен 2019 16:50:17
Каждому For свой Next
Power Query. При группировке развернуть значения столбца в строку через разделитель.
 
PooHkrd, забавно, а я пишу просто [парам] без _ и это работает
Каждому For свой Next
Замена во всех формулах одного столбца названия ячейки на числовое значение
 
Только в обратном порядке : F??? -> F?? -> F?
Каждому For свой Next
Power Query. При группировке развернуть значения столбца в строку через разделитель.
 
Можно и в одну строчку  :D
Код
Table.Group(Excel.CurrentWorkbook(){[Name="Таблица1"]}[Content], {"имя"}, {"Количество", each Text.Combine([парам],", "), type text})

PooHkrd, а такое наименование шагов - ручная доводка напильником или есть возможность так настроить?
Изменено: buchlotnik - 12 Сен 2019 09:45:52
Каждому For свой Next
Подстановка значений в Power Pivot по соответствию вхождения в диапазон значений
 
Так можно же банальными ЕСЛИ : =ЕСЛИ(([@[Номер телефона]]>=Таблица1[Диапазон от])*([@[Номер телефона]]<=Таблица1[Диапазон до]);Таблица1[Регион])
Каждому For свой Next
Как закрасить текст в outlook при отправке его из excel?
 
Цитата
dadac21 написал:
с outlook взаимодействовать
тут с html взаимодействовать надо, может так понятнее будет:
Код
 .HTMLBody = "<span style=""color: rgb(255, 255, 0)"">желтая строка<br>" & _
"<span style=""color: rgb(0, 0, 0)"">черная строка<br>ещё черная строка"

ну или в вашем случае:
Код
olMailItm.HTMLBody = "Добрый день!<br><br><span style=""color: rgb(255, 255, 0)"">Данные:  " & c
Изменено: buchlotnik - 11 Сен 2019 11:11:36
Каждому For свой Next
Поиск ячеек с числами в строках с определенным количеством столбцов
 
Светлый, я сделал без допов вариант от PooHkrd, про несколько пар в исходном примере ни слова - см  #1 и учтите, что мое сообщение #5, а про несколько пар возникло в #9
я знаю ограничения своей формулы, спасибо
Изменено: buchlotnik - 10 Сен 2019 07:14:10
Каждому For свой Next
Удалить строчку с одновременным поднятием картинок
 
показывайте пример - в норме  при условии
Цитата
Vasilij_83 написал:
перемещать и изменять объект вместе с ячейками
должно работать, максимум как дополнить
Код
Rows(i).Delete Shift:=xlUp
Изменено: buchlotnik - 9 Сен 2019 19:18:42
Каждому For свой Next
Поиск ячеек с числами в строках с определенным количеством столбцов
 
на формулиста не претендую, но вариант без допов:
Код
 =СУММ(--((B2:F2-A2:E2)=1))+(СУММ(--((B2:F2-A2:E2)=1))>0)
Каждому For свой Next
Страницы: 1 2 3 4 5 6 7 8 9 10 11 ... 28 След.
Наверх