Выбрать дату в календареВыбрать дату в календаре

Страницы: 1 2 3 4 5 6 7 8 9 10 11 ... 130 След.
Сумма значений по вертикальному и горизонтальному условию
 
Здравствуйте.
Попробуйте так:
Код
=СУММПРОИЗВ(($A$2:$A$8=$A13)*СМЕЩ(ИНДЕКС($B$2:$AJ$2;ПОИСКПОЗ($C$11;$B$1:$AJ$1;));;;7;$C$12-$C$11+1))
или так
=СУММПРОИЗВ(($A$2:$A$8=$A13)*(ИНДЕКС($B$2:$AJ$2;ПОИСКПОЗ($C$11;$B$1:$AJ$1;)):ИНДЕКС($B$8:$AJ$8;ПОИСКПОЗ($C$12;$B$1:$AJ$1;))))
подсчет количества отрицательных/положительных значений
 
Здравствуйте.
Попробуйте формулу массива
Код
=ЕСЛИ(ЗНАК(A1)=ЗНАК(A2);"";ЗНАК(A2)*(ПОИСКПОЗ(ЛОЖЬ;ЗНАК(A2:A22)=ЗНАК(A2);)-1))
Изменено: gling - 06.10.2022 23:29:50
макрос фильтра ИЛИ для трёх столбцов
 
Без макроса. В четвертом столбце пишем формулу
Код
=СЧЁТЗ(A1:C1)>0

Протягиваем её до конца данных, выделяем фильтром ЛОЖЬ в этом столбце и удаляем строки со значением ЛОЖЬ.

Выпадающий список с одинаковыми значениями между уровнями, Excel
 
Здравствуйте.
Вариант в файле. Так ли?
Вставить кнопку в документ
 
Цитата
написал:
как это
Нажмите на плюсик (+) над столбцом А.
Найти ФИО ДО определенного значения в листе и ПОСЛЕ того же значения. Вернуть эти значения в разные ячейки., Помогите дописать формулу .дописать формулу
 
После "Оптом"
Код
=ЕСЛИОШИБКА(ВПР('График работы + План намесяц'!B16;ИНДЕКС('01'!T:T;ПОИСКПОЗ("Оптом";'01'!$A$1:$A$103;)):'01'!$A$130;5;);)

Протягивание формулы ПОИСКПОЗ("Оптом";01!A1:A103;) без закрепления диапазона приведёт к ошибке.

Найти ФИО ДО определенного значения в листе и ПОСЛЕ того же значения. Вернуть эти значения в разные ячейки., Помогите дописать формулу .дописать формулу
 
А я не переводом занимался, просто правил формулу. Конечно MATCH это ПОИСКПОЗ
Изменено: gling - 24.09.2022 22:33:52
Найти ФИО ДО определенного значения в листе и ПОСЛЕ того же значения. Вернуть эти значения в разные ячейки., Помогите дописать формулу .дописать формулу
 
Это `01`, не ссылка на лист, это просто текст. По видимому должно быть так '01'!$A$1, вместо точки с запятой воскл. знак. И здесь ошибка СЧЕТЕСЛИ("Оптом";A1:A103;). Третьего аргумента быть не должно (после второй ; пустота, следовательно это 0), первый аргумент должен быть диапазон и СЧЁТ пишется через Ё. Это у СУММЕСЛИ 3 аргумента.
Изменено: gling - 24.09.2022 22:33:16
Не работает пересчёт данных при использовании формул в умной таблице, Формула не работает, когда берёт данные из умной таблицы, которые рассчитаны автоматической формулой
 
Здравствуйте. А автоматический пересчёт формул включен?
Суммирование при соблюдении нескольких условий
 
Здравствуйте.
Вариант без доп.строк.
Код
=СУММЕСЛИ(Исходник!$C$2:$P$2;"*"&ТЕКСТ(Итоговая!$I$1;"ММ.ГГГГ")&" S*";ИНДЕКС(Исходник!$C$8:$P$44;ПОИСКПОЗ(Итоговая!$H3;Исходник!$B$8:$B$44;);))
=СУММЕСЛИ(Исходник!$C$2:$P$2;"*"&ТЕКСТ(Итоговая!$I$1;"ММ.ГГГГ")&" R*";ИНДЕКС(Исходник!$C$8:$P$44;ПОИСКПОЗ(Итоговая!$H3;Исходник!$B$8:$B$44;);))
выпадающие окна
 
И вам здравствовать.
Вы создали в соседних столбцах три разные таблицы. Сначала каждый столбец преобразуйте в диапазон, а потом объедините их в одну таблицу и всё у вас получится.
Рассчитать в таблице "продажи" цену и сумму товара в зависимости от даты
 
Здравствуйте.
Ещё вариант, только сливы и груши в начале показывают нули, так как неизвестна их цена на эту дату, цена в прайсе появилась позже. Прайс отсортирован по датам.
Код
=СУММЕСЛИ($C$4:$C$18;ПРОСМОТР([@[Дата продажи]];1/($A$4:$A$18=[@Наименование])*$C$4:$C$18);$B$4:$B$18)
Цикличная универсальная формула для поиска совпадающих значений и подстановки данных
 
Цитата
написал:
под этим кодом 10000078656 кол-во на остатках 8
Тогда попробуйте так, но это последний не равный нулю остаток, а последний остаток = 0.
Код
=ИНДЕКС(Лист2!F:F;СУММПРОИЗВ(НАИБОЛЬШИЙ((Лист2!$A$2:$A$12=Лист1!B2)*(Лист2!$F$2:$F$12>0)*СТРОКА(Лист2!$A$2:$A$12);1)))
Изменено: gling - 24.08.2022 10:46:23
Цикличная универсальная формула для поиска совпадающих значений и подстановки данных
 
Здравствуйте.
В вашем файле ошибка, ведь правильный результат остатка по товару 10000050287 =0. Это и показала формула. Следовательно в комент: должно быть = находит. Почему результат должен быть другой?
Попробуйте использовать разницу СУМЕСЛИМН() с учётом всех условий по получению и расходу.
Изменено: gling - 24.08.2022 09:17:38
Как перевести ячейки с цифрами в числовые значения ?, Есть ячейки с цифрами, но Эксель их не воспринимает как числа. Как это исправить ?
 
Здравствуйте.
Есть вариант без формул и макросов. Но в этом случае все преобразования произойдут в тех-же ячейках где и записаны.
Выделяете диапазон данных--нажимаете Ctrl+H (или на ленте под биноклем -заменить)-- в окне Найти: пишите isk-- жмете Заменить все, далее в окне Найти: стираете isk и зажав кнопку Alt слева клавиатуры в правой части кнопок цифрами набираете номер 0160-- жмете Заменить все. Если не хотите набирать номер 0160, можно скопировать пробел в любой ячейке между числами и вставить этот пробел в окно Найти. Т.е. Копируете пробел--в Найти:--выделяете нужный диапазон--Заменить все.  
Изменено: gling - 22.08.2022 18:38:29
Связанный впадающий список в каждой ячейке столбца, В зависимости от выбранного поставщика и типа товара выпадать должен соответствующий список с артикулами. Особенность в том, что выпадающий список должен быть в каждой ячейке столбца, а не только в одной.
 
Здравствуйте.
Посмотрите вариант с вашим расположением данных и два варианта с изменёнными расположениями данных.
На мой взгляд. с вашим расположением данных сложнее получается.
Изменено: gling - 17.07.2022 22:24:43
Как макросом пошагово двигать картинку
 
Цитата
написал:
Возможен ли автозапуск макроса при каждом входе на страницу?
Да возможен. Посмотрите варианты движений, может используете что и для себя. Скачал давно, где не помню.
Гиперссылки из выпадающего списка
 
Здравствуйте.
Попробуйте в С2 формулу
Код
=ГИПЕРССЫЛКА("#'"&B2&"'!A1";ВПР(B2;Каталог;2;))

Изменено: gling - 19.06.2022 20:13:42
Как присвоить ячейкам столбца числа, соответствующими номеру ячейки
 
Код
=ИНДЕКС(B:B;A1)
Поиск из массива и подсчет
 
Здравствуйте.
Цитата
написал:
Можно ли это сделать формулами
Варианты в файле. Для каждой таблицы формулы разные.
Суммировать до определенной даты
 
Здравствуйте.
Вариант в файле.
Код
=ЕСЛИ(C$1="П";СУММ(ИНДЕКС($A3:C3;ПОИСКПОЗ("я";$A$1:B$1;1)+1):C3);0)
Изменено: gling - 29.05.2022 23:32:43
Как извлечь значение после символов
 
Данные--Текст по столбцам--с разделителями--другой--:
Поиск суммарных значений по каждому году, какая формула может на листе расчет при выбранном значении года просуммировать значения из листа данные, по каждой позиции товара
 
Ещё вариант
Код
=СУММЕСЛИ(Данные!$C$1:$I$1;"<="&$A$2;ИНДЕКС(Данные!$C$3:$I$8;ПОИСКПОЗ(B4;Данные!$B$3:$B$8;);))
Отобразить в сводной таблице среднее в зависимости от двух показателей
 
Здравствуйте. А поэксперементировать, слабо? Строки: Карат, Цвет, Прозрачность. Значения: Цена (среднее значение)
Поиск первого значения в диапазоне больше текущего
 
Попробуйте формулу массива
Код
=ИНДЕКС(A4:A142;ПОИСКПОЗ(1;--(B4:B142>B1);))
или
=ИНДЕКС(A4:A142;ПОИСКПОЗ(1=1;B4:B142>B1;))
Как собрать данные из значения ячеек на разных листах?
 
Код
=СУММЕСЛИ(ДВССЫЛ("'"&B$1&"'!A:A");$A2;ДВССЫЛ("'"&B$1&"'!B:B"))
Название листа в формуле ВПР в зависимости от значения ячейки
 
Код
=ВПР(B1;ДВССЫЛ("'"&D1&"'!A1:B21");2;0)
Попробуйте так.
Суммирование по нескольким критериям, Подстановка результата суммирования на основе нескольких критериев
 
Формула массива. Проверяйте, ваш результат не сходится с тем что выдала формула.
Код
=ЕСЛИОШИБКА(ИНДЕКС($B$18:$D$22;ПОИСКПОЗ($A2;$A$18:$A$22;);ПОИСКПОЗ(1;--(НАЙТИ($B$17:$D$17;$B2)>0);))-СУММЕСЛИМН($C$2:C2;$A$2:A2;A2;$B$2:B2;B2);"")
Формула массива для сравнения дат
 
Цитата
написал:
Где тут косяк?
......................
суть вопроса заключалась больше в том, почему именно формула из файла-примера не работает
Возможно по тому что у ПОИСКПОЗ три аргумента ПОИСКПОЗ(искомое_значение, просматриваемый_массив, [тип_сопоставления]). Пропишите третий аргумент 0 и формула посчитает.
Изменено: gling - 25.02.2022 20:48:25
почему одинаковые значения дают разные суммы?, Подсчет времени ,данные в столбцах одинаковые , формат ячеек одинаков а
 
Цитата
написал:
формат ящеек суммы  [ч]:мм
Установите такой формат для данных двух столбцов, увидите разницу.
Страницы: 1 2 3 4 5 6 7 8 9 10 11 ... 130 След.
Наверх