Выбрать дату в календареВыбрать дату в календаре

Страницы: 1 2 3 4 5 6 7 8 9 10 11 ... 128 След.
обновление рабочего файла без открытия дополнительных файлов, Помогите, пожа
 
Здравствуйте.
Попробуйте СУММПРОИЗВ(). Конечно-же адрес расположения файла будет ваш.
Код
=СУММПРОИЗВ('C:\Users\User\Downloads\[файл 2 ставки.xlsx]Лист1'!$D$3:$D$50*('C:\Users\User\Downloads\[файл 2 ставки.xlsx]Лист1'!$A$3:$A$50>=КОНМЕСЯЦА(F3;-1)+1)*('C:\Users\User\Downloads\[файл 2 ставки.xlsx]Лист1'!$A$3:$A$50<=КОНМЕСЯЦА(F3;0))*('C:\Users\User\Downloads\[файл 2 ставки.xlsx]Лист1'!$B$3:$B$50=B3))
Суммировать в ОТФИЛЬТРОВАННОМ списке только уникальные значения
 
Попробуйте функцию ПРОМЕЖУТОЧНЫЕ.ИТОГИ()
Как обойти округление и отображать сотые значения без округления?
 
Здравствуйте.
Вариант
Код
=--ЕСЛИОШИБКА(ПСТР(D4*1,2;1;НАЙТИ(",";D4*1,2)+2);D4*1,2)
Изменено: gling - 12.08.2021 21:32:19
Развернуть таблицу из горизонтальной в вертикальную
 
Может на одном листе так надо?
Код
=ИНДЕКС(S3:AW3;ПОИСКПОЗ(МАКС(S3:AW3);S3:AW3;))
Развернуть таблицу из горизонтальной в вертикальную
 
Здравствуйте. Формула для подтягивания даты
Код
=ИНДЕКС('Форма от руководителя'!$Q$2:$BS$2;ПОИСКПОЗ(P3;ИНДЕКС('Форма от руководителя'!$Q$3:$BS$130;СУММПРОИЗВ(('Форма от руководителя'!$F$3:$F$130='То, что должно получиться'!F3)*('Форма от руководителя'!$I$3:$I$130='То, что должно получиться'!I3)*('Форма от руководителя'!$E$3:$E$130='То, что должно получиться'!E3)*('Форма от руководителя'!$K$3:$K$130='То, что должно получиться'!K3)*('Форма от руководителя'!$N$3:$N$130='То, что должно получиться'!M3)*СТРОКА('Форма от руководителя'!$A$1:$A$128)););))
Суммирование данных с начала года до указанного последнего месяца
 
Если не хотите ничего менять, попробуйте так:
Код
=СУММ($C$8:ИНДЕКС($C$8:$C$19;ПОИСКПОЗ(G4;$B$8:$B$19;)))
Об организации и представлении план-факт(-ных) данных
 
Цитата
Kirill Gureev написал:
Спасибо.
Не пришлось долго ждать, даже три года не прошло.
ВПР по нескольким условиям со счетом значений из другого списка
 
Цитата
snatg написал:
всем раздает по 13 очков
Согласен. Не совсем разобрался в логике расчёта ваших формул. Попытаюсь разобраться.
Возможно это не просто ВПР, а расчёт предварительных параметров внутри функции ВПР()
Может формула массива подойдет?
Код
=ЕСЛИ(СЧЁТЕСЛИ(Spisok!E:E;B2);ВПР(СУММ(($B$2:B2=ТРАНСП(Spisok!$E$2:$E$8))*($G$2:G2=G2));S:T;2;);"")
Изменено: gling - 27.06.2021 21:52:30
ВПР по нескольким условиям со счетом значений из другого списка
 
Здравствуйте!
Цитата
snatg написал:
как избавиться от формул в столбцах O и  P на листе Data
Так не пишите их туда и всё. Запишите их в последнею с ВПР.
Код
=ВПР(ЕСЛИ(СЧЁТЕСЛИМН(Spisok!E:E;Data!B2);СЧЁТЕСЛИМН(Data!B:B;Data!B2;Data!G:G;Data!G2);"");S:T;2;)

Только у вас в списке Список Д+ фамилии должны совпадать с фамилиями на листе Дата. Сидоров не равен Сидоров В.

Суммировать с условием заполняемости ячеек из другой части таблицы
 
Здравствуйте.
Попробуйте такую формулу
Код
=СУММ(B10:ИНДЕКС(B10:M10;ПОИСКПОЗ(9^9;B5:M5;1)))
Суммирование цифр в одной ячейке.
 
Здравствуйте.
Возможно есть вариант проще, но я его не знаю. Попробуйте формулу массива
Код
=СУММ(ЕСЛИОШИБКА(--ПСТР(A1;СТОЛБЕЦ(A3:G3);1);0))
Добавить в макрос условие повтора
 
Здравствуйте.

Ответ выше.

Изменено: gling - 05.06.2021 17:28:08
Взять данные из таблицы, из верхней и нижней ячеек относительно ячейки с 0
 
И Вам не хворать!
Ничего не понятно. От куда вытащить, куда, почему рядом с 660, а не с 680 или 640?  
Суммировать нагрузку в интервалах, если она неравномерная
 
Здравствуйте.
Название темы
Цитата
Распределение неравномерной нагрузки, суммировать нагрузку в интервалах, если она неравномерная
а в тексте
Цитата
samox написал:
Подскажите пожалуйста как исправить код
Так в чём проблема, нужно исправить код или что то нужно просчитать? Что то здесь не "вяжется",  или объясните что нужно посчитать или измените название темы.
Добавить график в диаграмму которая составлена по сводной таблице
 
Здравствуйте.
Цитата
Артем Коваленко написал:
Вопрос можно ли вообще это как-то реализовать?
Так надо? Использовал Вычисляемое поле сводной таблицы.
Сложную вертикальную таблицу - в горизонтальную, с условием
 
Цитата
Алла Комарова написал:
Выбор линии - ок... и ничего
Теперь созданный вами стиль должен отображаться как Пользовательский, выберите его.
Изменено: gling - 02.06.2021 21:56:09
На основе листа-шаблона создать листы отдельно для каждого сотрудника
 
Посмотрите здесь.
Кросс.
Изменено: gling - 02.06.2021 19:31:34
Сложение итогов с большого количества листов с разным названием итоговой строки
 
Здравствуйте!
Вариант формулой, но макросы должны быть включены. В диспетчере имен формула которая формирует список листов автоматически, о,новляется при пересчёте формул или нажатии F9. На основании формулы которую написал  Сергей.
Сложную вертикальную таблицу - в горизонтальную, с условием
 
И Вам здравствовать!
А сводная вас не устроит? В В1 фильтром можно выбрать интересующие события, так-же можно выбрать интересующие дни.
Как убрать символы в конце текста с условием?
 
Здравствуйте.
Попробуйте такую формулу
Код
=ПСТР(A2;1;ДЛСТР(A2)-3)&ПОДСТАВИТЬ(ПРАВСИМВ(A2;3);" |";"") 

Если пробел в конце будет мешать то можно так

Код
=СЖПРОБЕЛЫ(ПСТР(A2;1;ДЛСТР(A2)-3)&ПОДСТАВИТЬ(ПРАВСИМВ(A2;3);" |";""))
или так
=ПСТР(A2;1;ДЛСТР(A2)-3)&ПОДСТАВИТЬ(ПОДСТАВИТЬ(ПРАВСИМВ(A2;3);"|";"");" ";"")
Изменено: gling - 31.05.2021 20:13:42
Сумма по цвету с дополнительными условиями
 
Цитата
Дмитрий Петров написал:
Я уже делал так, чтобы была сумма только по зеленым ячейкам всего столбца C
Покажите как.
Цитата
Дмитрий Петров написал:
но как это комбинировать с суммпроизв я не могу понять.
В файле нашёл только СУММПРОИЗВ(), про цвет ничего не нашёл. Про формулу понятно, а вот как вы искали по цвету не понятно. По этой причине и помочь не получается. И для понимания, не мешало бы понять критерии закраски ячеек определёнными цветами.
макрос: суммирования строк по названию столбца, макрос: суммирования строк по названию столбца
 
Цитата
Екатерина написал:
написать макрос,
Но у вас в примере прописана формула. Может и формулы достаточно и не нужен макрос?
Код
=СУММЕСЛИ($A$1:$D$1;"Apple";A2:D2)+СУММЕСЛИ($A$1:$D$1;"Pineapple";A2:D2)
или
=СУММ(ИНДЕКС(A2:D2;ПОИСКПОЗ("Apple";$A$1:$D$1;));ИНДЕКС(A2:D2;ПОИСКПОЗ("Pineapple";$A$1:$D$1;)))
Нумерация повторяющихся значений по положению первого в столбце
 
Цитата
excel-student написал:
к сожалению не работает с текстом...я имею ввиду, если текст также и во втором столбце
А где вы увидели в первом сообщении "текст во втором столбце"? Показали числа=получили числа. Прописали бы текст=получили бы текст
Код
=ИНДЕКС($B$1:B1;ПОИСКПОЗ(A1;$A$1:A1;0))
.
Изменено: gling - 24.05.2021 20:41:35
Нумерация повторяющихся значений по положению первого в столбце
 
Здравствуйте.
Если правильно понял, то тема должна называться так: "Нумерация повторяющихся значений по положению первого в столбце."
Код
=ПОИСКПОЗ(A1;$A$1:A1;0)
Отметка в указанной ячейке, если произвели любые изменения в строке.
 
Здравствуйте.
Илья Антонов, создайте дубликат листа который хотите отдать на проверку -- меняете на нем все формулы на значения (если в этом есть необходимость) -- устанавливаете на него условное форматирование сравнения -- прячете его от посторонних глаз. После получения открываете его и смотрите какие ячейки изменились.  Небольшой вариант в файле.
Как можно формулой подсчитать количество повторений с верха - вниз?
 
Здравствуйте.
Вариант
Код
=СУММПРОИЗВ(ПОИСКПОЗ(0;--(A2:A15=A2);)-1)
Есть ссылка на столбец умной таблицы. Как взять это название столбца из другой ячейки ?, Как правильно сослаться ?
 
Здравствуйте.  Попробуйте так  
Код
=СУММ(ДВССЫЛ("Таблица["&G1&"]"))
А может и без ДВССЫЛ().
Код
=СУММ(ИНДЕКС(Таблица;;ПОИСКПОЗ(G1;Таблица[#Заголовки])) 
Изменено: gling - 22.05.2021 18:52:47
Сортировка чисел в последовательности 1...6 1...6
 
Здравствуйте. Вариант с доп. столбцом в файле.
Не получается заменить казалось бы одинаковую фразу во всех строках таблицы, хотя с виду она одинаковая везде
 
Цитата
mxuper написал:
в чём может быть проблема.
Возможно в количестве символов в ячейке. При поиске к учету берётся только первые 255 символов и если в этой длине нет нужного текста, то он и не находится поиском.
Подсчёт себестоимости товара в зависимости от выбранного листа склада
 
Здравствуйте. Посмотрите вариант. Переделка во второй строке, исправленные ячейки отмечены зелёным. Убрал в диспетчере имен именованные диапазоны, переименовал листы, заменил формулу в проверке данных, изменил вашу формулу.
Код
=ЕСЛИОШИБКА(ИНДЕКС(ДВССЫЛ("'"&$E2&"'!B1:B300");ПОИСКПОЗ($J2;ДВССЫЛ("'"&$E2&"'!A1:A300");0));0)+ЕСЛИОШИБКА(ИНДЕКС(ДВССЫЛ("'"&$E2&"'!B1:B300");ПОИСКПОЗ($L2;ДВССЫЛ("'"&$E2&"'!A1:A300");0));0)
Страницы: 1 2 3 4 5 6 7 8 9 10 11 ... 128 След.
Наверх