Поиск  Пользователи  Правила 
Закрыть
Логин:
Пароль:
Забыли свой пароль?
Регистрация
Войти
 
Выбрать дату в календареВыбрать дату в календаре

Страницы: 1 2 3 4 5 6 7 8 9 10 11 ... 120 След.
Получить из массива количество ресурсов по значению из первого столбца
 
Здравствуйте.
Вариант
Код
=ЕСЛИОШИБКА(ИНДЕКС($B$1:$AA$1;СУММПРОИЗВ(НАИБОЛЬШИЙ((ИНДЕКС($B$2:$AA$27;ПОИСКПОЗ($B$31;$A$2:$A$27;);)>0)*СТОЛБЕЦ($B$1:$AA$1);СТРОКА(A1)))-1);"")
Автоматическое увеличение диапазона таблицы при добавление новых данных в другую таблицу
 
Цитата
Уникальные значения из таблицы 1 я выбираю с помощью формулы.
А может на втором листе использовать сводную таблицу, тогда и формулы не нужны?
Изменено: gling - 27 Мар 2020 23:55:37
Многоуровневый выпадающий список на три уровня сегментации
 
Формула в диспетчере имен
Код
=ИНДЕКС(Лист2!$E$2:$BQ$2;ПОИСКПОЗ(Лист1!B2;Лист2!$E$1:$AL$1;)):ИНДЕКС(Лист2!$E$2:$BQ$32;СЧЁТЗ(ИНДЕКС(Лист2!$E$2:$BQ$30;;ПОИСКПОЗ(Лист1!B2;Лист2!$E$1:$AL$1;)));ПОИСКПОЗ(Лист1!B2;Лист2!$E$1:$AL$1;))
Автоматическое заполнение ячейки по критериям списка во втором столбце
 
Здравствуйте. Вариант, проверьте,возможно не всегда правильно будет считать. Если данные привести о одному виду, без пробелов, то можно и ВПР.
Код
=ПРОСМОТР(1;--(ПОИСК($N$2:$N$7;B2)>0);$O$2:$O$7)
Изменено: gling - 16 Фев 2020 00:57:09
Автоподбор высоты строки объединенной ячейки
 
Цитата
macrofag написал:
кто-нибудь сталкивался с таким
Здравствуйте.
Была такая необходимость, по заполнению типовых бланков отчетности. Нужно было и высоту строк подогнать и чтобы подписи на бланке не убежали на другую страницу. Найденные мной макросы приладил, но обработка шла медленно.
Выкрутился следующим образом: вне поля печатной страницы в строках с объединенными ячейками создал столбец, шириной равной объединенным ячейкам. Необходимые данные вставлял в обе ячейки, объединенной, которая будет печататься, и не объединенной, в доп столбце. Высота строки автоматом формировалась по ячейке доп. столбца. Так как и текст и ширина ячеек раны, то получалось что высота объединенной ячейки устанавливалась правильно и текст соответственно вмещался и был виден. Может такой вариант и вас устроит?
Изменено: gling - 15 Фев 2020 23:04:30
Копирование формул по столбцам с шагом
 
Здравствуйте. Clot, у вас странно разбросаны данные на разные листы, для чего это сделано не знаю, но если данные хранить на двух листах с названиями План и Факт, было бы гораздо проще собрать из них данные в сводную таблицу.
Изменено: gling - 13 Фев 2020 15:33:13
Накопленная сумма при разных шагах
 
Тогда так, для значений не более 100 тыс
Код
=СУММПРОИЗВ(ПРОСМОТР((СТРОКА($A$1:$A$100000)-1);$F$5:$F$8;$G$5:$G$8)*((СТРОКА($A$1:$A$100000)-1)<G12))
Изменено: gling - 12 Фев 2020 21:59:23
[ Закрыто] Среднее значение. Внимание ТРУДНО, Среднее значение с несколькими условиями
 
Вы невнимательно читаете сообщения которые вам пишут. Проигнорировали сообщение про Правила, если не проигнорировали, то Правила прочитали невнимательно. Проигнорировали замечание модератора. Прочитали сообщение #11, но ищите не среднее значение жителей, а среднее значение средних значений. Вам давно ответили на ваш вопрос и здесь и на другом форуме
[ Закрыто] Среднее значение. Внимание ТРУДНО, Среднее значение с несколькими условиями
 
Цитата
sergkochet написал:
1. расчитать среднее число жителей в городах; (отдельно от остальных)?
2. среднее число жителей в хуторах, селах, поселках (соответсвтенно отдельно от города)?
Ответ:
1. Необходимо посчитать количество всех жителей в городах (отдельно от остальных) и разделить это число на количество городов (отдельно от остальных)
2. Необходимо посчитать количество всех жителей в хуторах, селах, поселках (соответсвтенно отдельно от города) и разделить это число на количество хуторов, сел, поселков (соответсвтенно отдельно от города)
Про заброшенные поселения принимайте решение сами, считать их за поселение или нет. Считать прибавляете 1 к общему количествку поселений, нет не прибавляете ничего.
Что здесь ТРУДНОГО?
Если вы знаете про другую логику определения среднего значения, дайте ссылочку, я поучусь.
Изменено: gling - 11 Фев 2020 23:59:45
Накопленная сумма при разных шагах
 
Ещё вариант, проверьте.
Код
=СУММПРОИЗВ(ПРОСМОТР((СТРОКА($A$1:$A$100)-1)*100;$F$5:$F$8;$G$5:$G$8)*(((СТРОКА($A$1:$A$100)-1)*100)<G11))*100
Цитата
100*17+3*16 = 1748
Странный какой то расчет. Шаг 100, а 3*16. 3 это же не 3 шага, это 3 из начала следующего шага. Так как полный шаг не пройден,3<100, то 3 принимаем за полный следующий шаг. Или что то не так?

Изменено: gling - 11 Фев 2020 19:00:53
Подсчитать количество строк отвечающих заданному набору условий
 
Попробуйте так
Код
=СУММПРОИЗВ(СЧЁТЕСЛИМН($H$2:$H$10;O3;$E$2:$E$10;$N$2:$N$4)+СЧЁТЕСЛИМН($I$2:$I$10;O3;$E$2:$E$10;$N$2:$N$4)) 

Вариант для названия темы: Подсчёт строк удовлетворяющих условиям из диапазонов

Изменено: gling - 11 Фев 2020 17:09:07
Подсчитать количество строк отвечающих заданному набору условий
 
Вы разберитесь,что вы хотите, потом объясните здесь. Покажите максимально ужасный вариант из нескольких строк и покажите сколько это будет при подсчёте на пальцах. А мы попытаемся придумать формулу которая будет считать на большом объёме строк. Вы в примере написали две формулы, СУМЕСЛИМН и СЧЕТЕСЛИМН, сумесли не верная, что хотите считать не понятно, меня это запутало. Если напишите ещё формулы не факт что напишите правильно, по этому объясните лучше на словах. Например нужно посчитать/просуммировать при условии чтобы в столце1=?; столбце2=?; столбце 3;4;или 5=? как то так, но попонятнее.
Подсчитать количество строк отвечающих заданному набору условий
 
Цитата
Kulibinslovoru написал:
Одно условие из двух похожих диапазонов в СЧЁТЕСЛИМН
=СЧЁТЕСЛИМН(....;I:I;O2)+СЧЁТЕСЛИМН(....;H:H;O2)
Как найти значение из таблицы на пересечении строки и столбца?, почему формула ИНДЕКС+ПОИСКПОЗ дает значение ССЫЛКА?
 
У вас в формула несколько ошибок.
1. ИНДЕКС(массив, номер_строки, [номер_столбца]) Второй аргумент функции строка, а вы ищите столбец на другом листе, третий аргумент столбец, вы ищите строку и находите =43, 43 это больше чем 24 часа, следовательно это за пределами диапазона A20:Z386, Z это 26 столбец на листе. Отсюда и ошибка ССЫЛКА.
2. У вас не закреплены диапазоны, поэтому при протягивании формулы всё передвигается. Необходимо закрепить диапазоны.
P.S. А что такое Кхм.. Кхм.., это вместо приветствия или это переводится как Здравствуйте, с какого то языка?
Изменено: gling - 11 Фев 2020 16:01:15
Оставить один столбец в разных листах.
 
Выделяете все листы так: мышкой на ярлык первого листа--зажимаете Shift и тыкает курсором в ярлык последнего листа. Удаляете не нужные столбцы на одном листе они удалятся на всех выделенных. Штучное выделение группы листов через Ctrl.
Изменено: gling - 11 Фев 2020 14:41:55
КОНМЕСЯЦА не считает последний день
 
Здравствуйте. Функция КОНМЕСЯЦА() выдаёт дату на 00 часов,если есть регистрация после ноля часов то ваша формула эту регистрацию не посчитает. Можете использовать предложенные формулы или сводную таблицу без формул.
Добавление определенного количества граф (столбцов) в пределах одной таблицы
 
Вариант в файле. Но используя именованный диапазон "шаблон" с рабочего лист, будут копироваться заполненные данные за январь в другие места. Лучше создать чистый шаблон без данных на отдельном листе и скрыть этот лист чтобы он не мешал.
Найти максимальное значение цифро-символьного кода в отфильтрованном диапазоне
 
Цитата
cuprum написал:
формулой, и без дополнительных столбцов.
У меня не получилось.
Расчет полученного ущерба по нескольким условиям
 
Здравствуйте.
Не знаю что хотите посчитать этой формулой, лучше бы описали словами все условия. В формуле есть невыполнимое условие, для чего его вставили, не понятно.
Код
ЕСЛИ([@[Состояние
ремонта]]="Восст., оплатил";ЕСЛИ([@[Состояние
ремонта]]="Восст., опл., осаго";

Возможно пропущено чтото при  выполнении [@[Состояние ремонта]]="Восст., оплатил"

Найти максимальное значение цифро-символьного кода в отфильтрованном диапазоне
 
Здравствуйте.
Как понять
Цитата
cuprum написал:
максимальное значение цифро-символьного кода.
Это максимальное количество символов или максимальное число после точки? Для максимального числа после точки можно использовать формулу массива
Код
=МАКС(ЕСЛИОШИБКА(--ПСТР(A2:A14;7;9);))

Если нужен весь код то так

Код
="02-05."&МАКС(ЕСЛИОШИБКА(--ПСТР(A2:A14;7;9);))
Для количества символов, тоже формула массива
Код
=МАКС(ДЛСТР(A2:A14))
Как изменить значение_1 на значение_2 везде где встречается
 
Здравствуйте. Если правильно понял, то такое можно сделать формулой
Код
=ВПР(D2;A:B;2;0)
не заменить конечно, а прописать рядом в отдельный столбец.
Ошибка при воспроизведении записанного макрорекордером создания сводной таблицы
 
Здравствуйте.
Попробуйте так
Код
    ActiveWorkbook.PivotCaches.Create(SourceType:=xlDatabase, SourceData:= _
    "Sheet1!R1C1:R18C100").CreatePivotTable TableDestination _
    :=Sheets("RSD OVERDUE REPORT").Cells(1, 1), TableName:="PivotTable1"
Выровнять таблицу по высоте средствами VBA
 
Цитата
DopplerEffect написал:
пустоты в строках между текстом и границами.
Попробуйте убрать отступы сверху и снизу абзаца так
Код
objDoc.Tables(1).AutoFitBehavior (2)
objDoc.Tables(1).Range.Paragraphs.SpaceBefore = 0
objDoc.Tables(1).Range.Paragraphs.SpaceAfter = 0
Задать область печати в зависимости от значения в конкретной ячейке.
 
Не понятно что вы хотите. Установите автофильтр по столбцу AF исключив нули и ошибки и печатайте без всякого кода.
Подсчет количество ячеек в графике с первого числа по сегодня
 
Здравствуйте. Может быть так?
Код
=СЧЁТЕСЛИМН(B4:AF4;"<="&F2;B5:AF5;"=0")
Задать область печати в зависимости от значения в конкретной ячейке.
 
Цитата
Сергей Эм написал:
Спасибо, но это не то.
Цитата
Сергей Эм написал:
в область печати не попадал диапазон A1:J4
А вы смотри вложенный в сообщение #4 файл?
Подсчитать количество уникальных значений в ячейках при применении одного или нескольких фильтров.
 
Вариант. Только нули считать не будет, при применении фильтра в скрытых ячейках, в формулах, данные обнуляются.
Остановка расчета сумм при достижении результата
 
Здравствуйте. Что-то сделал, но не знаю то-ли
Задать область печати в зависимости от значения в конкретной ячейке.
 
Цитата
Сергей Эм написал:
Можно ли изменить код с учетом фильтра?
А может менять область печати с учетом фильтра =1?
Изменено: gling - 27 Янв 2020 20:13:12
Найти первое и последнее значение соответствующее условию, Найти первое и последнее значение соответствующее условию
 
Здравствуйте.
Может так подойдет.
Код
=ИНДЕКС($D11:$N11;СУММПРОИЗВ(ПОИСКПОЗ(1;--($D11:$N11>$O$10);)))
=ИНДЕКС($D11:$N11;СУММПРОИЗВ(МАКС(($D11:$N11>$O$10)*СТОЛБЕЦ($D$11:$N$11)-3)))
Страницы: 1 2 3 4 5 6 7 8 9 10 11 ... 120 След.
Наверх