Поиск  Пользователи  Правила 
Закрыть
Логин:
Пароль:
Забыли свой пароль?
Регистрация
Войти
 
Выбрать дату в календареВыбрать дату в календаре

Страницы: 1 2 3 4 5 6 7 8 9 10 11 ... 123 След.
Выпадающий список по условию.
 
Здравствуйте.
Подправил формулу, чтобы не ругалась.
Код
=СМЕЩ('1'!$A$2;;ПОИСКПОЗ('2'!$A2;'1'!$A$1:$C$1;)-1;СЧЁТЗ(ИНДЕКС('1'!$A$2:$C$8;;ПОИСКПОЗ('2'!$A2;'1'!$A$1:$C$1;))))
Удаление текста между "(" и ")", как удалить любое значение между скобками
 
А такой вариант не подойдёт?
Ctrl+H -- Найти:  (*) -- Заменить на: ничего не пишем -- Заменить все
Выбор оператора для решения задачи (Поиск, Индекс, Неравенство), Работа с массивом
 
Для точного совпадения формула, какой выдаст результат столько совпадений.
Код
=СЧЁТЕСЛИ(H:H;D2)
Выбор оператора для решения задачи (Поиск, Индекс, Неравенство), Работа с массивом
 
У вас на картинке адреса с индексами и формулой вы ищите точное совпадение. Вашу формулу может заменить СЧЁТЕСЛИ().
В файле в столбце H нет индексов и формула СЧЁТЕСЛИ() без дополнительных преобразований данных не справится.
Так что вы хотите, определить наличие адреса в столбце H по неточному совпадению, так как адрес в столбце D с индексом? Или же вы хотите определить точное совпадение адреса в столбце H?
Изменено: gling - 4 Авг 2020 23:26:25
Не работает макрос для создания выпадающего списка, Макрос не работает при копировании на другие листы в файле
 
Цитата
Energo73 написал:
Когда это повторил для другого, то вообще непонятное началось
Здравствуйте.
Цитата
Energo73 написал:
Вставил этот код в лист23
Зачем вставлять? Копируете лист с работающими списками ПКМ по ярлычку - Переместить или скопировать - Создать копию =галка - Показываете куда копировать - ОК. Переименовываете этот новый лист, в нём всё должно работать так-же как и в оригинале. Стирайте не нужные данные и вводите новые.
Как в сводной таблице сделать, чтобы столбец не учитывался при отборе?
 
Кросс
Раскрытие диапазона при фильтрации
 
Можно и без макроса. Раз вы всё равно объединяете ячейки вручную, то объединяйте их таким образом:
1. Первоначально в таблице все ячейки не объединены и вы в столбце В в ячейках которые будите объединять пишите нужное название объекта, например "Футбольное поле"
2. Объединяете ячейки столбца D и в объединенной ячейке пишите формулу (это вы делаете при формировании таблицы).
3. Копируете эту объединенную ячейку и вставляете "Специальной вставкой" - Форматы - ОК в ячейку В2.
После этого фильтроваться должно так как вам и нужно.
Сравнение значения со списком и подставление значения из списка, работа со списками
 
И вам здравствовать, уважаемый Maxim -!
Попробуйте ВПР()
Формула для нахождения суммы цифр в столбце до пустой строки.
 
Здравствуйте.
Ещё вариант, тоже формула массива.
Код
=ЕСЛИ(ЕТЕКСТ(B1);СУММ(ИНДЕКС($C$1:C1;ПОИСКПОЗ("яя";$A$1:A1)):ИНДЕКС(C1:C190;ПОИСКПОЗ(;ДЛСТР(B1:B190);)));"")
Раскрытие диапазона при фильтрации
 
Здравствуйте.
Вариант в файле.
Изменение номера строки в ссылках в значениях нескольких ячеек
 
Цитата
oleg9911 написал:
как это редактировать?
ПКМ по кнопкам - Формат объекта - Элемент управления
Изменение номера строки в ссылках в значениях нескольких ячеек
 
Здравствуйте.
Вариант без макросов.
Изменено: gling - 2 Авг 2020 10:28:01 (Заменил файл. Счётчик начинается с 1.)
как формуле ЕСЛИ И работать в двух и более диапазонах, ЕСЛИ И в диапазоне ?
 
И Вам тоже здравствовать.
Попробуйте так
Код
=ЕСЛИ(СЧЁТЕСЛИМН(Общ.!$E:$E;ПСТР(B$1;ПОИСК("№";B$1)+1;3);Общ.!$F:$F;ПСТР($A3;ПОИСК(".";$A3)+2;99));"+";"-")
Создание сводной таблицы по графикам платежей
 
9 в степени 9, очень большое число.
Создание сводной таблицы по графикам платежей
 
Похоже вчера я чуток перегрелся. Попробуйте так
Код
=ИНДЕКС(Лист2!$B$10:$B$23;ПОИСКПОЗ(9^9;Лист2!$G$10:$G$23;1)+1)
Создание сводной таблицы по графикам платежей
 
Здравствуйте. Попробуйте формулу, может подойдет.
Код
=ИНДЕКС(Лист2!$B$10:$B$23;ПОИСКПОЗ(ПРОСМОТР(9^9;Лист2!$G$10:$G$23;Лист2!$G$10:$G$23);Лист2!$B$10:$B$23;1)+1)
Дополнить формулу чтоб значение вписывалось в диапазон от 1-22.
 
Цитата
Ігор Гончаренко написал:
повалят решения
Первый пошел
Код
=ЕСЛИ(ОСТАТ(I2;22);ОСТАТ(I2;22);1)
или
=ЕСЛИ(ОСТАТ(СУММ((ДЛСТР(C2)-ДЛСТР(ПОДСТАВИТЬ(C2;{1;2;3;4;5;6;7;8;9};)))*{1;2;3;4;5;6;7;8;9});22);ОСТАТ(СУММ((ДЛСТР(C2)-ДЛСТР(ПОДСТАВИТЬ(C2;{1;2;3;4;5;6;7;8;9};)))*{1;2;3;4;5;6;7;8;9});22);1)

Но при сумме чисел =22 и 23; 44 и 45; 66 и 67 результат будет =1.

Добавить на гистограмму сбоку от столбцов значения в процентах
 
Здравствуйте Андрей!
На работе 2007 и заменить на более новую запрещают безопасники, так что 2010 это даже слишком для работы, не всякие функции принимает рабочий комп сделанное в 2010. По этому и домашний не меняю на более новый. Не хочу потом переделывать. А здесь у большинства уже продвинутые версии. Чтож пока с 2010 можно что то сделать буду пользоваться, возрастет потребность, поставлю новее.
При открытии .csv меняются форматы данных. Как отключить?
 
И Вам здравствовать i_resh.
С форматом csv. не работаю, но думаю что если предварительно на листе задать формат ячеек текстовый, а туда скопировать данные и csv.  как значения, то изменяться не должно. Но это нужно пробовать.
Добавить на гистограмму сбоку от столбцов значения в процентах
 
У меня Excel 2010  ни один из вариантов нормально не открылся, по этому не понял что и как сделано. Возможно у меня такой же вариант как и у других. Сделал на базе варианта Андрей Лящук, с вспомогательной вертикальной осью. Если нужно то её отображение можно скрыть настройками. На мой взгляд любую диаграмму приходится "доводить до ума" руками, так как после изменения данных может в диаграмме измениться цвет столбца или предельное значение ... и по этому приходится подправлять.
У меня почему то вместо %  написано [ДИАПАЗОН ЯЧЕЕК]  а куда это ссылается не понятно.
Изменено: gling - 13 Июн 2020 09:27:06
Посчитать количество часов за день по сумме смен
 
Здравствуйте.
Так надо?
Код
=СУММПРОИЗВ(СУММЕСЛИ($F$2:$F$4;B2:B3;$G$2:$G$4))
Округление чисел в большую сторону, если после запятой >0.2
 
Код
=ЦЕЛОЕ(B3)+ПРОСМОТР(ОСТАТ(B3;1);{0;0,3};{0;1}) 

Или если по названию то

Код
=ЦЕЛОЕ(B3)+ПРОСМОТР(ОСТАТ(B3;1);{0;0,201};{0;1}) 
Изменено: gling - 12 Июн 2020 17:47:02
Написать формулу с использованием "ЕСЛИОШИБКА", "ДВССЫЛ", "АДРЕС", "СТОЛБЕЦ", "СТРОКА".
 
Код
=ЕСЛИОШИБКА(ДВССЫЛ(АДРЕС(СТРОКА(A1);СТОЛБЕЦ(A1)));0)
Что вычисляет формула НАИБОЛЬШИЙ(СЧЁТЕСЛИ($N$12:$N$29;{1;2;3;4;5;6;7;8;9});1)
 
Цитата
Radist09 написал:
Могли бы прокоментировать ?
Цитата
Ігор Гончаренко написал:
вас на гугле забанили или на Майкрософте что вы не можете этого почитать

Radist09, разберитесь со вторым аргументом функции НАИБОЛЬШИЙ и всё поймёте.
Получить название столбца с максимальным значением, Вывод текстового значения по заданному критерию (максимум)
 
Здравствуйте. Попробуйте так
Код
=ИНДЕКС(Таблица4[[#Заголовки];[январь]:[июнь]];ПОИСКПОЗ(МАКС(Таблица4[@[январь]:[июнь]]);Таблица4[@[январь]:[июнь]];))
или
=ИНДЕКС($C$3:$H$3;ПОИСКПОЗ(МАКС(C4:H4);C4:H4;))
Изменено: gling - 9 Июн 2020 18:00:14
Задать несколько условий = если (), если в условиях есть параметр "в n раз"
 
Здравствуйте. Может так? В файле Зеленый, здесь Синий. Цвет пишите какой хотите.
Код
=ПРОСМОТР(B2*7/C2;{0;2;3};{"Синий";"Жёлтый";"Красный"})
Изменено: gling - 9 Июн 2020 11:39:04
VBA обращение к листу
 
Цитата
agregator написал:
Sheets("Инструктаж").Range(Cells(2, 2), Cells(2, 4)).Value
Попробуйте так
Код
Sheets("Инструктаж").Range(Sheets("Инструктаж").Cells(2, 2), Sheets("Инструктаж").Cells(2, 4)).Value

Но если в момент работы макроса будет активным лист "Инструктаж", то первая строка тоже не сработает.

Изменено: gling - 9 Июн 2020 11:23:23
Не считать итоги, если в ячейке текст
 
Ещё вариант
Код
=СУММ(ЕСЛИ(СЧЁТЗ(H4:H8)-СЧЁТ(H4:H8);"";H4:H8))
Как посчитать количество Да за указанный период времени
 
БМВ, Спасибо, а я то этот прикол и не заметил))) Они же почти одинаково пишутся, вот и оПшиПся.
Как посчитать количество Да за указанный период времени
 
Цитата
Роман написал:
Мне нужно произвести подсчёт Да в одном столбце,
БМВ, я исходил из этого. Изначально не понятно что хочет автор. То-ли в одном столбце то-ли все Да за период.
Страницы: 1 2 3 4 5 6 7 8 9 10 11 ... 123 След.
Наверх