Поиск  Пользователи  Правила 
Закрыть
Логин:
Пароль:
Забыли свой пароль?
Регистрация
Войти
 
Выбрать дату в календареВыбрать дату в календаре

Страницы: 1 2 3 4 5 6 7 8 9 10 11 ... 122 След.
Не считать итоги, если в ячейке текст
 
Ещё вариант
Код
=СУММ(ЕСЛИ(СЧЁТЗ(H4:H8)-СЧЁТ(H4:H8);"";H4:H8))
Как посчитать количество Да за указанный период времени
 
БМВ, Спасибо, а я то этот прикол и не заметил))) Они же почти одинаково пишутся, вот и оПшиПся.
Как посчитать количество Да за указанный период времени
 
Цитата
Роман написал:
Мне нужно произвести подсчёт Да в одном столбце,
БМВ, я исходил из этого. Изначально не понятно что хочет автор. То-ли в одном столбце то-ли все Да за период.
Автоматический сдвиг ячеек в зависимости от содержимого динамического массива
 
Здравствуйте. Фильтр в столбце J по 1 и на печать.
Как посчитать количество Да за указанный период времени
 
Еще вариант но с СУММЕСЛИМН(), вместо дат можно указать ячейки куда прописывать даты.
Код
=СЧЁТЕСЛИМН(A:A;"Да";H:H;">=1.01.2020";H:H;"<=31.01.2020")
Как создать многоуровневый выпадающий список
 
И надо показать как это
Цитата
Nikolaevich127 написал:
реализован через отдельные ячейки
Отдельные ячейки с выпадающими списками или стихийно расположенные, чтобы выяснить это дополнительный уровень формирования ещё одного выпадающего списка или изменение имеющегося.
Текст по столбцам с переносом строки внутри ячейки
 
Здравствуйте. Для вашего варианта на шаге 2 поставьте галки на =Знак табуляции, запятая, другой, -- в окно другой тыкните курсором и нажмите одновременно Ctrl+j. На шаге 3 пустой столбец можно пропустить установив ему Формат данных столбца= "Пропустить столбец". Покажите ячейку куда вставлять разбитые данные и жмите Готово.
Предложение по названию: Текст по столбцам с переносом строки внутри ячейки.
Изменено: gling - 4 Июн 2020 18:28:12
Убрать пустые ячейки в связанном выпадающем списке
 
Удалил, как посчитал лишние, формулы в диспетчере имен, чуть изменил формулы на листе "Tab", теперь при ошибке выдаёт пробел " ", теперь этот пробел можно искать как конец/отсутствие данных, = последняя ячейка с данными выше пробела, это о чем и писал БМВ, только он предложил подчеркивание, можно заменить на подчеркивание, тогда и в именованно формуле "Диап" тоже надо будет искать подчеркивание.
Вариант решения в файле. Формула в диспетчере правда длинновата получилась, ну да ладно её там не видно, надеюсь тормозить не будет.
Проверка содержимого диапазона ячеек на определенные значения
 
А так не подойдёт?
Код
=ЕСЛИ(СУММ(A1:K10);"есть числовые данные";"числовых данных нет")
Смена столбца по наличию значения
 
Здравствуйте. Вариант в файле
Создание списка товаров из повторяющихся наименований товара.
 
Здравствуйте. Сводная таблица в помощь, такие запросы решает на раз.
Встроить в формирование выпадающеео списка индекс и поискпоз в двссыл
 
Цитата
Lelya7 написал:
Возможно ли это реализовать
А почему нет, если и месяцы будут плясать то столбец() тоже нужно поменять на поискпоз( ) в А2:N2
Код
=ИНДЕКС(ДВССЫЛ("'"&$A$2&"'!A1:N300");ПОИСКПОЗ($A6;ДВССЫЛ("'"&$A$2&"'!A1:A300"););СТОЛБЕЦ())
Удалить дубликаты строк
 
Цитата
DJMC написал:
или все верно сделал
Всё правильно. Есть ещё более простой способ с помощью Условного форматирования Выделить интересующий диапазон: Вкладка Главная--Стили--Условное форматирование--Правила выделения ячеек--Повторяющиеся значения. Все повторяющиеся выделятся цветом. Можете проверить все ли они по формуле посчитались, с числом >1. Для удаления автофильтром -- "Фильтр по цвету" по столбцу А выделить цвет и удалить эти строки.
Изменено: gling - 3 Июн 2020 10:11:19
Удалить дубликаты строк
 
В соседний столбец пишите формулу
Код
=СЧЁТЕСЛИ(A$1:A$1000;A1)
и тяните её вниз на 1000 строк, ставите автофильтр по этому столбцу, выделяете все >1 и удаляете эти строки. Останутся только те которые были без повторов. Если хотите удалит только вторые повторяющиеся, а оставить по одному не повторяющемуся значению, то нужна немного другая формула
Код
=СЧЁТЕСЛИ(A$1:A1;A1)
так же тянуть вниз и удалить >1.
Изменено: gling - 3 Июн 2020 02:10:29
Преобразовать СЛОЖНУЮ вертикальную таблицу в горизонтальный формат, Преобразовать СЛОЖНУЮ вертикальную таблицу в горизонтальный формат
 
Вариант с дополнительной сводной таблицей Подсмотрел здесь
[ Закрыто] Перевод формулы в макрос
 
Здравствуйте. Включаете макрорекордер - активируете ячейку с этой формулой - тыкаете курсором в строку формул - Интер. Всё макрос с формулой готов. Но что то меня берет сомнение, будет он работать в умных таблицах. Формулы с такими ссылками мне не нравятся, а вы экспериментируйте, может у вас всё получится.
Как привязать вычисления сводной таблицы к дополнительны данным при перемещении таблицы?
 
Цитата
Евгения Некрасова написал:
Что мне с этим делать?
По возможности делать расчеты внутри сводной. Вкладка работа со сводными таблицами - Параметры - Поля, элементы и наборы - Вычисляемое поле.
К сводной таблице привязать внешнее поле не просто, на определенную ячейку сводной таблицы привязываться нельзя, так как таблица динамичная, изменяется в зависимости от фильтров и других данных. Если хотите привязать к данным в сводной таблицы, то необходимо их выявить в какой строке они в данный момент находятся. Но для того чтобы попробовать вам помочь, необходимо видеть данные и желаемый результат, как вы его видите.
Не работают кнопки на быстрой панели при работе с макросом
 
Цитата
olga1305 написал:
команды где найти - просто мышью буду открывать
Здравствуйте. Скопировал макросы в файл. Этот файл нужно будет открывать вместе с файлом с которыми хотите работать. Чтобы найти команды нажмите Alt+F8. Выберите книгу Макросы - выберите команду выполнить.
Если в Интернете почитаете про Личную книгу макросов Excel, скопируете туда эти макросы, то возможно и работу кнопок на вашей панели сможете восстановить. Информация в помощь.
Поиск слова без окончания
 
Здравствуйте. Был бы пример можно бы эксперементировать. Из текста создаем конструкцию, добавляем пробелы в начале и в конце " "&"ячейка с текстом"&" " в этой сцепке ищем " СЛОВО ", впереди и сзади пробелы.
Нахождение минимального значения в диапазоне между первым и максимальным значением в столбце
 
В Вашей формуле из K96, используется функция ВССЫЛ, по этому Excel не понимает что делать.
Код
=ИНДЕКС(B5:ДВССЫЛ(L96);ПОИСКПОЗ(МИН(ABS((СУММ(I96))-G5:ВССЫЛ(L97)));ABS((СУММ(I96))-G5:ДВССЫЛ(L97));0)) 

Но зачем СУММ если формула работает и без неё

Код
={ИНДЕКС(B5:ДВССЫЛ(L96);ПОИСКПОЗ(МИН(ABS(I96-G5:ДВССЫЛ(L97)));ABS(I96-G5:ДВССЫЛ(L97));0))}
Изменено: gling - 28 Май 2020 01:56:43
Динамический адрес таблицы в выпадающем списке
 
Здравствуйте. Может так надо?
Код
=ИНДЕКС((ПП;ФЛ);;1;ПОИСКПОЗ(Лист1!$H$7;{"ПП";"ФЛ"};0))
Удаление повторяющихся значений с условием, Нужно удалить повторяющиеся товары из прайса, оставив товар с наменьшим значением цены
 
Кросс
Вставка данных в другую ячейку
 
Можно сделать сводную таблицу.
Определение количества при частичном совпадении номенклатур.
 
Здравтсвуйте. Может так надо?
Код
=ВПР("*"&E2&"*";$A$1:$C$42;3;0)
Поиск значения с двумя условиями: из выпадающего списка и фильтра, сложный впр с выпадающим списком
 
Цитата
Екатерина Шубина написал:
сложный впр с выпадающим списком
Здравствуйте.
Не удачно выбрали функцию, вместо ВПР() используйте СУММЕСЛИМН().
Код
=СУММЕСЛИМН('1С'!$C$2:$C$63;'1С'!$A$2:$A$63;B2;'1С'!$B$2:$B$63;C2)
Можно конечно и с ВПР(), но с ней будет немного сложнее.
Код
=ВПР(C2;СМЕЩ('1С'!$A$1;ПОИСКПОЗ(расчет!B2;'1С'!$A:$A;0)-1;1;СЧЁТЕСЛИ('1С'!$A:$A;расчет!B2);2);2;)

В файле пробы, может пригодятся.

Ускорить код по применению параметров страницы ко всем листам книги
 
Здравствуйте. А попробуйте не перебором, а выделить все нужные листы и задать им параметры. Возможно так не все параметры можно задать, а может и получится. А возможно в связи с изменением параметров, что то происходит на листах, пересчитываются какие нибудь формулы. Попробуйте выключить ненужные процедуры на время выполнения этого макроса.
Изменено: gling - 12 Май 2020 23:55:51
Цветная заливка в зависимости от значений в каждой строке
 
olga1803, Вариант в файле из сообщения #6 не устраивает?
Цитата
а одним движением...
Копировать диапазон C4:G4, выделить нужный диапазон, спец. вставкой вставить форматы. Это не одно, а несколько движений.
Изменено: gling - 11 Май 2020 23:20:57
Цветная заливка в зависимости от значений в каждой строке
 
Здравствуйте. А сколько будет столбцов? Если только 5, то можно создать 5 условий.
Вычислить порядковый номер выходного дня в месяце, второе Вс, первое Вс...
 
Удалил сообщение.
Подожду окончания дискуссии.
Изменено: gling - 10 Май 2020 23:04:10
В прайс-листе код, название,цена нужно заменить на выгруженные со склада, в прайс лист
 
Цитата
Poxmetolog написал:
из файла 2222
А это где такой файл найти?
Страницы: 1 2 3 4 5 6 7 8 9 10 11 ... 122 След.
Наверх