Поиск  Пользователи  Правила 
Закрыть
Логин:
Пароль:
Забыли свой пароль?
Регистрация
Войти
 
Выбрать дату в календареВыбрать дату в календаре

Страницы: 1 2 3 4 5 6 7 8 9 10 11 ... 118 След.
Работа со сводной таблицей. Выделение строк цветом.
 
Цитата
fareng8 написал:
Цветов не сотни, их 4.
Для пары категорий пропишите ещё 2 условия с другими цветами в УФ. Для сотни не понятно, а в какие цвета вы их хотите красить? 50 одним и 50 другим?
Цитата
fareng8 написал:
И их статус каждые пару недель необходимо менять.
Каким образом вы меняете статус? Можно в первоначальной таблице создать доп столбец где будет прописываться статус, а по статусу будет определяться цвет закраски.
Работа со сводной таблицей. Выделение строк цветом.
 
Вариант.
Сбор данных с разных листов из определенных ячеек
 
Цитата
anddrei55 написал:
необходимо чтоб артикул брался с последней строчки
Проверьте такой вариант.
Сбор данных с разных листов из определенных ячеек
 
Не знаю правильно ли, но результат соответствует Вашему примеру.
Изменено: gling - 13 Июл 2019 15:38:06
Таблица с выбором данных с разных листов
 
Дубль темы создавать было не обязательно, можно было в теме попросить модератора переименовать и там же вложить файл. Теперь модератору придется или объединять или удалить одну тему.
Вариант решения в файле. Выбирайте склад в ячейках А1 и С1, но если на листах наименования товара будет повторяться, то формулы нужно будет написать другие.
Изменено: gling - 12 Июл 2019 18:13:56
VBA выпадает ошибка при методе find
 
Цитата
firework42 написал: там 3 листа и длиный код,
На каждом листе 10-20 строк и столбцов?
Создайте такой файл и попробуйте запустить макрос, если выдаст ошибку выкладывайте. Для уменьшения объёма можно удалить все форматы, ведь для макроса нужны только данные.
Посчитать какого материала и сколько в таблице
 
Цитата
Mulder написал:
заполнив ячейки, выделенные зелёным.
Лучше бы показали как требуют правила
Цитата
что есть сейчас и того, что хотелось бы на выходе.
У меня Excel 2010, зеленым выделена только шапка таблицы, а где у вас зеленый у меня отображает серым. В общем лучше на цвета не ссылаться, лучше указывать диапазон ячеек. Это на будущее.  
В файле еще вариант формулами, без сводной таблицы.
Посчитать какого материала и сколько в таблице
 
Активируйте любую ячейку сводной таблицы -- вкладка "Работа со сводными таблицами" -- "Конструктор" -- "Макет отчета" -- "Показать в табличной форме"
Посчитать какого материала и сколько в таблице
 
Здравствуйте. Попробуйте сводную таблицу.
Привязка формулы к значениям выпадающего списка
 
Цитата
Евгений И. написал:
как сослаться на Значения Выпадающего списка в формуле..
Может так?
Код
=СУММЕСЛИМН(ИНДЕКС(Ассортимент!$G$2:$L$9;;ПОИСКПОЗ(База!$G$1;Ассортимент!$G$1:$L$1;0));Ассортимент!$B$2:$B$9;База!B2;Ассортимент!$A$2:$A$9;База!A2;Ассортимент!$L$2:$L$9;"1";Ассортимент!$F$2:$F$9;">="&$H$1;Ассортимент!$F$2:$F$9;"<="&$I$1
)
Работа с датой в excel, Работа с датой в excel
 
Цитата
Ігор Гончаренко написал:
раньше)
У меня позже, но правильнее))
Нужно от даты  23 столбца
Изменено: gling - 4 Июл 2019 14:47:29
Работа с датой в excel, Работа с датой в excel
 
Здравствуйте. В 23 и 24 столбец
Код
=ДАТАМЕС(RC[-1];1)
=РАБДЕНЬ(RC[-1];10)
Отбор данных из определенных ячеек с разных листов с распределением коэффициентов (одной формулой)
 
Цитата
Baad написал:
необходимо написать одну формулу,
Вариант в файле.
Код
=ЕСЛИОШИБКА(ИНДЕКС(Затраты!$D$4:$BP$8;ПОИСКПОЗ($A16;Затраты!$A$4:$A$8;);(ПОИСКПОЗ(F$6&", 2020";Затраты!$D$4:$BP$4;)+ПОИСКПОЗ($D16;{"Конденсат";"Нефть и конденсат";"Добыча Нефть"};)+1))*$C16*ЕСЛИОШИБКА(1/(1/СУММЕСЛИ(Index!$C$3:$C$16;$D16;ИНДЕКС(Index!$D$4:$AA$16;;ПОИСКПОЗ(F$6;Index!$D$2:$AA$2;))));1);"")
Изменено: gling - 4 Июл 2019 14:11:36
Десятичные знаки при использовании числа в тексте
 
Ну и славненько.
Изменено: gling - 30 Июн 2019 23:31:15
Десятичные знаки при использовании числа в тексте
 
Здравствуйте.
Попробуйте ТЕКСТ(B1;"0,00")
Сортировка по итоговой сумме платежей
 
Цитата
RMG написал:
это сообщение я не Вам
Понял, увидел.
Сортировка по итоговой сумме платежей
 
Не понял смысл сообщения #9. Что результат в файле не верный? Но ведь он совпадает с вашим примером.
Сортировка по итоговой сумме платежей
 
Так устроит? Столбец F скрыт группировкой, нажать (+) над столбцом G
Изменено: gling - 29 Июн 2019 10:16:34
Сортировка по итоговой сумме платежей
 
Цитата
RMG написал:
и чтобы разместились плательщики по убыванию общей суммы произведенных ими платежей.
Цитата
RMG написал:
Данные уже отсортированы по ИНН
Эти два условия не стыкуются. Если нужно не сортировка по ИНН, а группировка, тогда ваша хотелка понятна.
Какая должна быть сортировка по примеру?
ИНН   ГодоваяСумм
А         100
Б          50
В          150
Изменено: gling - 29 Июн 2019 09:52:23
Сумма по нескольким столбцам по одному критерию
 
Здравствуйте. Вариант
Код
=ЕСЛИ(СЧЁТЕСЛИ($A$3:A3;A3)=1;СУММПРОИЗВ(($B$3:$N$13)*($A$3:$A$13=A3));"")
Найти минимальную сумму для повторяющегося номера, присвоить значение
 
Цитата
IrinaVN написал:
без предварительной сортировки
Вариант
Код
=ЕСЛИ(И((СЧЁТЕСЛИ($B$2:$B$49;B2)-1)>0;СУММ(D2:G2)=0);"удалить из списка";"актуальные значения")
или так
=ЕСЛИ(И(СЧЁТЕСЛИ($B$2:$B$49;B2)>1;СУММ(D2:G2)=0);"удалить из списка";"актуальные значения")
Изменено: gling - 17 Июн 2019 00:41:47
Каталог с выпадающими списками
 
Покажите кусочек вашей базы данных, и вариант с выпадающими списками.
При слиянии с вордом дата "ломается", а график не меняется после повторного открытия файла Ворд
 
Цитата
БМВ написал:
Можно сколь угодно делать примеры
Согласен, и не факт что файл с ошибкой выдаст ошибку на моём компе. Но попробовать можно.
При слиянии с вордом дата "ломается", а график не меняется после повторного открытия файла Ворд
 
У Вас первый вопрос про дату, а второй про график? Или это один и тот же вопрос "Дата неправильно отображается в графике который вставлен из Exсel  в Word?
При слиянии с вордом дата "ломается", а график не меняется после повторного открытия файла Ворд
 
Цитата
pikabu написал:
"\@ "dd.MM.yyyy"
Может нужен пробел перед слешем?
При слиянии с вордом дата "ломается", а график не меняется после повторного открытия файла Ворд
 
Цитата
pikabu написал:
но ничего не меняется.
После изменения формата нужно обновить поле. Или попробуйте сохранить и открыть вновь, а может получится. Еще замечал, что при написании формата в Word, пробелы имеют значение, не правильно поставленный пробел или отсутствие его может повлиять на результат. А может это мне показалось.
Изменено: gling - 16 Июн 2019 19:17:20
При слиянии с вордом дата "ломается", а график не меняется после повторного открытия файла Ворд
 
А поискать?
Группировка данных под один шаблон
 
Вариант в файле, с использованием ИНДЕКС+ПОИСКПОЗ, два диапазона - две формулы.
Код
=ЕСЛИОШИБКА(ИНДЕКС(Лист1!$B:$D;ПОИСКПОЗ($A2;Лист1!$A:$A;);ПОИСКПОЗ(B$1;Лист1!$B$1:$D$1;));"")
=ЕСЛИОШИБКА(ИНДЕКС(Лист1!$H:$J;ПОИСКПОЗ($A2;Лист1!$G:$G;);ПОИСКПОЗ(G$1;Лист1!$H$1:$J$1;));"")
Как избавиться от пробелов, образующихся при выгрузке из 1С?
 
Цитата
kolyale написал:
Проблема с ВПР
Цитата
kolyale написал:
Как удалить НЕНУЖНЫЕ пробелы?
Задача в чём, удалить пробелы, заставить работать ВПР, а может нужно посчитать определенны данные из выгрузки 1С? Так и нужно было назвать тему соответственно, при чем здесь ВПР? Предполагаю, что название "Подсчет значений при не полном совпадении наименований" более подходит.
Можно и с ВПР
Код
=ВПР(A2&"*";'из 1С'!A:B;2;0)

Но в выгрузке есть одинаковые наименования, строки 4-6, при ВПР подтянутся только данные строки 4, а как должно быть, вам виднее.

Изменено: gling - 14 Июн 2019 23:29:30
Какой Макрос сможет это сделать!, настройка макроса
 
Цитата
veter9191 написал:
которые способны переработать вес в указанный спок.
На заказ не претендую, просто интересно как определяется тот, кто способен переработать? Хочу попробовать организовать это на формулах.
Изменено: gling - 12 Июн 2019 15:31:01
Страницы: 1 2 3 4 5 6 7 8 9 10 11 ... 118 След.
Наверх