Поиск  Пользователи  Правила 
Закрыть
Логин:
Пароль:
Забыли свой пароль?
Регистрация
Войти
 
Выбрать дату в календареВыбрать дату в календаре

Страницы: 1 2 3 4 5 6 7 8 9 10 11 ... 756 След.
Формула для проставления 0 перед набором цифр
 
Главный вопрос - а зачем?
Изменение файла xml макросом, Поменять некоторые данные в xml-файле
 
Цитата
doober написал:
Надо стать на строку 8 и посмотреть, есть ли такой атрибут ПрТовРаб.
- есть, но у меня тоже выпадает на этой строке: http://prntscr.com/ur0qko
Нужно внести изменения в модуль, что-бы "оглы" и "кызы" начинались со строчной буквы.
 
Вообще судя по коду Игорь там специально поработал чтоб в двойных фамилиях все части были прописными, ну и эти оглы/кызы попутно задело...
Нужно внести изменения в модуль, что-бы "оглы" и "кызы" начинались со строчной буквы.
 
Так ведь так и работает...
[ Закрыто] Изменение макроса
 
Да считать строки кода никто и не станет... Для этого есть индикатор :)
Где и на сколько нужно увеличивать количество листов - я не в курсе. Видел там книга создаётся с листами...
[ Закрыто] Изменение макроса
 
Ага, ответишь, а потом название темы придумывать... Нет уж, сами!
[ Закрыто] Нужно перевести время от и до в минуты всего
 
И поэтому главный вопрос - а зачем?
Макрос для переноса данных из одного Excel в другой Excel файл, Помогите пожайлуста прописать макрос для автоматизации процесса работы
 
Честно пытался помочь - я пас. Понял только что початок - это не про кукурузу :)
Не строится график после преобразования csv в xlsx, Не строится график после преобразования csv в xlsx
 
Цитата
cheiz написал:
Менять долго придётся
- долго нажать Ctrl+H?
А если записывать макрос - то в нём сразу и делать даты датами, числа числами (указывая правильный разделитель).
Изменено: Hugo - 28 сен 2020 20:59:21
Подстановка значения из столбца массива., Найти и подставить значение из столбца D (Список1) в столбец D при определенных условиях
 
Так ВПР же!
Код
=ВПР(C2;Список1!$A$1:$D$4;4;0
Изменено: Hugo - 28 сен 2020 18:57:17
Сравнение значений по целой части
 
Тогда по условиям задачи нужно округлять только вниз, есть такая функция
Код
=ОКРВНИЗ(A1;1)
Подтянуть данные в таблицу в зависимости от выбранного счета.
 
Я бы не использовал слово Target как имя функции. на всякий случай...
И ещё - не всегда UsedRange.Rows.Count будет совпадать с номером последней заполненной строки! Файл правда не смотрел, тут может оно и совпадает...
Необходимо настроить надгрузку данных из ячеек одного файла в ячейки другого файла эксель.
 
Если все файлы сделаны по шаблону - то достаточно открыть файл-ярлык, и заменить в его формулах листа [ИНВ-3.xlsx] на [текущийфайл.xlsx] любым способом.
Выставить столбцы друг под другом
 
Рискуете вылезти за ограничения, если в столбцах могут быть сотни строк.
Теряется десятичная часть при конкатенации (&) текста и ячейки, содержащей число
 
И кстати если когда захотите так же объединять текст с датами - решение аналогичное.
Сопоставить две таблицы из разных листов и отметить совпадения
 
Как по мне - так все лицевые счета похожи...
Как китайцы. :)
Изменено: Hugo - 24 сен 2020 17:11:10
VBA. Удаление строк, в которых непустая ячейка в столбце
 
Да уже и не важно.
Есть кстати ещё способ с ColumnDifferences, но там тоже вроде были ограничения по количеству.
VBA. Удаление строк, в которых непустая ячейка в столбце
 
Я сдуру замахнулся сразу на миллион :)
Код
Sub tttt()
    Dim i&, delra As Range
    For i = 1 To 1000000 Step 2
        If delra Is Nothing Then Set delra = Cells(i, 1) Else Set delra = Union(delra, Cells(i, 1))
        Application.StatusBar = delra.Cells.Count
        DoEvents: DoEvents
    Next
End Sub

Может конечно тормозило извлечение delra.Cells.Count... :)
Я собирался дождаться когда вывалится в ошибку.
Изменено: Hugo - 23 сен 2020 18:00:06
Сопоставление столбцов на наличие нечетких совпадений
 
Файл.
VBA. Удаление строк, в которых непустая ячейка в столбце
 
Т.е. если как заявлено в диапазоне 30 тысяч строк, и удалять нужно унионом каждую вторую (ну вдруг так карта легла) - то тот код нужно запускать на ночь :)
VBA. Удаление строк, в которых непустая ячейка в столбце
 
8700
...
8950
ну оочень медленно уже, но пока в ошибку не выпало
9020
нафиг. прекращаю, надоело :)
Изменено: Hugo - 23 сен 2020 17:25:08
VBA. Удаление строк, в которых непустая ячейка в столбце
 
Кстати вроде как у union есть ограничение по количеству несмежных, вот сижу тестю - 6960,6961,6962... медленно так набирает уже, когда до 8000 доберётся не знаю...
VBA. Удаление строк, в которых непустая ячейка в столбце
 
На stackoverflow почему-то метод с union признан самым медленным... Но это может потому что было 5 years, 3 months ago :)
VBA. Удаление строк, в которых непустая ячейка в столбце
 
Вот ещё нашлось по теме (но не вникал):
Excel VBA Performance - 1 million rows - Delete rows containing a value, in less than 1 min
https://stackoverflow.com/questions/30959315/excel-vba-performance-1-million-rows-delete-rows-containing-a-value-in-less
VBA. Удаление строк, в которых непустая ячейка в столбце
 
ZVI DelRows:
https://www.planetaexcel.ru/forum/index.php?PAGE_NAME=message&FID=8&TID=24531&TITLE_SEO=24531&MID=335928­#message335928
Изменено: Hugo - 23 сен 2020 15:43:54
VBA. Удаление строк, в которых непустая ячейка в столбце
 
Сортируете диапазон по М, удаляете всё скопом. Затем можно отсортировать назад, если важен изначальный порядок.
Именно так работает быстрый код удаления строк от ZVI, где-то тут на форуме он есть.
Ну а в этом нужно отключить обновление экрана и пересчёт - на 30000 должно хватить ускорения
Пробелы, с которыми не работают СЖПРОБЕЛЫ и Trim
 
В VBA можно писать vbtab
Пробелы, с которыми не работают СЖПРОБЕЛЫ и Trim
 
"Неразрывный". Код 160.
Хотя стоп, открыл файл...
Там TAB.
Изменено: Hugo - 23 сен 2020 12:40:21
Сопоставление столбцов на наличие нечетких совпадений
 
Ответ такой - дату так вообще не найдёте, только часть текста.
Если после даты всюду текст (и дата слева и в виде как в примере) - то правильно считает такая формула:
Код
=СУММПРОИЗВ((ТЕКСТ(A6;"ДД.ММ.ГГГГ")=ЛЕВСИМВ($I$6:$I$24;10))*($J$6:$J$24=B6))
Изменено: Hugo - 23 сен 2020 10:58:58
Сопоставление ячеек с частично совпадающей информацией
 
И это уже второй макрос!
Страницы: 1 2 3 4 5 6 7 8 9 10 11 ... 756 След.
Наверх