Поиск  Пользователи  Правила 
Закрыть
Логин:
Пароль:
Забыли свой пароль?
Регистрация
Войти
 
Выбрать дату в календареВыбрать дату в календаре

Страницы: 1 2 3 4 5 6 7 8 9 10 11 ... 746 След.
Поиск в одной строке нескольких столбцов по части текста
 
Ну тогда думаю удобнее так (тоже массивная!):
Код
=ПОДСТАВИТЬ(ВПР(B$2&"*";ТРАНСП($F3:$I3);1;);B$2&": ";"")

есть косяк если не найдёт например в B5, но и это можно доработать если напрягает.
скрин
Изменено: Hugo - 14 Июл 2020 20:51:00
Поиск в одной строке нескольких столбцов по части текста
 
Тогда никак, раз в названии написано ВПР - значит поиск только в одном столбце! В первом из указанной таблицы.
Поиск в одной строке нескольких столбцов по части текста
 
Сравните свой вариант с моим - увидите. Все!
Поиск в одной строке нескольких столбцов по части текста
 
Нужно указать все параметры!
Код
=ВПР(B2&"*";F3:I3;1;0)

Только как-то нелепо - зачем искать в одной строке, зачем 3 столбца...
Изменено: Hugo - 14 Июл 2020 18:41:00
Макрос перебора ячеек, Как задать переменную правильно
 
Можно начать с логики:
If ccel = "Да" Then - вот тогда и есть смысл ставить формулу и очищать диапазоны.
Ну а в другом случае - округлять и ставить формат.
И переменные тут вообще не нужны!
Изменено: Hugo - 13 Июл 2020 19:38:44
VBA. Поиск по частичному совпадению
 
Цикл в цикле с проверкой на частичное совпадение быстрым не будет в любом случае. Даже если бегать по массивам.
VBA. Поиск по частичному совпадению
 
А можно такую ВПР и ставить макросом, и затем заменять на значение.
Данные в ячейке в зависимости от другой ячейки
 
Чем не подходит банально ВПР()? Хотя описание расплывчато, но по примеру не вижу препятствий, только составить список где-то нужно, хотя можно и прямо в формуле и прописать, не такой уж он большой:
Код
=ВПР(C2;{"Очень медленно";20:"Медленно";40:"Средне";60:"Быстро";80:"Очень быстро";100};2;0)
Изменено: Hugo - 8 Июл 2020 20:24:58
Помогите с заменой ячеек
 
ВПР и спецкопипаст.
Как обойти преобразование данных при открытии CSV
 
Цитата
Vsevolod написал:
какая альтернатива, если нужна таблица?
- не помню точно какая, но у меня на работе девчонки что-то делали с таблицей из csv в альтернативной программе, их (спецпрограмм для csv) гугл пару тройку точно даёт.
P.S. кажется вот этой работали: https://csved.sjfrancke.nl/

Изменено: Hugo - 8 Июл 2020 18:37:29
Как обойти преобразование данных при открытии CSV
 
Или открывайте не в Экселе :)
Обращение к Workbooks.worksheets.range из другой книги
 
В первом же ответе и был ответ, и ведь сказали что понятно. Оказываете лукавите? :)
Обращение к Workbooks.worksheets.range из другой книги
 
Пишите без селекта, на кой он нужен?
Обращение к Workbooks.worksheets.range из другой книги
 
А чтоб сделать селект - нужно этот лист активировать! Но для работы с With никакяа активация и селекты не нужны, с чего Вы это взяли?
Функция ВПР ищет точное значение, но почему-то выдаёт разный результат.
 
Для начала - сделайте два столбца с окгруглёнными значениями и ищите по ним.
Установить макрос в Excel средствами VBA
 
Можно тот файл превратить в надстройку и подключить.
Посчитать даты по годам, кроме повторяющихся
 
И чем не угодило предложенное решение?
Код
=СУММПРОИЗВ(--(ГОД(даты!$A$2:$A$20)=A2))
Изменено: Hugo - 30 Июн 2020 13:43:54
Поиск в массиве по двум критериям и вывод нескольких текстовых значений из одной ячейки
 
Я думаю проще написать свою UDF. Но как развлечение это меня не привлекает...
Подстановка данных из одной таблицы в другую, путем сравнения по трем критериям., Поиск данных в двух таблицах по трем условиям
 
Я свой код выше тоже поправил.
Подстановка данных из одной таблицы в другую, путем сравнения по трем критериям., Поиск данных в двух таблицах по трем условиям
 
Я смотрю там водители по несколько дней в рейсе, и что заправка только один раз?
А если 2, то вроде как PQ не считает, проверьте.
Кстати, я там выше забыл ФИО проверить, сейчас подправлю... :)
Изменено: Hugo - 28 Июн 2020 19:53:19
Подстановка данных из одной таблицы в другую, путем сравнения по трем критериям., Поиск данных в двух таблицах по трем условиям
 
Код
Option Explicit

'1. Ф.И.О. Литры Время взять в массив, чтоб там можно было обнулять не повредив источник.
'2. Шаг цикла по таблице1, в нём цикл по массиву, проверяем есть ли литры, затем фио, затем время - если ОК, то суммируем в переменной, обнуляем литры в массиве.
'3. Записываем из переменной в таблицу1, переменную обнуляем.
'4. Шаг цикла по таблице1, и т.д.

Sub tt()
    Dim a, y&, i&, ii&, x#

    a = Range("Таблица5712").Value

    For i = 2 To Range("Таблица4").Rows.Count
        For ii = 2 To UBound(a)
            If a(ii, 2) > 0 Then
                If a(ii, 1) = Cells(i, 1) Then
                    If a(ii, 3) >= Cells(i, 2) Then
                        If a(ii, 3) <= Cells(i, 3) Then
                            x = x + a(ii, 2): a(ii, 2) = 0
                        End If
                    End If
                End If
            End If
        Next
        Cells(i, 7) = x: x = 0
    Next
End Sub

Изменено: Hugo - 28 Июн 2020 19:59:10
Подстановка данных из одной таблицы в другую, путем сравнения по трем критериям., Поиск данных в двух таблицах по трем условиям
 
Макросом особых трудностей не вижу, если данные будут в таблицах корректные, а не как сейчас с этим Раусом... хотя и с такими сработает:
1. Ф.И.О. Литры Время взять в массив, чтоб там можно было обнулять не повредив источник.
2. Шаг цикла по таблице1, в нём цикл по массиву, проверяем есть ли литры, затем фио, затем время - если ОК, то суммируем в переменной, обнуляем литры в массиве.
3. Записываем из переменной в таблицу1, переменную обнуляем.
4. Шаг цикла по таблице1, и т.д.
Изменено: Hugo - 28 Июн 2020 19:04:18
Выбрать курс по выбранной валюте на выбранную дату
 
Только ВПР! Можно легко добавить валюты.
Код
=ВПР($B$5;$A$11:$C$40;ВПР(B4;{"USD";2:"EUR";3};2;0);)
Ускорение копирования данных из другой книги
 
На каждом шаге первого цикла Вы 29 раз лезете на лист за одними и теми же значениями. Почему не взять их сразу в массив, тем более что они в столбце и тут даже не нужен цикл по ячейкам?
Из множества значений составить список значений, из которых это множество состоит
 
Ну или использовать из копилки UDF VLOOKUPCOUPLE() или аналогичное с других сайтов. Список фруктов можно сделать вручную, или тоже сперва макросом на словаре или коллекции, таких тут уже много писали.
Изменено: Hugo - 26 Июн 2020 22:04:45
Проблемы с кодировкой в Excel
 
У меня в ноуте на днях обновилась версия вин10 и перестала работать батарея... Процент зарядки видит, но не работает и не заряжает. Совпадение? Не думаю...
Пользовательская функция VBA "Определения скрыта ли строка", базовый VBA
 
А бывает что не скрыта, но не видна, потому что высота минимальная...
VLOOKUP не возвращает в ячейку результат, если ищем по числу (но возвращает, если в ячейке содержатся не только цифры)
 
Цитата
Foster777 написал: можете поделиться?
Цитата
Hugo написал:  как формулу массива ввести
VLOOKUP не возвращает в ячейку результат, если ищем по числу (но возвращает, если в ячейке содержатся не только цифры)
 
Можно как формулу массива ввести
Код
=ВПР(""&A2;""&raw!$A$1:$C$7;3;ЛОЖЬ)

Или надёжнее сразу раз уж
Код
=ВПР(СЖПРОБЕЛЫ(A2);СЖПРОБЕЛЫ(raw!$A$1:$C$7);3;ЛОЖЬ)
Изменено: Hugo - 25 Июн 2020 18:17:07
Замена названий файлов содержащих специальные символы с помощью vba
 
Цитата
ser11241 написал:
Из интернета скачивается большое количество картинок
, и к каждому названию с такими Unicode символами нужно вручную написать новое название, причём нужно как-то отследить чтоб не было дублей!
Вопрос - а зачем?
Страницы: 1 2 3 4 5 6 7 8 9 10 11 ... 746 След.
Наверх