Поиск  Пользователи  Правила 
Закрыть
Логин:
Пароль:
Забыли свой пароль?
Регистрация
Войти
 
Выбрать дату в календареВыбрать дату в календаре

Страницы: 1 2 3 4 5 6 7 8 9 10 11 ... 754 След.
Перевести дату по-русски на дату по-английски одной формулой
 
Цитата
buchlotnik написал:
так дано ж
ДАТА!
Цитата
Mst Touch написал:
а если дата в формате "21.11.2020"
то я написал. Правда у меня не хватает "st", это может кто подскажет.
Перевести дату по-русски на дату по-английски одной формулой
 
Не совсем, но близко:
Код
=ТЕКСТ(A1;"[$-409]дддд, ММММ дд, гггг")

Ну или формат такой ячейке  поставить, если можно без формулы.
Изменено: Hugo - 17 сен 2020 21:33:01
Скрыть столбцы по условию макросом
 
В ActiveSheet.UsedRange.
А этот диапазон может начинаться с любой строки листа.
Скрыть столбцы по условию макросом
 
Из этого всего можно оставить 3 строки:
Код
Private Sub ToggleButton1_Click()

'If Me.ToggleButton1.Value = True Then
    For Each cell In ActiveSheet.UsedRange.Rows(1).Cells
    'Debug.Print ActiveSheet.UsedRange.Rows(1).Cells.Address
        If cell.Value Like "*НЕДЕЛЯ*" Then cell.EntireColumn.Hidden = Me.ToggleButton1.Value 'True
    Next
'Else
'    For Each cell In ActiveSheet.UsedRange.Rows(1).Cells
'        If cell.Value Like "*НЕДЕЛЯ*" Then cell.EntireColumn.Hidden = False
'    Next
'End If
End Sub
Суммесли не работает с длинными числами в качестве условия, Суммесли суммируя по условию в качестве которого задано длинное число заменяет последнюю цифру нулем.
 
СЧЁТЕСЛИ() косячит аналогично.
И СУММЕСЛИМН() тоже.
А вот СУММПРОИЗВ() можно использовать.
Изменено: Hugo - 16 сен 2020 20:46:14
Помогите. Нужно написать "код - дание" в ячейку, и сответственно от етого появиться значение в строках (пример додаю)
 
складний=сложный? Ну нафиг, так напрограммируем :)
VBA. Как исправить ошибку Run-time error '1004' Application-defined or object-defined error
 
В xls точно работать не будет.
Применение параметра Delimiter для файлов*.csv
 
Кинул линки в личку.
Применение параметра Delimiter для файлов*.csv
 
Да там данные такие что обычным импортом никак не взять корректно.
Если не лень качать кажется 30 мб - попробуй :)
Изменено: Hugo - 15 сен 2020 19:17:16
Применение параметра Delimiter для файлов*.csv
 
Привет Павел!
Да я тут на днях на эксельмире такооой csv импортировал :)
Скрин: https://u.to/ym2eGQ
Только PQ и справился. легко.
Изменено: Hugo - 15 сен 2020 19:08:19
Применение параметра Delimiter для файлов*.csv
 
А лучше PQ!
Как скрыть строки таблицы не содержащие текст, внесенный в контрольные ячейки над таблицей?
 
Цитата
Hugo написал:
а ещё там используется LinkedCell!
Как скрыть строки таблицы не содержащие текст, внесенный в контрольные ячейки над таблицей?
 
ListObjects - это умная таблица!
А таких нет.
P.S. а ещё там используется LinkedCell!
Вот сделал в файле для первой таблицы.
Изменено: Hugo - 15 сен 2020 09:08:00
Как скрыть строки таблицы не содержащие текст, внесенный в контрольные ячейки над таблицей?
 
Цитата
SamuelW написал:
Проименовал диапазон
- не вижу.
Функция не видит число
 
Код
=ЕСЛИ(СЧЁТЕСЛИ(A1;"ДА")=1;3;"-")

Зачем превращать текст в цифры? Выводите сразу цифры!
Хотя в общем случае конечно не цифры, а числа! :)
Изменено: Hugo - 14 сен 2020 19:57:32
Сохранение файла с ячейкой, обязательной для заполнения
 
Ну так я подсказал, на другой машине с другим Экселем проблем в этом быть не должно.
Но вот проверку я бы делал не по
Код
IsEmpty(Range("F9"))

а по
Код
Len(Trim(Range("F9"))) = 0

Потому что забить туда пробел у них нет проблем :(
И ещё нужно указать лист, вдруг там ещё листы добавятся.
Изменено: Hugo - 14 сен 2020 12:16:22
Сохранение файла с ячейкой, обязательной для заполнения
 
События включаются сами при старте Экселя.
Выпадающий список (проверка данных) - создать макросом, В списке имеются запятые и точки с запятой
 
И ещё если список большой - создавая как строку можете столкнуться с проблемой длины строки.
Как вызвать макрос, выбранный из КомбоБокс на листе?, Нужно добавить несколько макросов в "поле со списком"
 
Я бы делал как любое другое ветвление - через if-then или удобнее select case ComboBox1 и там внутри call нужныймакрос
Код
Private Sub ComboBox1_Change()
'    Application.Run ActiveSheet.ComboBox1
    Select Case ActiveSheet.ComboBox1
    Case "Macro1": Call Macro1
    Case "Macro2": Call Macro2
    Case "Macro3": Call Macro3
    End Select
End Sub

В этом случае не обязательно в комбобоксе писать именно название макроса.
Изменено: Hugo - 13 сен 2020 14:28:39
Копировать текст и вставить в другую ячейку (в конец), в которой уже есть текст, команды макроса
 
По описанию должен быть перенос! :)
Изменение формата файла с .xlsx на .xls макросом
 
Цитата
suricat555 написал:
Ведь .xls - это формат, не поддерживающий макросы
- кто сказал? Всегда было наоборот, и ничего не менялось.
P.S. А вот откуда макрос в согласно теме xlsx? :)
Изменено: Hugo - 10 сен 2020 20:49:59
Если нет листа с нужным именем, копировать лист-образец и переименовать
 
Цитата
Kulibinslovoru написал:
не дай боже круглые тески
- сперва пробежаться и выловить тёзок.
Или в процессе. Но я бы пробежался сперва, сообщил, пускай юзер думает что делать.
Изменено: Hugo - 10 сен 2020 18:40:39
Изменение формата файла с .xlsx на .xls макросом
 
С простой табличкой с голыми данными думаю ничего не случится.
Изменение формата файла с .xlsx на .xls макросом
 
Количество ячеек, формулы, сводные, форматы, да мало ли что...
Изменение формата файла с .xlsx на .xls макросом
 
Надеюсь Вы осознаёте риски?
Найти дубликаты ссылок в формуле
 
Найти если формула вот такая как показана - нет особых проблем например при помощи простой UDF.
А вот выделить - прямо там по месту никак не возможно. Где-то в другом месте - лично мне геморно. Проще вывести список повторяющихся, с количеством повторов.
Но если формулы намного сложнее - не факт что будет просто.
Хотя если нет проблем перебрать все Range().Precedents и запомнить адреса - то решаемо.
Изменено: Hugo - 10 сен 2020 10:36:08
Импорт данных из текстового файла в Excel с помощью vba
 
Вероятно нет там FileDialog.
Можно пробовать убрать этот тип вообще, может Application.FileDialog(msoFileDialogFilePicker) там всёж есть.
Импорт данных из текстового файла в Excel с помощью vba
 
На маке не работает, или не пробовали?
Если значение найдено, возращать слово "совпадает"
 
Добавьте ЕСЛИ()
[ Закрыто] Увеличить скорость работы, Часть кода при большом кол-ве данных макрос выполняется бывало и по 48 часов
 
Я думаю эту оптимизацию нужно оплачивать по затраченному времени на разбор этой каши.
Страницы: 1 2 3 4 5 6 7 8 9 10 11 ... 754 След.
Наверх