Поиск  Пользователи  Правила 
Закрыть
Логин:
Пароль:
Забыли свой пароль?
Регистрация
Войти
 
Выбрать дату в календареВыбрать дату в календаре

Страницы: 1 2 3 4 5 6 7 8 9 10 11 ... 191 След.
Суммирование в одной ячейке по нескольким условиям (табель раб. времени).
 
Еще вариант:
=СУММПРОИЗВ(СЧЁТЕСЛИ(A3:W3;{"Я3";"Я8";"Я9"});{3;8;9})
Если в мире всё бессмысленно, — сказала Алиса, — что мешает выдумать какой-нибудь смысл? ©Льюис Кэрролл
Отобразить в отдельном столбце пропущенные числа
 
А доп. столбец использовать?
Если в мире всё бессмысленно, — сказала Алиса, — что мешает выдумать какой-нибудь смысл? ©Льюис Кэрролл
Отобразить в отдельном столбце пропущенные числа
 
Цитата
totaljeka написал:
Я дождался результата, там везде 82
Вы не дождались результата. Формула вычисляется. Это по сути так же формула что и была, только она подстраивается под добавление новых чисел.
Если в мире всё бессмысленно, — сказала Алиса, — что мешает выдумать какой-нибудь смысл? ©Льюис Кэрролл
Отобразить в отдельном столбце пропущенные числа
 
=НАИМЕНЬШИЙ(ЕСЛИ(НЕ(СЧЁТЕСЛИ(A$1:ИНДЕКС(A$1:A$50000;ПОИСКПОЗ(9^9;A$1:A$50000;1));СТРОКА(A$1:ИНДЕКС(A$1:A$50000;МАКС((A$1:A$50000))))));СТРОКА(A$1:ИНДЕКС(A$1:A$50000;МАКС((A$1:A$50000)))));СТРОКА())
Формула тяжелая. Я конечного результата так и не дождался. Для таких объемов или доп столбец или макрос.
Если в мире всё бессмысленно, — сказала Алиса, — что мешает выдумать какой-нибудь смысл? ©Льюис Кэрролл
Сумма чисел через дробь и чисел в текстовом формате
 
lyulik049, а еще лучше с рыбкой волжской, которой нет в Днепре :) .
Если в мире всё бессмысленно, — сказала Алиса, — что мешает выдумать какой-нибудь смысл? ©Льюис Кэрролл
Сумма чисел через дробь и чисел в текстовом формате
 
Не нравится мне это решение, но ничего лучше не придумал
=СУММ(--ЕСЛИОШИБКА(ЛЕВСИМВ(B4:F4;ПОИСК("/";B4:F4)-1);ЕСЛИОШИБКА(--B4:F4;0)))
Если в мире всё бессмысленно, — сказала Алиса, — что мешает выдумать какой-нибудь смысл? ©Льюис Кэрролл
Отобразить в отдельном столбце пропущенные числа
 
Почему текстовый файл?
Если в мире всё бессмысленно, — сказала Алиса, — что мешает выдумать какой-нибудь смысл? ©Льюис Кэрролл
Как сложить цифры с определенным символами в разные ячейки
 
Двум минусам -- не страшны никакие пробелы.
Если в мире всё бессмысленно, — сказала Алиса, — что мешает выдумать какой-нибудь смысл? ©Льюис Кэрролл
Сумма чисел через дробь и чисел в текстовом формате
 
Цитата
lyulik049 написал:
По моему проще уволиться...
Не спешите увольняться. Лучше файл с ошибкой покажите.
Если в мире всё бессмысленно, — сказала Алиса, — что мешает выдумать какой-нибудь смысл? ©Льюис Кэрролл
Отобразить в отдельном столбце пропущенные числа
 
Цитата
Максим В. написал:
покажиет файл где моя формула не работает.
Я еще в 23 сообщении написал.
Если в мире всё бессмысленно, — сказала Алиса, — что мешает выдумать какой-нибудь смысл? ©Льюис Кэрролл
Как сложить цифры с определенным символами в разные ячейки
 
Цитата
Wiss написал:
Формула от  Максим В. ,  криво отработает при "  ТР/42"
У меня работает.
Изменено: Максим В. - 23 Янв 2020 14:52:19
Если в мире всё бессмысленно, — сказала Алиса, — что мешает выдумать какой-нибудь смысл? ©Льюис Кэрролл
Как сложить цифры с определенным символами в разные ячейки
 
Формула массива:
=СУММ(ЕСЛИОШИБКА(--ПОДСТАВИТЬ($A$2:$F$2;G1&"/";"");0))
Если в мире всё бессмысленно, — сказала Алиса, — что мешает выдумать какой-нибудь смысл? ©Льюис Кэрролл
Сумма чисел через дробь и чисел в текстовом формате
 
Точно такую формулу Вам предложил Михаил Лебедев, во втором сообщении.
Если в мире всё бессмысленно, — сказала Алиса, — что мешает выдумать какой-нибудь смысл? ©Льюис Кэрролл
Отобразить в отдельном столбце пропущенные числа
 
totaljeka, выдержка из правил:
Цитата
5.3. Администраторы и модераторы имеют право преимущественного трактования тех или иных пунктов правил форума в случае заявлений о наличии двойного смысла в таких пунктах со стороны пользователя.
Я дал решение потому что посчитал, что нозвание темы полностью отражает задачу. У модератора иное мнение. Советую предложить название, а не брать форумчан на слабо:
Цитата
totaljeka написал:
неужели так тяжело макрос написать, это же форум, здесь же люди компетентные очки рейтинга себе зарабатывают.
Цитата
totaljeka написал:
Блин, не хотелось бы такую классную тему поднимать на других форумах, но если мне никто сегодня здесь не поможет, то придется.

О, тему поменяли. totaljeka, покажиет файл где моя формула не работает.
Изменено: Максим В. - 23 Янв 2020 13:41:51
Если в мире всё бессмысленно, — сказала Алиса, — что мешает выдумать какой-нибудь смысл? ©Льюис Кэрролл
Отобразить в отдельном столбце пропущенные числа
 
vikttur, давайте начнем с автора темы. Тем более, что предложенные решения ему не подошли.
Если в мире всё бессмысленно, — сказала Алиса, — что мешает выдумать какой-нибудь смысл? ©Льюис Кэрролл
Отобразить в отдельном столбце пропущенные числа
 
Цитата
totaljeka написал:
когда числа новые появляются
это нужно учитывать в формуле или переписать её так, что бы она сама это делала.
Если в мире всё бессмысленно, — сказала Алиса, — что мешает выдумать какой-нибудь смысл? ©Льюис Кэрролл
Сумма чисел через дробь и чисел в текстовом формате
 
lyulik049, а так?
=СУММ(--ЕСЛИОШИБКА(ЛЕВСИМВ(B2:F2;ПОИСК("/";$B2:$F2)-1);B2:F2))
Если в мире всё бессмысленно, — сказала Алиса, — что мешает выдумать какой-нибудь смысл? ©Льюис Кэрролл
Пересчет непустых ячеек и пропуск пустых
 
iva2000, Вы можете воспользоваться Вашей формулой, а в параметрах Эксель отключить отображение нулей.
Если в мире всё бессмысленно, — сказала Алиса, — что мешает выдумать какой-нибудь смысл? ©Льюис Кэрролл
Отобразить в отдельном столбце пропущенные числа
 
  1. Копируете формулу в ячейку ну скажем В1.
  2. Вводите сочетанием клавиш Ctrl+Shift+Enter/
  3. Тяните вниз.
Если в мире всё бессмысленно, — сказала Алиса, — что мешает выдумать какой-нибудь смысл? ©Льюис Кэрролл
Отобразить в отдельном столбце пропущенные числа
 
Медведь сегодня не в духе ;) . Из-за погоды в спячку никак не ляжет.
Если в мире всё бессмысленно, — сказала Алиса, — что мешает выдумать какой-нибудь смысл? ©Льюис Кэрролл
Пересчет непустых ячеек и пропуск пустых
 
Цитата
iva2000 написал:
если ячейка пустая не делать ничего
Что это значит в Вашем понимании? 0/92=0. Т.е. исходные данные не меняются.
Цитата
iva2000 написал:
переходить к следующей?
Это тожже не понятно.
Сделайте пример 5х5 и покажите желаемый результат.
Если в мире всё бессмысленно, — сказала Алиса, — что мешает выдумать какой-нибудь смысл? ©Льюис Кэрролл
Отобразить в отдельном столбце пропущенные числа
 
Формула массива:
=НАИМЕНЬШИЙ(ЕСЛИ(НЕ(СЧЁТЕСЛИ($A$1:$A$650;СТРОКА($1:$772)+29999));(СТРОКА($1:$772)+29999));СТРОКА())
Если в мире всё бессмысленно, — сказала Алиса, — что мешает выдумать какой-нибудь смысл? ©Льюис Кэрролл
Сумма чисел до сегодняшнего дня в таблице
 
Проверяйте:
В любую ячейку кроме А1.
=СУММПРОИЗВ((A1:G9<=СЕГОДНЯ())*(A1:G9<>"")*ЕНЕЧЁТ(СТРОКА(A1:A9))*A2:G10)
Если в мире всё бессмысленно, — сказала Алиса, — что мешает выдумать какой-нибудь смысл? ©Льюис Кэрролл
Где что? Search, Изменение/удаление темы.
 
Цитата
БМВ написал:
А вот Лунтик …. :-)  
так его забанил Малыш.
Если в мире всё бессмысленно, — сказала Алиса, — что мешает выдумать какой-нибудь смысл? ©Льюис Кэрролл
Поиск соответствующих значений
 
vikttur, так подойдет?
Найти значение по коду в таблице, где нескольким кодам соответствует одно значение.
Если в мире всё бессмысленно, — сказала Алиса, — что мешает выдумать какой-нибудь смысл? ©Льюис Кэрролл
Значение в зависимости от среднего возраста
 
Еще вариант:
=(C2=40)*40+(C2<>40)*C3
Если в мире всё бессмысленно, — сказала Алиса, — что мешает выдумать какой-нибудь смысл? ©Льюис Кэрролл
Поиск соответствующих значений
 
Пробуйте:
=ИНДЕКС(Лист2!D$1:D$4;СУММПРОИЗВ((Лист2!A$1:C$4=A1)*СТРОКА(Лист2!A$1:A$4)))
Если в мире всё бессмысленно, — сказала Алиса, — что мешает выдумать какой-нибудь смысл? ©Льюис Кэрролл
Значение в зависимости от среднего возраста
 
Anastas'a, а если IF поменять на ЕСЛИ?
Если в мире всё бессмысленно, — сказала Алиса, — что мешает выдумать какой-нибудь смысл? ©Льюис Кэрролл
смещение относительно исходной строки с пропуском строк
 
Цитата
perminovandr написал:
тогда уж лучше Доп. столбец и СМЕЩ
Покажите реализацию.
Если в мире всё бессмысленно, — сказала Алиса, — что мешает выдумать какой-нибудь смысл? ©Льюис Кэрролл
смещение относительно исходной строки с пропуском строк
 
Доп. столбец и ВПР
Если в мире всё бессмысленно, — сказала Алиса, — что мешает выдумать какой-нибудь смысл? ©Льюис Кэрролл
Страницы: 1 2 3 4 5 6 7 8 9 10 11 ... 191 След.
Наверх