Поиск  Пользователи  Правила 
Закрыть
Логин:
Пароль:
Забыли свой пароль?
Регистрация
Войти
 
Выбрать дату в календареВыбрать дату в календаре

Страницы: 1 2 3 4 5 6 7 8 9 10 11 ... 202 След.
Автозаполнение таблиц значениями больше нуля
 
Добрый и Вам. Покажите файл-пример с исходными данными и желаемым результатом.
Если в мире всё бессмысленно, — сказала Алиса, — что мешает выдумать какой-нибудь смысл? ©Льюис Кэрролл
Перемножение динамических ячеек
 
=ПРОИЗВЕД(ИНДЕКС(L3:L14;C15):ИНДЕКС(L3:L14;F15))
Если в мире всё бессмысленно, — сказала Алиса, — что мешает выдумать какой-нибудь смысл? ©Льюис Кэрролл
Как подсчитать количество условий, если условия - масивы строк и столбцов?
 
Привет. Проверяйте:
=СУММПРОИЗВ((ИНДЕКС(Лист2!$D$2:$AH$21;0;ПОИСКПОЗ($A$1;Лист2!$D$1:$AH$1;))=$A3)*(B$2=Лист2!$B$2:$B$21))
Если в мире всё бессмысленно, — сказала Алиса, — что мешает выдумать какой-нибудь смысл? ©Льюис Кэрролл
Перемножение динамических ячеек
 
Пример покажите. Что есть, что нужно на выходе.  
Если в мире всё бессмысленно, — сказала Алиса, — что мешает выдумать какой-нибудь смысл? ©Льюис Кэрролл
Нахождение глаголов в столбце EXCEL, Нужно найти все глаголы в столбце EXCEL
 
В интернете находите список всех глаголов. Это будет справочник. Сравниваете ваш список со справочником, и то что есть, вытягиваете в столбец.
Если в мире всё бессмысленно, — сказала Алиса, — что мешает выдумать какой-нибудь смысл? ©Льюис Кэрролл
Подставление данных в ячейку функцией ВПР из разных столбцов., Подставление данных в ячейку функцией ВПР из разных столбцов.
 
Формула массива:
=ВПР(B2;ЕСЛИ({1;0};A10:A15;B10:B15&C10:C15);2;)
Если в мире всё бессмысленно, — сказала Алиса, — что мешает выдумать какой-нибудь смысл? ©Льюис Кэрролл
Заливка таблицы цветом, как в первой строке
 
Сделал для первых двух блоков. Дале сами по аналогии.
Если в мире всё бессмысленно, — сказала Алиса, — что мешает выдумать какой-нибудь смысл? ©Льюис Кэрролл
Заливка таблицы цветом, как в первой строке
 
Цитата
irina111 написал:
В рабочем документе заливка выполняется с помощью условного форматирования,
Что мешает применить УФ не к одной строке, а ко всей таблице?
Если в мире всё бессмысленно, — сказала Алиса, — что мешает выдумать какой-нибудь смысл? ©Льюис Кэрролл
Проверка синтаксиса email
 
Добрый и Вам. Что значит проверка синтаксиса?  
Если в мире всё бессмысленно, — сказала Алиса, — что мешает выдумать какой-нибудь смысл? ©Льюис Кэрролл
Текст в сводной таблице
 
И Вам здравствовать. Может это статья поможет Сводная таблица с текстом в значениях
Если в мире всё бессмысленно, — сказала Алиса, — что мешает выдумать какой-нибудь смысл? ©Льюис Кэрролл
Заливка таблицы цветом, как в первой строке
 
Добрый день. Формат по образцу пробавали?
Если в мире всё бессмысленно, — сказала Алиса, — что мешает выдумать какой-нибудь смысл? ©Льюис Кэрролл
Имя Отчество Фамилия преобразовать в Фамилия Имя Отчество
 
Зачем ПСТР заменили на ПОДСТАВИТЬ?
И по Вашему Cергеев Станислав Михайлович соответствует маске Имя Отчество Фамилия?
Изменено: Максим В. - 2 Июн 2020 14:18:36
Если в мире всё бессмысленно, — сказала Алиса, — что мешает выдумать какой-нибудь смысл? ©Льюис Кэрролл
Имя Отчество Фамилия преобразовать в Фамилия Имя Отчество
 
=ПСТР(A1&" "&A1;ПОИСК(" ";A1;ПОИСК(" ";A1)+1)+1;ДЛСТР(A1))
Если в мире всё бессмысленно, — сказала Алиса, — что мешает выдумать какой-нибудь смысл? ©Льюис Кэрролл
Поиск даты ближайшего рабочего дня
 
Здрасьте и Вам. Формулы массива:
=ИНДЕКС(A1:A731;ПОИСКПОЗ(1;(A1:A731>=F1)*(C1:C731="робочий");))
=МИН(ЕСЛИ((A1:A731>=F1)*(C1:C731="робочий");A1:A731))
Если в мире всё бессмысленно, — сказала Алиса, — что мешает выдумать какой-нибудь смысл? ©Льюис Кэрролл
Некорректно работает условное форматирование с повторяющимися значениями
 
Правило для УФ:
=СУММПРОИЗВ(--($A$1:$A$115&""=A1&""))>1
Если в мире всё бессмысленно, — сказала Алиса, — что мешает выдумать какой-нибудь смысл? ©Льюис Кэрролл
Вытягивание списка между категориями
 
Нормальзовать таблицу и построить сводную
Если в мире всё бессмысленно, — сказала Алиса, — что мешает выдумать какой-нибудь смысл? ©Льюис Кэрролл
Автозаполнение ячейки в записимости от значений 2ух выпадающих списков
 
1) Привести исходную таблицу в нормальный вид. Убрать объедененные ячейки и пропуски строк.
2) Построить Сводную таблицу.
Если в мире всё бессмысленно, — сказала Алиса, — что мешает выдумать какой-нибудь смысл? ©Льюис Кэрролл
Автоматическая подстановка значений в ячейку в зависимости от значения в другой ячейке
 
Добрый и Вам. По описанию поможет ВПР()
Если в мире всё бессмысленно, — сказала Алиса, — что мешает выдумать какой-нибудь смысл? ©Льюис Кэрролл
Совпадение из заданного списка умной таблицы
 
Добавить ИЛИ нужно и это уже будет формула массива:
=ЕСЛИ(ИЛИ(A2=Регион[Регион ТС]);1;0)
или тоже самое, но короче:
=--ИЛИ(A2=Регион[Регион ТС])
ВВодить тремя клавишами Ctrl+Shift+Enter
Если в мире всё бессмысленно, — сказала Алиса, — что мешает выдумать какой-нибудь смысл? ©Льюис Кэрролл
Совпадение из заданного списка умной таблицы
 
Можно руками ввести. У себя попробовал- получилось. Вот только зачем это нужно?
Если в мире всё бессмысленно, — сказала Алиса, — что мешает выдумать какой-нибудь смысл? ©Льюис Кэрролл
Совпадение из заданного списка умной таблицы
 
Цитата
Старый написал:
--перед isnumber -это какая то специальная штука?
Преобразует логические ИСТИНА, ЛОЖЬ в 1 и 0.
Цитата
Старый написал:
И почему когда я делаю ссылку на умную таблицу, то у меня она отображается одним словом, а у вас двумя:
На счет этого точно не скажу. Может из за именованного диапазона.
Цитата
Старый написал:
=ISNUMBER(FIND(B2;"Регион")
Кавычки здесь лишние. Все что в кавычках- это текст. Т.е. Вы ищете Mosco в слове Регион.
Если в мире всё бессмысленно, — сказала Алиса, — что мешает выдумать какой-нибудь смысл? ©Льюис Кэрролл
Совпадение из заданного списка умной таблицы
 
Цитата
Старый написал:
Нужно специально вводить Регион[Регион ТС] -т.е. 2 раза и в квадратных скобках?
Нет. Так отображаются столбцы умной таблицы.
Цитата
Старый написал:
Мне достаточно ответа 1 или 0,
Именно такой результат и возвращает формула.
Если в мире всё бессмысленно, — сказала Алиса, — что мешает выдумать какой-нибудь смысл? ©Льюис Кэрролл
Совпадение из заданного списка умной таблицы
 
Добрый и Вам. Не понятно в каком виде нужен результат. Формула ищет точное и частичное совпадение:
=СУММПРОИЗВ(--ЕЧИСЛО(НАЙТИ(A2;Регион[Регион ТС])))
Если в мире всё бессмысленно, — сказала Алиса, — что мешает выдумать какой-нибудь смысл? ©Льюис Кэрролл
Проверка отсортированы ли значения (например, по возрастанию) в колонке, как это сделать одной формулой или функцией?
 
paganafora, идея элементарная. Проверяется 2 массива. Если каждое предыдущее значение меньше или равно следующему, значит массив отсортирован.
Если в мире всё бессмысленно, — сказала Алиса, — что мешает выдумать какой-нибудь смысл? ©Льюис Кэрролл
Проверка отсортированы ли значения (например, по возрастанию) в колонке, как это сделать одной формулой или функцией?
 
Формула массива для проверки сортировки от мин к макс:
=ЕСЛИ(И(A2:A24<=A3:A25);"Отсортирован";"Нет")
Изменено: Максим В. - 21 Май 2020 13:03:22
Если в мире всё бессмысленно, — сказала Алиса, — что мешает выдумать какой-нибудь смысл? ©Льюис Кэрролл
Перенести данные из другого согласно имени одной формулой для всех столбцов
 
Еще вариант:
=ВПР($B6;ЕСЛИ({1;0};Лист1!$B$2:$B$200;ИНДЕКС(Лист1!$A$2:$H$200;0;ПОИСКПОЗ(C$5;Лист1!$A$1:$H$1;)));2;)
Если в мире всё бессмысленно, — сказала Алиса, — что мешает выдумать какой-нибудь смысл? ©Льюис Кэрролл
Вычленение имён и фамилий из массива, Работа с текстовым массивом, в котором перепутаны местами имена, фамилии и отчества.
 
Посмотрите здесь
Если в мире всё бессмысленно, — сказала Алиса, — что мешает выдумать какой-нибудь смысл? ©Льюис Кэрролл
Перенос уникальных значений из соседней ячейки в другой столбец с условием
 
Добрый день. Проверьте эту формулу массива:
=НАИМЕНЬШИЙ(ЕСЛИ(СТРОКА(B$1:B$16)=ЕСЛИОШИБКА(ПОИСКПОЗ(B$1:B$16;ЕСЛИ(D$1:D$16="перенос";B$1:B$16););"");B$1:B$16);СТРОКА(G1))
Если в мире всё бессмысленно, — сказала Алиса, — что мешает выдумать какой-нибудь смысл? ©Льюис Кэрролл
Количество дней с минимальной температурой (воздуха, на поверхности почвы, на высоте 2 см) < или = 0
 
Проверяйте:
=СУММПРОИЗВ(--ЕЧИСЛО(A9:A21);ЗНАК((D9:D21<=0)+(F9:F21<=0)+(G9:G21<=0)))
Если в мире всё бессмысленно, — сказала Алиса, — что мешает выдумать какой-нибудь смысл? ©Льюис Кэрролл
Количество дней с минимальной температурой (воздуха, на поверхности почвы, на высоте 2 см) < или = 0
 
=СЧЁТЕСЛИ(G9:G23;"<=0")
Если в мире всё бессмысленно, — сказала Алиса, — что мешает выдумать какой-нибудь смысл? ©Льюис Кэрролл
Страницы: 1 2 3 4 5 6 7 8 9 10 11 ... 202 След.
Наверх