Поиск  Пользователи  Правила 
Закрыть
Логин:
Пароль:
Забыли свой пароль?
Регистрация
Войти
 
Выбрать дату в календареВыбрать дату в календаре

Страницы: 1 2 3 4 5 6 7 8 9 10 11 ... 202 След.
Вытягивание списка между категориями
 
Нормальзовать таблицу и построить сводную
Если в мире всё бессмысленно, — сказала Алиса, — что мешает выдумать какой-нибудь смысл? ©Льюис Кэрролл
Автозаполнение ячейки в записимости от значений 2ух выпадающих списков
 
1) Привести исходную таблицу в нормальный вид. Убрать объедененные ячейки и пропуски строк.
2) Построить Сводную таблицу.
Если в мире всё бессмысленно, — сказала Алиса, — что мешает выдумать какой-нибудь смысл? ©Льюис Кэрролл
Автоматическая подстановка значений в ячейку в зависимости от значения в другой ячейке
 
Добрый и Вам. По описанию поможет ВПР()
Если в мире всё бессмысленно, — сказала Алиса, — что мешает выдумать какой-нибудь смысл? ©Льюис Кэрролл
Совпадение из заданного списка умной таблицы
 
Добавить ИЛИ нужно и это уже будет формула массива:
=ЕСЛИ(ИЛИ(A2=Регион[Регион ТС]);1;0)
или тоже самое, но короче:
=--ИЛИ(A2=Регион[Регион ТС])
ВВодить тремя клавишами Ctrl+Shift+Enter
Если в мире всё бессмысленно, — сказала Алиса, — что мешает выдумать какой-нибудь смысл? ©Льюис Кэрролл
Совпадение из заданного списка умной таблицы
 
Можно руками ввести. У себя попробовал- получилось. Вот только зачем это нужно?
Если в мире всё бессмысленно, — сказала Алиса, — что мешает выдумать какой-нибудь смысл? ©Льюис Кэрролл
Совпадение из заданного списка умной таблицы
 
Цитата
Старый написал:
--перед isnumber -это какая то специальная штука?
Преобразует логические ИСТИНА, ЛОЖЬ в 1 и 0.
Цитата
Старый написал:
И почему когда я делаю ссылку на умную таблицу, то у меня она отображается одним словом, а у вас двумя:
На счет этого точно не скажу. Может из за именованного диапазона.
Цитата
Старый написал:
=ISNUMBER(FIND(B2;"Регион")
Кавычки здесь лишние. Все что в кавычках- это текст. Т.е. Вы ищете Mosco в слове Регион.
Если в мире всё бессмысленно, — сказала Алиса, — что мешает выдумать какой-нибудь смысл? ©Льюис Кэрролл
Совпадение из заданного списка умной таблицы
 
Цитата
Старый написал:
Нужно специально вводить Регион[Регион ТС] -т.е. 2 раза и в квадратных скобках?
Нет. Так отображаются столбцы умной таблицы.
Цитата
Старый написал:
Мне достаточно ответа 1 или 0,
Именно такой результат и возвращает формула.
Если в мире всё бессмысленно, — сказала Алиса, — что мешает выдумать какой-нибудь смысл? ©Льюис Кэрролл
Совпадение из заданного списка умной таблицы
 
Добрый и Вам. Не понятно в каком виде нужен результат. Формула ищет точное и частичное совпадение:
=СУММПРОИЗВ(--ЕЧИСЛО(НАЙТИ(A2;Регион[Регион ТС])))
Если в мире всё бессмысленно, — сказала Алиса, — что мешает выдумать какой-нибудь смысл? ©Льюис Кэрролл
Проверка отсортированы ли значения (например, по возрастанию) в колонке, как это сделать одной формулой или функцией?
 
paganafora, идея элементарная. Проверяется 2 массива. Если каждое предыдущее значение меньше или равно следующему, значит массив отсортирован.
Если в мире всё бессмысленно, — сказала Алиса, — что мешает выдумать какой-нибудь смысл? ©Льюис Кэрролл
Проверка отсортированы ли значения (например, по возрастанию) в колонке, как это сделать одной формулой или функцией?
 
Формула массива для проверки сортировки от мин к макс:
=ЕСЛИ(И(A2:A24<=A3:A25);"Отсортирован";"Нет")
Изменено: Максим В. - 21 Май 2020 13:03:22
Если в мире всё бессмысленно, — сказала Алиса, — что мешает выдумать какой-нибудь смысл? ©Льюис Кэрролл
Перенести данные из другого согласно имени одной формулой для всех столбцов
 
Еще вариант:
=ВПР($B6;ЕСЛИ({1;0};Лист1!$B$2:$B$200;ИНДЕКС(Лист1!$A$2:$H$200;0;ПОИСКПОЗ(C$5;Лист1!$A$1:$H$1;)));2;)
Если в мире всё бессмысленно, — сказала Алиса, — что мешает выдумать какой-нибудь смысл? ©Льюис Кэрролл
Вычленение имён и фамилий из массива, Работа с текстовым массивом, в котором перепутаны местами имена, фамилии и отчества.
 
Посмотрите здесь
Если в мире всё бессмысленно, — сказала Алиса, — что мешает выдумать какой-нибудь смысл? ©Льюис Кэрролл
Перенос уникальных значений из соседней ячейки в другой столбец с условием
 
Добрый день. Проверьте эту формулу массива:
=НАИМЕНЬШИЙ(ЕСЛИ(СТРОКА(B$1:B$16)=ЕСЛИОШИБКА(ПОИСКПОЗ(B$1:B$16;ЕСЛИ(D$1:D$16="перенос";B$1:B$16););"");B$1:B$16);СТРОКА(G1))
Если в мире всё бессмысленно, — сказала Алиса, — что мешает выдумать какой-нибудь смысл? ©Льюис Кэрролл
Количество дней с минимальной температурой (воздуха, на поверхности почвы, на высоте 2 см) < или = 0
 
Проверяйте:
=СУММПРОИЗВ(--ЕЧИСЛО(A9:A21);ЗНАК((D9:D21<=0)+(F9:F21<=0)+(G9:G21<=0)))
Если в мире всё бессмысленно, — сказала Алиса, — что мешает выдумать какой-нибудь смысл? ©Льюис Кэрролл
Количество дней с минимальной температурой (воздуха, на поверхности почвы, на высоте 2 см) < или = 0
 
=СЧЁТЕСЛИ(G9:G23;"<=0")
Если в мире всё бессмысленно, — сказала Алиса, — что мешает выдумать какой-нибудь смысл? ©Льюис Кэрролл
Преобразование текстовой записи в число с отбрасыванием лишнего
 
=ЛЕВСИМВ(A2;2)*60+ПСТР(A2;ПОИСК(",";A2)+2;2)
Если в мире всё бессмысленно, — сказала Алиса, — что мешает выдумать какой-нибудь смысл? ©Льюис Кэрролл
Преобразование текстовой записи в число с отбрасыванием лишнего
 
iRon-k, Вам об этом писали выше.
Если в мире всё бессмысленно, — сказала Алиса, — что мешает выдумать какой-нибудь смысл? ©Льюис Кэрролл
Если в диапазоне ячеек есть текст, то в другой ячейке выполняется условие
 
В ячейку В1
=ЕСЛИ(СУММПРОИЗВ(ДЛСТР(B2:B5));"Есть текст";"")
Если в мире всё бессмысленно, — сказала Алиса, — что мешает выдумать какой-нибудь смысл? ©Льюис Кэрролл
Преобразование текстовой записи в число с отбрасыванием лишнего
 
Цитата
iRon-k написал:
А в чём, собственно, дело?
Собственно пробуйте:
=ЛЕВСИМВ(A1)*60+ПСТР(A1;8;1)
Если в мире всё бессмысленно, — сказала Алиса, — что мешает выдумать какой-нибудь смысл? ©Льюис Кэрролл
Если в диапазоне ячеек есть текст, то в другой ячейке выполняется условие
 
Если у вас значения копируются из столбца А в столбец В формулой, то предложенная мной формула, ссылаясь на столбец А, вернет верный результат. Или я не прав?
Если в мире всё бессмысленно, — сказала Алиса, — что мешает выдумать какой-нибудь смысл? ©Льюис Кэрролл
Если в диапазоне ячеек есть текст, то в другой ячейке выполняется условие
 
А что там помогать? Поменяйте руками или в режиме редактирования формулы перетащите диапазон.
Если в мире всё бессмысленно, — сказала Алиса, — что мешает выдумать какой-нибудь смысл? ©Льюис Кэрролл
Если в диапазоне ячеек есть текст, то в другой ячейке выполняется условие
 
Смотрите файл
Если в мире всё бессмысленно, — сказала Алиса, — что мешает выдумать какой-нибудь смысл? ©Льюис Кэрролл
Если в диапазоне ячеек есть текст, то в другой ячейке выполняется условие
 
Формула
=ЕСЛИ(СЧЁТЗ(A1:A10)>0;"Есть текст";"")
Если в мире всё бессмысленно, — сказала Алиса, — что мешает выдумать какой-нибудь смысл? ©Льюис Кэрролл
Заливка цветом праздничных дней в табеле, Помогите, пожалуйста, разобраться как правильно прописать формулу условного форматирования, чтоб закрасить праздничные дни цветом
 
Правило для УФ:
=ЕЧИСЛО(ПОИСКПОЗ($R$7+F$10-1;праздники!$A$2:$A$5;))
Судя по файлу вы знакомы с УФ,
Если в мире всё бессмысленно, — сказала Алиса, — что мешает выдумать какой-нибудь смысл? ©Льюис Кэрролл
Условное форматирование выходных дней в табеле
 
Добрый и Вам. Можете вручную продемонстрировать нужный результат?
Если в мире всё бессмысленно, — сказала Алиса, — что мешает выдумать какой-нибудь смысл? ©Льюис Кэрролл
Если сумма чисел меньше константы, оставить сумму. Если больше, от суммы отнять константу.
 
Код
=СУММ(A16:B16)-(СУММ(A16:B16)>25)*25

Название темы:

Если сумма чисел меньше константы, оставить сумму. Если больше, от суммы отнять константу.

Изменено: Максим В. - 11 Май 2020 12:27:55
Если в мире всё бессмысленно, — сказала Алиса, — что мешает выдумать какой-нибудь смысл? ©Льюис Кэрролл
Поиск в таблице равное или больше указанного значения
 
Цитата
ejik_off написал:
Можно выделить в таблице "Еженедельный взнос" найденную строку цветом?
Можно. С помощью условного форматирования и такого правила:
=$H2=$B$6
Если в мире всё бессмысленно, — сказала Алиса, — что мешает выдумать какой-нибудь смысл? ©Льюис Кэрролл
Транспонировать на новый лист в линейное представление
 
Вариант с доп. столбцом
Если в мире всё бессмысленно, — сказала Алиса, — что мешает выдумать какой-нибудь смысл? ©Льюис Кэрролл
Копирование через строку
 
Zeddo, покажите файл где не получается.
Если в мире всё бессмысленно, — сказала Алиса, — что мешает выдумать какой-нибудь смысл? ©Льюис Кэрролл
Добавить/отнять единицу е в зависимости от знака числа
 
Так?
=C5+ЗНАК(C5)
Если в мире всё бессмысленно, — сказала Алиса, — что мешает выдумать какой-нибудь смысл? ©Льюис Кэрролл
Страницы: 1 2 3 4 5 6 7 8 9 10 11 ... 202 След.
Наверх