Поиск  Пользователи  Правила 
Закрыть
Логин:
Пароль:
Забыли свой пароль?
Регистрация
Войти
 
Выбрать дату в календареВыбрать дату в календаре

Страницы: 1 2 3 4 5 6 7 8 9 10 11 ... 1318 След.
Макрос для добавления пустых строк между строками с данными и дублирования в них содержимого
 
"ДИСКЛЕЙМЕР"...такой текст-предупреждение пишется в самом начале, перед основным текстом или постановкой задачи. А вообще - стоит ли заменять нормальное слово на искаженную транскрипцию?
[ Закрыто] Проблема с вложенным условием vba, Не выполняется второе условие
 
Цитата
ocet p написал: Пожалуйста и вы помогите помогающим тоже
Почитайте личку, правила, измените логин и создайте тему с учетом полученных замечаний.
Зафиксировать постоянное число после знака ","
 
"сталий" (укр.) = "устойчивый" (рус). Здесь в понятии "неизменный, постоянный"
Вывод последнего значения из массива в другую таблицу
 
romaperov, надо реагировать... Помощь приостановлена до устранения замечаний.
впр нескольких значений по горизонтали, может кто то помочь? индекс и поиск поз не получается использовать
 
Какой Вы добрый... Вам помогли и теперь можно удалить труды помогающего? А как же другие посетители, им помочь не хотите?
Значит, помогающий вместо Вас еще раз напряжется.
впр нескольких значений по горизонтали, может кто то помочь? индекс и поиск поз не получается использовать
 
Уточняем название темы.
шаблон для прайс листа
 
Уже видел добавленную ссылку в первом сообщении. Скайп в личке.
PaRADoX. Форма с поиском по маске. Как найти и получить одно или несколько значений
 
Цитата
voxik-24 написал: последняя строка не влазит  в пределы видимости
Это проблема самого ListBox. Можно решить добавлением пустой строки  в конце. Но это усложняет обработку, при выводе или просмотре данных нужно это учитывать.
шаблон для прайс листа
 
Не понял, как показанная иструкция связана с Excel...
Да, в Excel можно организовать функционал, описанный в сообщении.
Выбирается категория, в зависимост от нее формируются выпадающие списки... "Умный ввод" - фильтрация списка категорий по введенным символам.
В личке написал Скайп для связи, могу показать похожие разработки
Обработка идентичных кнопок в UserForm
 
Здесь - обсуждение заглавной темы.
Обработка идентичных кнопок в UserForm
 
В списках трех (на форме не три - 6 или 7, но это дела не меняет) полей ввода данные меняются в зависимости от тарификации.
Уходим от темы. Если хотите обсудить єтот вопрос - новая ема с примером в Excel
Обработка идентичных кнопок в UserForm
 
Цитата
vikttur написал: Возможно, тоже приводится к одному блоку?
ListBox с предметами, три поля для ввода значений, ListBox с результатом.
Вібираем предмет, вносим значения, сохраняем запись (добавляется во второй список). После обработки/корректировки второго  списка сохраням данніе куда надо.. Но
Цитата
вопрос для другой темы.
Обработка идентичных кнопок в UserForm
 
Написать класс. Пример в файле ускоряет помощь.
Цитата
29 одинаковых блоков Frames
Не всегда оправдано. Возможно, тоже приводится к одному блоку? Это зависит от задачи. Ну, и вопрос для другой темы.
Обработка идентичных кнопок в UserForm
 
Код
Private Sub PredmetComboBox2_Change ()
       Call общая_процедура (передаваемые параметры)
End Sub

Private Sub общая_процедура (принимаемые параметры)
       здесь_работаем
End Sub
VBA: очистить ячейку, если в ячейке 0
 
Функция не может управлять форматом ячейки. Проблема в том, чтобы задать формат сразу, при создании таблицы?
Вывод последнего значения из массива в другую таблицу
 
1. О пустых строках я Вам зря писал? Приведите сообщене в порядок.
2. Кнопка цитироваия не для бездумного нажатия. Приведите в порядок другое сообщение.
3. Вы предлагаете для помощи Вам создавать файл и вносить туда данные из Вашей картинки? И много охочих нашлось?
Снять галочки с чекбоксов
 
Sanja, :)
Цитата
НСС написал: Задача решена заменой флажка-объекта на "флажок" в ячейке по событию выделения ячейки
VBA: очистить ячейку, если в ячейке 0
 
Код
Public Function f_x5(x As Long)
    If x = 0 Then f_x5 = "" Else f_x5 = x
End Function

Наличие текста среди числовых данных (а это "" - текст нулевой длины) может навредить последующим вычислениям
Формат ячеек 0;; скроет ненужные нули без применения функции.
Вывод последнего значения из массива в другую таблицу
 
Цитата
romaperov написал: Существует диапозон из строк
Пока что в собщении сущетвует только куча пустых строк, примера не видно.
Ознакомьтесь с правилами форума
VBA: очистить ячейку, если в ячейке 0
 
Цитата
Alex D написал: Пример.
Нет, пример - это файл, демонстрирующий проблему

Цитата
если это число = 0 то нужно ноль убрать на "". Для этого и нужна пользовательская функция.
Может, достаточно в параметрах листа снять галку, ответственную за отображение нулевых значений?
При вводе номера клиента подтянуть информацию в соответствующие поля из справочника клиентов
 
По названию темы задача непонятна. Об этом - в правилах форума.
VBA: очистить ячейку, если в ячейке 0
 
Код
If myVariant = "0" Then   myVariant.ClearContents

Если одной строкой, то End If
В ячейке точно текст "0", не число 0? myVariant - это откуда? В функцию что-то передаваться должно?
Надо пример в файле показывать
Нужно сравнить две даты
 
Цитата
В столбце А...  сравнить с текущей в ячейке Р1
Пробовал ставить =ЕСЛИ(C5...
Над пример показывать, а не путать описаем
Снять галочки с чекбоксов
 
В общем модуле
Код
Dim bFlag As Boolean

В процедуре
Код
Private Sub CommandButton1_Click()
    ' ///////////////   
    bFlag = True
    ' ///////////////
    bFlag = False
End Sub

В событии каждой птички прописать условие флага.
Код
If bFlag = False Then Call check_boxes

Но вариант топорный. Ищите на форуме темы с  заменой флажка-объекта на "флажок" в ячейке - запись символа по событию выделения ячейки.
[ Закрыто] Вопрос по регулярке
 
Вопрос другой - п.2.1 правил форума пропустили мимо внимания?
При протяжке формулы число в середине кода увеличивать на 1
 
=ТЕКСТ(СТРОКА(A1);"\R000")&"A-SY19/20"
Условное форматирование. Раскрасить изменяющиеся даты разными цветами
 
=ОСТАТ(СУММ(1/СЧЁТЕСЛИ($A$1:A1;$A$1:A1));2)
Условное форматирование. Раскрасить изменяющиеся даты разными цветами
 
Пришлите фломастеры, я Вам Ваше сообщение раскрашу
Сопоставление данных относительно 2-х столбцов
 
Извините, не вник в задачу. Покажите в файле, что не получается.
Распределить материалы по заказам
 
n_alex_n, свои сообщения можно дополнять. Вернитесь и сделайте одно. А то создается впечатление, что руки быстрее работают, чем голова.
Страницы: 1 2 3 4 5 6 7 8 9 10 11 ... 1318 След.
Наверх