Поиск  Пользователи  Правила 
Закрыть
Логин:
Пароль:
Забыли свой пароль?
Регистрация
Войти
 
Выбрать дату в календареВыбрать дату в календаре

Страницы: 1 2 3 4 5 6 7 8 9 10 11 ... 1325 След.
Накопительные ячейки
 
Цитата
vikttur написал: Предложите название темы. Модераторы заменят.
Избушка формулистов-3, не для вопросов, но для формульных задач
 
Zasypich, решение от Вас будет?
Подсчет совпадений значений в ячейке из списка
 
kolyaya, Вы не пнимаете, что зачит "показать в файле"?
VBA: Ускорение удаления строк в умной таблице по критерию
 
Код
Private Sub CommandButton1_Click()
    Dim arrData()
    Dim Compare ' что там? тип переменной?
    Dim rRng As Range

    arrData = Sheets(1).ListObjects(1).Range.Value
    Compare = Sheets(1).Range("F3").Value
    
    With Application
        .ScreenUpdating = False
        .EnableEvents = False
        .Calculation = xlCalculationManual
    End With
    
    For i = 1 To UBound(arrData)
        If arrData(i, 1) = Compare Then
            If rRng Is Nothing Then
                Set rRng = Cells(i, 1)
            Else
                Set rRng = Union(rRng, Cells(i, 1))
            End If
        End If
    Next i
    
    If Not rRng Is Nothing Then rRng.EntireRow.Delete
    
    With Application
        .Calculation = xlCalculationAutomatic
        .EnableEvents = True
        .ScreenUpdating = True
    End With
End Sub
Копировать и заменить по * (звездочке)
 
Посмотрите на "цитату" в свем последнем сообщении. Для чего эта бездумная копия? Там написаны замечания. Вы их читаете?

Решение есть у меня. Но показывать его Вам не хочу. Вы же не хотите раегировать на замечания. Ссылки на парллельное размещение темы не показываете, решение в предыдущей теме не выкладываете.
Как вывести искомое значение из столбцы
 
После прихода модератора тоже есть такая возможость :)
Сцепить значение 4-х ячеек, игорируя пустые
 
=ЕСЛИ(здесь="";"";здесь&",")
и так же для оставшихся трех.
Проверка с помощью УФ нескольких масок на содержание в строке
 
Цитата
Ігор Гончаренко написал: что при наличии в ячейке слова витязь формула посчитатет, что там есть витя и подсветит ее
Тоже неплохо звучит - витязь Витя... Я бы принял это за правильное исключение и не считал ошибкой :)
Проверка с помощью УФ нескольких масок на содержание в строке
 
Э, аккуратнее!!! "Витя" не может быть ошибкой! :)

=ПОИСК("витя";$A2&"витя")<ДЛСТР($A2)
Петю добавить.
Если значений много, закинуть их в именованный диапазон
Удаление определенных слов из ячеек
 
Может не быть "№", но обязательно есть "на право"
Может не быть "на право", но обязательно есть "№"
Эти правила всегда выполняются? Если нет - как еще можо определить наличие или отсутствие заменяемого фрагмента?

Если  вмето "на право" есть только  "на" - удалять его или дополнить?
Проверка с помощью УФ нескольких масок на содержание в строке
 
Не, основная проблема - нет примера :)
Копировать и заменить по * (звездочке)
 
А ссылки? А в теме ответ показать?
(решение есть)
Копировать и заменить по * (звездочке)
 
Нужно самостоятеьно давать ссылки на темы-дубли, размещенные на других ресурсах.
Пример Вы и здесь не показываете.

В этой теме так и не показали решение...
Удалить определенный последний символ (если он есть)
 
=ЕСЛИ(ПРАВБ(A2)=",";ЛЕВБ(A2;ДЛСТР(A2)-1;A2)
Сбор данных с листов, Сбор данных с разных листов для получения общей "картинки"
 
ГДВ, Вы рассказали о листах, но постеснялись раскрыть задачу. Ее нужно описывать в сообщении.
Назвние темы тоже общее, не отражает проблему.
Записать в переменную код из середины текста
 
Код
sStr = "78И100"
sCode = Mid$(sStr,3,2)
Накопительные ячейки
 
У нас не получается увидеть столбцы G, I и тл
У Вас не получается ознакомиться с правилами форума. Предложите название темы. Модераторы заменят.

Кстати, что такое "тл"?
Условное форматирование ячеек, адреса которых указаны в других ячейках
 
Но Вы же просили определять не по одной ячейке.  Я понял - все ячейки,  в которых есть ссылка.
Импорт примечаний и исправлений из Word в Excel
 
Понимаете,  но все равно нарушаете...
Условное форматирование ячеек, адреса которых указаны в других ячейках
 
По-моему, никак.
Закладка Формулы-Зависимые ячейки - стрелочки не помокут?
Собирать данные из закрытых книг в зависимости от имени графы ("умения"). Путь к книгам указан в ячейках, ДВССЫЛ не работает с закрытыми книгами
 
Если путь к файлам формируется из текстовых значений - формулами никак.
[ Закрыто] Excel, разбивка
 
А еще нормально задачу описать.
Закрашивание ячейки при заполнении
 
Наипростейший ответ - смотрите условное форматирование
Удалить три строки через одну, Удаление строк
 
В свободном столбце:
=ОСТАТ(СТРОКА(A1);4)=0
Установить фильтр, оставить видимыми ЛОЖЬ. Выделить строки, удалить. Раскрыть фильтр. Удалить оставшиеся формулы.
Как сделать, чтобы все файлы Excel открывались и закрывались "одним блоком"?
 
Zasypich, ну,  если бы цитаты давали хоть какую- то информацию...  Зачем это горе-цитирование? Можно обратиться по имени,  этого вполне достаточно.  Да и ответить можно было в одном сообщении.  Не заметили -  вернулись и дополнили.
Прошу исправить
[ Закрыто] поиск и замена, формула поиска ячейки и подставления ее значения.
 
предложите название темы. Модераторы заменят.
О файле-примере правила форума тоже пишут.
VBA добавить строку по условию., Как можно добавить строку из текстбоксов в userform?
 
В картинку строка не вставится. В картинке макросы не работают.
Цитата
как быть?  
читать
Макрос фильтр
 
Сначала автор вернется в свои сообщения, оформит код с помощью кнопки <...>, предложит назвние темы согласно правил форума. После того, как модераторы переименуют тему, сообщения с помощью откроются.
Отображение с помощью формул ВПР, ИНДЕКС и ПОИСКПОЗ значений по условию, Получается отобразить первое совпадающее значение, но как отобразить все последующие?
 
Название темы не отражает задачу. Общее и размытое.
Если не предложите новое название, придется помогающемунапрягаться.
Roman77, на форуме такая договоренность - или воздерживаетесь от помощи при наличии нарушения в теме, или сами предлагаете название.
Избушка формулистов-3, не для вопросов, но для формульных задач
 
Zasypich, от Вас ждут решения.
Потом избушка будет почищена, намусорили тут с подачи Zasypich
Страницы: 1 2 3 4 5 6 7 8 9 10 11 ... 1325 След.
Наверх