Поиск  Пользователи  Правила 
Закрыть
Логин:
Пароль:
Забыли свой пароль?
Регистрация
Войти
 
Выбрать дату в календареВыбрать дату в календаре

Страницы: 1 2 3 4 5 6 7 8 9 10 11 ... 1299 След.
Перенос слов в определенное место внутри ячейки
 
Присмотрелся. Вопрос остался.
Цитата
Fsociety_ написал: ну там перенесено, присмотритесь внимательнее в примеру с до и после)
Цитата
эти слова в ячейке в середине предложения или в конце и их нужно перенести вперед предложения
checkbox скрыть строку и отобразить слово в ячейки и обратно
 
Код
Private Sub CheckBox1_Click()
    Rows(3).Hidden = Not CheckBox1
    
    If CheckBox1.Value = True Then
        Range("A1").Value = "ñòîèò"
    Else
        Range("A1").ClearContents
    End If
End Sub
Приравнивание части массива другому массиву без цикла
 
Вместо того, чтобы показать пример, уже 16 сообщений в пустоту...
Приравнивание части массива другому массиву без цикла
 
Если разовая операция, зачем массив?
Код
Application.GeoMean(Range("A1:A100"))
excel PQ интерфейс, не открывается редактирование запроса power query
 
Правила форума, о назвнии темы. Предлагайте новое, Модераторы заменят.
Суммирование при ИНДЕКС и ПОИСКПОЗ
 
Помощники, где в Ваших решениях функции, которые просил автор темы?

Автору: ознакомьтесь с правилами и предложите название темы ПО ЗАДАЧЕ. Модераторы заменят.
Подсчитать ранг регионов в соответствии с адресами
 
Покажите нужный результат
Перенос слов в определенное место внутри ячейки
 
Цитата
vikttur написал: Почему не перенести
Опечатка.
Почему не перенесли? Ведь эти слова есть в перечне.
Автоматически заполняемая форма по условию
 
Вопрос не по теме
Перенос слов в определенное место внутри ячейки
 
Я уточнял задачу. Не мне, так другим помощникам пригодится.
И Вы не ответили на первый вопрос.
Перенос слов в определенное место внутри ячейки
 
Почему не перенести Анастасию или Григория в последнем предложении?
Если в текте несколько нужных слов - как тогда?
Минимальное значение > 0 отдельных ячеек одной строки
 
Немассивна, некритична к изменению количества промежуточных столбцов:
=НАИБОЛЬШИЙ((A1;C1;E1;H1;L1);СЧЁТ(1/ИНДЕКС((A1;C1;E1;H1;L1);;;Ч(ИНДЕКС({1;2;3;4;5};)))))

И еще одна нашлась:
=НАИМЕНЬШИЙ((A1;C1;E1;H1;K1);ЧАСТОТА((A1;C1;E1;H1;K1);0)+1)
Здесь небольшая хитрость.
ЧАСТОТА((A1;C1;E1;H1;K1);0) - массив из двух значений: количество нулей и положительных чисел
Результат работы целой формулы - два наименьших значения  >0, в ячейке отображается меньшее. Но такая "хитрость" может боком вылезти при использовании результата для дальнейших вычислений.
Полностью корректная (с получением первого значения массива):
=НАИМЕНЬШИЙ((A1;C1;E1;H1;K1);ИНДЕКС(ЧАСТОТА((A1;C1;E1;H1;K1);0);1)+1)
69 знаков

Надо было в Избушке размещать )
Подсчитать ранг регионов в соответствии с адресами
 
При чем здесь ранжирование? Счет двух текстовых значений в диапазоне от начала до текущей строки:
=ЕСЛИ(Таблица1[@Регион]="";"";СЧЁТЕСЛИ($B$3:B4;Таблица1[@Регион]))
Или я не так понял? Но с результатом совпадает.
Минимальное значение > 0 отдельных ячеек одной строки
 
PerfectVam, не нужно ломать двоичное число :)
=МИН(ЕСЛИ({101010010001};ЕСЛИ(A1:L1>0;A1:L1)))
Ерунду написал. Так не работает.
Минимальное значение > 0 отдельных ячеек одной строки
 
А я-то думал, действительно цвет... )

Цитата
bedvit написал: так можно только с неразрывным диапазоном.
В примере неразрывный диапазон в строке, но между нужными столбцам разрывы. Формула должна работать как формула массива. В масиве констант условии единицами указаны нужные столбцы

Немассивно:
=МИН(ЕСЛИ(ИНДЕКС(A1:L1;Ч(ИНДЕКС({1;3;5;8;12};)))>0;ИНДЕКС(A1:L1;Ч(ИНДЕКС({1;3;5;8;12};)))))
=НАИБОЛЬШИЙ(ИНДЕКС(A1:L1;Ч(ИНДЕКС({1;3;5;8;12};)));СЧЁТ(1/ИНДЕКС(A1:L1;Ч(ИНДЕКС({1;3;5;8;12};)))))

То же, летуче:
=МИН(ЕСЛИ(Ч(СМЕЩ(A1;;{0;2;4;7;11}))>0;Ч(СМЕЩ(A1;;{0;2;4;7;11}))))
=НАИБОЛЬШИЙ(Ч(СМЕЩ(A1;;{0;2;4;7;11}));СЧЁТ(1/Ч(СМЕЩ(A1;;{0;2;4;7;11}))))
Минимальное значение > 0 отдельных ячеек одной строки
 
Цитата
[Критерий] цвет
Формулы какого офиса цвет видят? В 10 не видят.
Минимальное значение > 0 отдельных ячеек одной строки
 
Цитата
Сергей написал: я с елефона
Оно и понятно - связь еле-еле :)
Минимальное значение > 0 отдельных ячеек одной строки
 
Какой критерий "нужности" столбцов? Минимальные находить построчно?
Группировка
 
Правила форума, о названии темы. предлагайте новое. Модераторы заменят
СКРИПТ ПРОДАЖ, Необходимо сделать скрипт продаж
 
Что значит "выдающий по строчкам"? Задача, которую Вы решаете, какая?

В первой строке отображение значения выделенной ячейки - так?
Или:
Отображение в первой строке следующего шага скрипта продаж
Произвольное количество символов в ячейке
 
Название темы нужно поменять. Что значит "произвольное количество"? Проблему не отражает.
Предлагайте. Модераторы заменят
СКРИПТ ПРОДАЖ, Необходимо сделать скрипт продаж
 
Strizh, сообщение скрыто. Или предложите сами название темы, или ждем автора
СКРИПТ ПРОДАЖ, Необходимо сделать скрипт продаж
 
Название темы должно отражать суть проблемы. Если вся работа представляет проблему - есть раздел платных заказов.
Поиск части наименования и возврат необходимого значения
 
olga-optrans, читайте личку
Функция СУММЕСЛИМН принимает буквы за цифры, вопрос касательно ошибки в функции СУММЕСЛИМН
 
По задаче формулы есть, аж три. Но кто их тут будет искать?
Преобразовать таблицу: месяцы из строки перенести в столбец, Месяцы должны идти друг за другом вертикально
 
Так трудно было самому  взять часть текста из сообщения...
Функция СУММЕСЛИМН принимает буквы за цифры, вопрос касательно ошибки в функции СУММЕСЛИМН
 
Цитата
=СУММЕСЛИМН(B6:AF6;B5:AF5;B3;B6:AF6;"<"&C3)
Функция работает правильно. Суммирует под D1 значения, которые меньше 10,5.  Результат - 25,5

Цитата
При написании формулы во время поиска например значения которое больше 10,5
В СУММЕСЛИМН нет такого. Если же условие изменить на >, то см. ответ выше. Ранг букв выше ранга числовых значений. Для такого суммирования функция не подходит.

У Вас есть СВОЯ ЗАДАЧА. Забудьте о функциях и в нескольких словах расскажите, чего пытаетесь получить. Это и будет название новой темы.
Поиск пути на двумерном пространстве, Алгоритм
 
Решение в Excel. Кому-то еще может помочь. Перенес в  основной раздел.
Поиск пути на двумерном пространстве, Алгоритм
 
Почему в курилке?
Заменить диапазон одним числом
 
"????"&"-" = "????-"
Страницы: 1 2 3 4 5 6 7 8 9 10 11 ... 1299 След.
Наверх