Поиск  Пользователи  Правила 
Закрыть
Логин:
Пароль:
Забыли свой пароль?
Регистрация
Войти
 
Выбрать дату в календареВыбрать дату в календаре

Страницы: 1 2 3 4 5 6 7 8 9 10 11 ... 73 След.
Отражение дня недели в дате согласно календарю
 
Нужно поменять числовой формат. См. файл
KL
Преобразование таблицы (из нескольких больших в кучу маленьких)
 
Может вот это подойдёт? http://www.rondebruin.nl/win/s3/win006_4.htm
KL
Формула выбора минимального/максимального значения по условию
 
vikttur, так тема у меня стояла с оповещением :) сразу ящик забило.
KL
Формула выбора минимального/максимального значения по условию
 
Может замкнутая ссылка или файл в режиме ручного пересчета? Нет ли на статусной панели слева чего-то типа Calculate?
KL
Подсчёт значений, ПРОМЕЖУТОЧНЫЕ.ИТОГИ
 
Вариант: =СУММПРОИЗВ(ПРОМЕЖУТОЧНЫЕ.ИТОГИ(3;СМЕЩ(A2;СТРОКА(A2:A44)-СТРОКА(A2);))*(B2:B44="+"))
Изменено: KL - 25 Май 2016 02:36:28
KL
Подсчет суммы в зависимости от текста и значений во втором столбце
 
Варианты:
ФормулаВводДлина
=СУММПРОИЗВ((B2:B12=0)*(A2:A12={"A";"B";"C"})*{4;3;2})+СЧЁТЕСЛИ(B2:B12;">0")не массив76
=СУММ((ВЫБОР(ПОИСКПОЗ(A2:A12;{"A";"B";"C"});4;3;2))^(B2:B12=0))массив63
=СУММ(МУМНОЖ(--(A2:A12={"A";"B";"C"});{4;3;2})^(B2:B12=0))массив58
=СУММПРОИЗВ((A2:A12={"A";"B";"C"})*{4;3;2}^(B2:B12=0))не массив54
=СУММ((5-ПОИСКПОЗ(A2:A12;A2:A12;))^(B2:B12=0))массив46
KL
Вывод уникальных значений из списка
 
с доп столбцом (тяжелая)
KL
Вывод уникальных значений из списка
 
Это функция СЧЁТЕСЛИ :)
Изменено: KL - 24 Май 2016 02:04:31
KL
Теоретический вопрос что лучше большие формулы или вспомогательные ячейки?
 
более того - имена пересчитываются столько раз, сколько они повторяются в каждой формуле :)
KL
Какие комплектующие ПК влеяют на скорость обработки данных в Таблице
 
Тройное условие лучше заменить на 3 столбца. Попробуйте конкатенацию в четвертом столбце (массив поиска и условие, оба с каким-нибудь делимитером) и функцию ПОИСКПОЗ()

Например: =ПОИСКПОЗ("American"&"|"&$C$1&"|"&$B$1;Opt!$D2&"|"&Opt!$H2&"|"&Opt!$G2;0)
Изменено: KL - 19 Май 2016 13:29:09
KL
Теоретический вопрос что лучше большие формулы или вспомогательные ячейки?
 
будет
KL
Какие комплектующие ПК влеяют на скорость обработки данных в Таблице
 
А время на сам sql-запрос учитывали? И еще: проверяли на летучесть? Летучесть возникает при использовании летучих функций либо при превышении лимита зависимостей (обычно происходит при множественных операциях с большими диапазонами). Потом еще нужно смотреть, что за формулы и что за решение с доп. столбцом :)
KL
Oпределение таблицы по значению в норке
 
Используйте функцию ВЫБОР() для выбора таблицы.
KL
VBA: метод Select Case, несколько условий
 
Код
Select Case True
    Case t7Arr(t, 4) = "R" And bArr(f,4) <> "ОТС"
KL
Как в сводной таблице сделать так, чтобы промежуточные итоги не суммировали бы свои составляющие, а рассчитывались бы самостоятельно
 
Так: берете еще раз то поле, по которому проценты (Дельта, сумма) и меняете его представление как на картинке
KL
Как макросом удалить макрос с листа и сохранить?
 
Александр Сергеевич, на это уйдет две бесплатных минуты.
Но мотивы данной темы мне не близки т.ч. я отчалил :)
KL
Учет праздничных дней в уже существующей формуле
 
Но у нас с gling (да и с вами, хоть и в меньшей степени) явно считает по-разному - результаты-то не совпадают ;) Советую досконально проверить.
Изменено: KL - 26 Фев 2016 19:10:47
KL
Как макросом удалить макрос с листа и сохранить?
 
Цитата
ultraman написал: На данный файл то останется
если в директории то Kill :)

Код
Sub test()
    Kill "C:\Users\User\Desktop\Book1.xlsx"
End Sub
Изменено: KL - 26 Фев 2016 19:05:44
KL
Как макросом удалить макрос с листа и сохранить?
 
Способ предложенный Александр Сергеевич несколько проще, но встает проблема удаления оригинала. Хорошо если он в директории пользователя, а что если в e-mail сообщении или winzip :) Выбранный же вами способ защиты вашего ноу-хау, тоже имеет серьезный недостаток - вам надо попросить потенциального нарушителя, включить доверие к манипуляциям с проектом, т.к. по умолчанию стоит недоверие :)
Вообще надежного способа нет, тем более в VBA.
KL
Математический знак в формулу СУММПРОИЗВ из ячейки
 
Александр Сергеевич, а как это может помочь? Они же возвращают строку и число  соответственно :) все равно вернемся к развилке с конкатенацией и условной конструкцией. Нет?
Изменено: KL - 26 Фев 2016 18:47:06
KL
Математический знак в формулу СУММПРОИЗВ из ячейки
 
=ВЫБОР(ПОИСКПОЗ(A1;{">";">=";"=";"<=";"<";"<>"};0);СУММПРОИЗВ(--'1'!U10:U28;--('1'!S10:S28>E25));СУММПРОИЗВ(--'1'!U10:U28;--('1'!S10:S28>=E25));СУММПРОИЗВ(--'1'!U10:U28;--('1'!S10:S28=E25));СУММПРОИЗВ(--'1'!U10:U28;--('1'!S10:S28<=E25));СУММПРОИЗВ(--'1'!U10:U28;--('1'!S10:S28<E25));СУММПРОИЗВ(--'1'!U10:U28;--('1'!S10:S28<>E25)))
KL
Математический знак в формулу СУММПРОИЗВ из ячейки
 
Конкатенация тут наверняка невозможна. Любое использование ЕСЛИ() или ВЫБОР() с одним из параметров СУММПРОИЗВ() скорее всего приведет к массивному вводу (Ctrl+Shift+Enter) :)
Изменено: KL - 26 Фев 2016 18:05:49
KL
Математический знак в формулу СУММПРОИЗВ из ячейки
 
ОК. Тогда да :) Это один из тех немногих случаев, а в примере этого видно не было.
KL
Математический знак в формулу СУММПРОИЗВ из ячейки
 
=СУММЕСЛИ('1'!S10:S28;A1&E25;'1'!U10:U28)

Во всех смыслах лучше :) Бинарное использование СУММПРОИЗВ() практически - дело прошлого (за весьма редкими исключениями, включая совместимость с MSO11). Оно было нужно, чтобы восполнить отсутствие СУММЕСЛИМН() и СЧЁТСЛИМН()
KL
Учет праздничных дней в уже существующей формуле
 
Не до конца понимаю логику оригинала, но может так? см. вложение
KL
Ссылка в ячейке на имя листа другой книги, вывод значения ячеек
 
Хочу напомнить о том, что ДВССЫЛ() видит данные в другой книге только, когда та открыта. Родного решения функцией без макросов нет :)
KL
Сложение ячеек с несколькими условиями, одно из условий: просматривать ячейку на ее наличие в диапазоне.
 
Вот вам БДСУММ. Рекомендую почитать справку :)
KL
Необходимы уникальные строки в массиве из 13 имен и 13 фамилий
 
Это верно :)
KL
Oпределение таблицы по значению в норке
 
Цитата
Arnoldas написал: формула принимает значение и ток да кок да оно неправленое (нету такой таблицы)

пардон, поменяйте эту часть добавив третий параметр - 0: MATCH(G3;{"Table1","Table2","Table3"};0)
KL
Необходимы уникальные строки в массиве из 13 имен и 13 фамилий
 
Если б знать заранее, что:

- эстетика превыше всего
- задача одноразовая
- ручная доработка допустима

я бы сразу предложил подобное примитивное решение, а не изучал бы учебники по комбинаторике :)
KL
Страницы: 1 2 3 4 5 6 7 8 9 10 11 ... 73 След.
Наверх